• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 271
  • Last Modified:

vi adding ~ after filename

I am using Mandrake Linux 9.  I have vim installed.  For some reason when I edit a pre-existing file, it (when I save and exit) creates a duplicate file with the same name, but with a ~ (tilda) at the end (Ex. "filename.html~").  

This is annoying because I dont want a ton of "filename.html~" files in my apache document root.  

I suspect it is something with the way vim is configured, but I do not know, any suggestions?

Matthew Brainard
brainarm@insight.rr.com
0
brainarm38802
Asked:
brainarm38802
  • 3
1 Solution
 
akshayxxCommented:
it is for ur benefit only .. it is the bakup file .. if ur system crashes while ur in the middle of editing.. u can retrieve the old file from the backed up file..
0
 
akshayxxCommented:
0
 
akshayxxCommented:
read all the options ..
backup
backupcopy
backupdir
backupnext
backupskip
0
 
brainarm38802Author Commented:
Your answer wasnt direct... but from what you gave me, I was able to turn it off.  

For future reference for anyone else:
if you edit the /usr/share/vim/vimrc file, you can disable backup if you want.  
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now