• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 161
  • Last Modified:

help needed

hello all

we have a 2 pc lan and this is the problem, they share an internet connection fine, they see themselves in network neighbourhood, but not each other.

the machines are set up thus: 1x pc running win98se the other running dual boot 98se and xp. both pc's are set on automatic ip addressing. both pcs' see themselves in network neighbourhood, and we share the internet over a programme called allaboard. since the internet share is fine, i cannot see why the pc's cannot see each other. file and print sharing is enabled, and both pc's are firewalled by zonealarm pro. both firewalls have the respective ip addreses set as trusted.

i can only imagine it has something to do with the way allaboard works, as it sets up a virtual lan adress, could that be it? anyway, as you can imagine im a rank beginner with networking so all help gratefully recieved!

regards, mal.
0
malfisher
Asked:
malfisher
1 Solution
 
jlindqCommented:
For the machines to see eachother they have to see each other's broadcasts. Add the entire network they are on as a trusted network. That should include the broadcast address. If this does not work, try shutting off ZA (while not connected to the Internet) to verify if there is a problem other than blocking from the ZA.
0
 
malfisherAuthor Commented:
how do i add the entire network? i know how to add an ip address ect, and it gives the alternative of range and subnet. can you explain a little more please?
0
 
Punker51Commented:
try to set a local ip adress to both of your machines.

Something like 192.168.100.0 and 192.168.100.1

try to ping Computer A from B and vice-versa
0
The Lifecycle Approach to Managing Security Policy

Managing application connectivity and security policies can be achieved more effectively when following a framework that automates repeatable processes and ensures that the right activities are performed in the right order.

 
publicCommented:
x.x.x.0 is the network address, and cannot be used by individual machines. Use 192.168.100.10, 192.168.100.11 or something like that.
To use automatic ip, you need a dhcp server on your network. Otherwise you must assign static ip, and a gateway if you want internet access.
0
 
Count_OnnetCommented:
Without knowing more about Allaboard (it's past my bedtime, so I ain't lookin' it up <g>), I'd make sure the computers are in the same workgroup.  (I only bring it up because you didn't mention checking that.)  In Win98 right-click "Network Neighborhood", click properties and check the "Identification" tab.  In WinXP right-click "My Computer", click "Properties", and look under "Computer Name".

Hope it helps!
0
 
jlindqCommented:
It's been a while since I ran win98, so bear with me.

First you need to find the IP network and netmask.

If you don't know it, you can find it through "winipcfg" (run from a command prompt) or in the Network properties in the Control Panel. The netmask is right there, but to find the network address, you can start with the IP address.

So, to calculate the IP network from an IP-address/netmask is not terribly hard, but there are other places that is explained in detail. I found an online application for it at http://www.a-plus.net/Useful_Netmask.htm. Just put your address and netmask there and it will tell you the network.

Armed with the network and netmask, go into ZoneAlarm Pro configuration, Security, Advanced, Local Zone Contents, press Add and choose Subnet. Fill in a comment, the network and the netmask. Done!
0
 
malfisherAuthor Commented:
jlindq you get the points for helping me out with the zone alarm thing.

anyway i got it working yesterday this was the solution:
uninstalled allaboard.
assigned 10.x.x.1 to the server
assigned 10.x.x.2 to the client
subnet mask 255.255.255.0
added the ip's and the subnet to zonealarm, that established the working lan.
reinstalled allaboard and allowed it to do its own thing. zonealarm picked up on allaboards own virtual addresses, i authorized them and hey presto, it all worked.

mal.
0
 
spider-moeCommented:
My friend had the same problem but was using Symantec's Personal Firewall.

1. You have to try and disable the firewall to make sure that is the problem.

2. If the firewall is the problem then adding IP addresses, ranges, or subnets as the trusted network might not be enough since Win98 uses NetBios (a differnt protocol than TCP/IP) to share files. Check and see if the firewall is blocking that protocol.

3. If disabling the firewalls does not solve the problem and you have netbeui installed on both systems, then check to make sure that the Workgroup name on both systems is in the exactly the same (its case sensitive, so put them both in upper case)
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now