?
Solved

blank screen with VNC and Redhat 8.0

Posted on 2003-03-07
11
Medium Priority
?
473 Views
Last Modified: 2013-12-15
Hello there,

I have just recently done a fresh install of Redhat 8.0. Previously I had been running 7.3 in which I was using the VNC program with no problems whatsoever.
The server machine was obviously my linux box, whilst the client machine was my winxp laptop.

However, upon freshly installing Redhat 8.0 and going about the same way as before (setting vncserver up as a service and then starting it at the bash prompt by typing: vncserver), when I went to start my client machine, all I get is a grey screen. The VNC website calls it the 'rootweave' screen. The vnc website said to look in the log file for that particular session for errors. However I have no errors showing up!!
Except for , it says the following:
gnome-session: you're already running a session manager.

Would that have something to do with it? I am running kDE...

Thanks,

Tim.
0
Comment
Question by:tomcrom
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 3

Expert Comment

by:Flash828
ID: 8100323
try "switchdesk-gnome" and see if that works.  Are you running X while loading the vncserver (although I dont think that should matter).  
0
 

Expert Comment

by:zeus11
ID: 8106664
type "vncserver n " where n is the display number, then try to connect by "vncviewer ip:n"
0
 
LVL 2

Accepted Solution

by:
dlusty earned 220 total points
ID: 8142257
in ~/.vnc/xstartup you need:

unset SESSION_MANAGER
xrdb $HOME/.Xresources
exec gnome session

if you want the vncserver at startup the open /etc/rc.local and enter the line

su -l root -c vncserver

if you want it run as root obviously :o)

this worked for me, I now have a gnome session on VNC from startup. hope this helped
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 2

Expert Comment

by:dlusty
ID: 8142263
oh bugger you said you're running KDE :O( silly me! change the "exec gnome-session" to "exec kde" or whatever the command to start kde is :o)
0
 

Author Comment

by:tomcrom
ID: 8144266
thanks dlusty!

I figured out that you need to put that unset SESSION MANAGER in myself a couple of days ago.. I wonder why?!..

Anyways, I have had trouble getting kde to work - only Gnome has been working, which isn't really the end of hte world..

But you've shown me how!!

Cheers.
0
 
LVL 2

Expert Comment

by:dlusty
ID: 8145118
the session manager variable is only for gnome, it sets whether there is a running session or not because gnome only supports 1 session per user. it ahouldn't be needed to start kde at all, but with kde you should use suse or similar as redhat it designed around gnome so the tools won;t look as good.

as for the file try startkde, just looked it up and seems to be the answer :o)

so
exec startkde
instead of
exec gnome-session

0
 
LVL 2

Expert Comment

by:dlusty
ID: 8233697
did you get this working?
0
 

Expert Comment

by:CleanupPing
ID: 9076650
tomcrom:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
LVL 2

Expert Comment

by:dlusty
ID: 9077215
I'd like to know if you got this working :o) also I think it looks like I helped so do I get the points?
0

Featured Post

DFW AZURE MEETUP TONIGHT FRI 6PM

We will be discussing what Azure Stack is, how does it fit into the suit of offerings that Azure has currently, and where can it fit into your organizations technology stack. We will also be discussing limitations of the platform while covering various applicable scenarios.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month15 days, 4 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question