USB port will not recognize camera as device

I have a Compaq 5600 with windows ME.  Digital Camera is a Kodak DX4900.  I have installed and uninstalled software from camera mfg.  Is had worked previously.  The software is there, however, it cannot find a the camera.  I have tried transferring pictures from both the dock and directly to the camera from both front USB ports.  I have updated the BIOS with a download from Compaq.  I have reinstalled the USB drivers by uninstalling the USB ports and having the computer reinstall them.  When I check system hardware it says divice is working properly.  However, one USB port listed has a green circle with a question mark.  I have tried to install new drivers, however,  it says the best driver is being used.  I cannot choose another driver because it requests a Windows ME disc. which I don't have because the
computer came with the ME installed from the factory.  I have tried reverting the computer back to an earlier date, when the camera did transfer pictures, to no avail.  

I have also tried downloading the software from the Kodak web site.

While I was "investigating" I noticed that my file MSPaint.exe, is missing from my computer.  I don't believe that has anything to do with the USB, but I would like to know how to get that back.  It is not listed under Accessories in Windows options.   Thank you
Who is Participating?
dbruntonConnect With a Mentor Commented:
>>> I don't have because the computer came with the ME installed from the factory.

There should have been some disks one way or the other.  Look in your computer for a folder that may contain the setup files for ME.  This should be a folder with a large number of CAB files.  The factory or installer may have done this.

I have seen usb peripherals fail to be recognized properly due to bad usb cables. Sometimes they will show as unknown like you say with a green circle w/question mark. I think you should try another cable.
To get paint back use add remove programs in the controll pannel in the control panel. Hit Windows Components Accesories and click on Pain and with your ME cd add it again. You may not need the CD though.

Usually the computer companies give you the OS's cd for backup use. Usually you can call them for a CD.

For the camera try another camera. Also make sure the camera is on in the Docking station. If that doesn't work go with the bad cable idea.

I'd like to help some except you haven't provided enough information about the system properties device issue--the one with the exclamation mark.

Either way,  you will need to get a copy of Windows ME in order to solve the problem.

A couple questions.

1)  What is the error message text that you get when you bring up the properties for the device with the exclamation mark?  Word it precisely.

2)  You say you have 2 usb devices and 2 roots?  You didn't explain that enough, so if you could clarify that would help.

I am assuming you are saying that, due to a standard piece of hardware (the motherboard) you have 2 usb connectors near the keyboard/mouse connectors.  Given this is probably true, in the device manager (system properties) there would be 4 entries  under the universal serial bus section.  Two of those are the devices and two of those are hub roots.

Is it the device itself that has the error or is it one of the hub roots?

If it is the hub root, is it only one of them?  If it is one of the devices, is the 2nd hub root missing?

Get the windows ME disc and report back that info and we can resolve the issue for you.

Also, I would hope that once you do get it resolved you'd come here and tell everyone exactly how it was resolved.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.