?
Solved

USB Mass Storage Driver

Posted on 2003-03-09
9
Medium Priority
?
324,788 Views
Last Modified: 2012-08-13
I have purchased a USB Mass Storage device which utalizes a standard 2.5" laptop hard drive. The hard drive is full functional and works fine when I plug it into a motherboard directly. The USB adaptor case I purchased came with drivers for Win 98 or older. It says in the literature that it does not need a driver for later versions of Windows. When I first got the case, it hooked up with no problem. The drive was found and showed up as a mass storage device. This worked for a couple of days. Since then, when I plug it in, the auto detect, on any machine I use, sats it has found an unidentified USB device. It no longer is recognized as a mass storage device. What could  be the problem and can I use a generic driver when installing the device?

The drive enclosure I purchased can be seen at:

http://www.cooldrives.com/poc25porusba.html

Any help would be appriciated.

James
0
Comment
Question by:jcalaway
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +3
9 Comments
 
LVL 4

Expert Comment

by:kannabis
ID: 8099146
What operating system are you using?  Some flavours of windows will have drivers that others don't.  For example Win98 has less drivers included than Win98 SE, which has less drivers than ME etc,.

That still doesn't explain why it worked for a bit and then stopped.  By the looks of that thing, you can see the chip on the USB controller through the plastic cover.  Can you make out any names or model numbers on it?  This might help getting a "generic" driver since there doesn't seem to be any manufacturer name on that enclosure.

0
 

Author Comment

by:jcalaway
ID: 8099221
I have tried using it with both Windows XP and 2000. I am able to see the chip on the board, but there are no names. There is a model number though. The model numbers on the chip are GL811USB. In addition, there in a number of 0239MF4FW02-17 on the chip.

A bit of additional back ground that might be of interest is before I noticed it would no longer work with the USB adaptor, I had hooked the drive up direct to a slave port in my machine and performed a scan and defragment on it. When I put it back in the USB enclosure, it would no longer work. Could it have done something to the drive to make it invisible to the USB detector?

James
0
 
LVL 4

Accepted Solution

by:
kannabis earned 200 total points
ID: 8100755
From what you said, it sounds like the system wants a driver for the USB controller, the hard drive comes after, so I doubt formatting it did something.

That controller is made by Genesis Logic, I didnt' see any driver on their website, but from a review of the product on some chinese site, it looks like it can use the NEC USB 2.0 driver.  The NEC driver is included in Windows XP SP1.  I got this info from the MSI website:

 NEC USB 2.0 Driver  
Support model  K7T266 Pro2-RU (MS-6380 Ver2.0), 845 Ultra-ARU (MS-6398)  
Description  
Add General ID: VEN_1033&DEV_00E0
-- Driver version: 2.0.3300.20300.
For K7T266 Pro2, this driver must be used together with BIOS Ver3.3 or after.

Note: For WinXP, please use Microsoft Windows Update to download driver from Microsoft or aquire the latest service pack
WinXP SP1 Download Website :
http://www.microsoft.com/windowsxp/pro/downloads/servicepacks/sp1/sp1lang.asp 
Date  2002-9-20  
Your System OS   Win98SE/ME(79KB) Win2000(7011KB)  

They have some drivers for Win2000 for a bunch of USB chips.
http://www.msi.com.tw/program/support/driver/dvr/spt_dvr_list.php

Check that out
0
WordPress Tutorial 4: Recommended Plugins

Now that you have WordPress installed, understand the interface, and know how to install new parts, let’s take a look at our recommended plugins.

 
LVL 11

Expert Comment

by:robert_marquardt
ID: 8101092
0
 
LVL 5

Expert Comment

by:meb_santoso
ID: 8109834
Err... the driver(s) indeed could be the problem, but also other x-factors, such as power supply. Did you plugged it in to the rear USB port or the front one ?

Let me rephrase: Rear USB ports =? the ones which are fixed to the motherboard soldered, no wires, etc..

Front / side USB ports => the ones (usually) glued to the chasis (the box), connected to the motherboard using cables. Well, it also could be at the rear side, and I am reffering to MSI's D-bracket's USB ports. (I think it's called D-Brackets...)

If you plugged it in to the front/side port, you might having the lack-of-power issue. Don't ask me why, but I know one thing for sure: my IOmega won't run if I plugged it in to the front / side / D-bracket port, but read & write smoothly if it is plugged in to the mobo's USB port.

Hope this helps.
0
 
LVL 11

Expert Comment

by:robert_marquardt
ID: 8110192
No, if the device does not get enough power from USB it gets disabled and will not show up at all.

A USB device is initially only allowed to draw 100 mA. It can ask the hub to provide 500 mA, but this can be denied by the hub.
A hub can be unpowered which means it has to live from the 500 mA it gets from its parent hub. It therefore cannot hand out 500 mA on its ports.
A powered hub need only to draw 100 mA from its parent hub and hands out its own power allowing 500 mA on its ports.


Best reask your question on http://www.usbman.com/forum
0
 
LVL 5

Expert Comment

by:meb_santoso
ID: 8110236
robert_marquardt : "No, if the device does not get enough power from USB it gets disabled and will not show up at all."

Well, Robert, I don't know about this, but my drive DID show up, but it's unaccessible. It is working now, connected to the rear port.
0
 

Expert Comment

by:sosilly
ID: 8473381
Downlaod a patch to fix your problem with gl811usb at:

http://www.mapower.com.tw/drivers/genesys/fixustor.zip
0
 

Expert Comment

by:raybay
ID: 13811879
Methinks you are not getting enough power to the unit. A poor quality or too lengthy USB cable can be the culprit, or anything else the pushes the 500Ma power requirement to its limit.  We have found many USB 2.0 cables that are marginal. Bent, crimped, or damaged ones also have troubles.  
I would try it on a powered, amplified hub to see if there is any difference, using a new, short USB cable.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

AWS Glacier is Amazons cheapest storage option and is their answer to a ‘Cold’ storage service.  Customers primarily use this service for archival purposes and storage of infrastructure backups.  Its unlimited storage potential and low storage cost …
How to update Firmware and Bios in Dell Equalogic PS6000 Arrays and Hard Disks firmware update.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question