Wni 2000 server DNS will not forward DNS request to ISP

I have a win 2000 server with DNS, DHCP etc.  My problem arises when I put my servers address first in the client DNS list.  It just hangs (will not go on Internet).  I got around this for a while because I only had win 98 clients so I just replaced the servers address in the DNS table with the one my ISP gave me (in DHCP).  However now that I am starting to get winXP clients It is a problem.  The login time is long 2-3 min usually and I suspect that it is because they can not find their name in the DNS.  It is there and the DNS self tests pass but becase I have set DHCP to give out the external DNS address it can not find it.  I tried setting the "forwarders" tab in DNS but it will not let me as it is a domain controler.  How can I get the win2K server to work properly and just have it as the DNS.  Somehow it must be told about the ISP's DNS so that when it fails to find it in its own table it goes out to the ISP's DNS.

Thanks
RTUTTLEAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pastorchicoCommented:
check you LMhost file for #include statement and notate it out with "'".  Your server is more than likely trying to use this worthless file to create a connection to the world.  If this include is there, it would have been put in manually and is no longer accurate.  The process of DNS requires to check this file before moving on.  In my exp, the problem you are referring to has been caused by this archaic WINS file.
0
BeermanCommented:
Your clients and servers should all point to your dns server as the primary dns server in network properties (via dhcp or static).  The forwarders tab should point to your isp dns servers.  There should be no reason the server wont let you do this unless your not an administrator.  Are you getting errors or permissions denied when setting the forwarders?
0
hongtaocCommented:
setup your dns w2k as the first dns;

and add the ip of isp servers in the forwards tab

if it still doesnt work, create a domain as root-servers.net, put the static root dns servers in it,
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

SimonL-UKCommented:
Your DNS servers will not let you set up forwarders because they think they are root servers.  To get round this, in DNS, delete the zone "."
Close DNS and re-open.  You can now enter your ISP's DNS servers.
Configure DHCP to give out your internal DNS server addresses to your clients.

Make sure that your clients are not using HOSTS or LMHOSTS files (unless your using archaic programs that require them).

XP sometimes take a while to login.  This is because of the way XP loads its drivers.  When XP boots, it will enable you to attempt to login without the network drivers being loaded (hence the hang which is caused by XP waiting for the device drivers to load).  You can fix this by following this link http://www.tweakxp.com/tweakxp/display.asp?id=1336

XP
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SimonL-UKCommented:
forgot to add to make sure WINS is configured properly and allow DNS to use WINS forward lookup which will help your legacy machines (9x).
0
RTUTTLEAuthor Commented:
Gave me some ideas but did not solve problem.  Deleted old Zone and added new one with Gateway address as DNS (works with manually configured clients same as before) Not using lmhosts, hosts, wins etc.  Additional concern that this solution also deleted all the clients that were in the old zone.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.