• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 729
  • Last Modified:

Messages awaiting directory lookup

Hi all, i have a slight problem with my exchange server.

The server is receiving messages and they are sitting in the  messages awaiting directory lookup queue.
I have set all the logging to maximum on the exchange transports side of things and the only warning error i get is Event ID: 6004 saying
The categorizer is unable to categorize messages due to a retryable error.

And thats it, i am lost, any ideas would be appreciated!
Regards
Sparky!
0
sparky1977
Asked:
sparky1977
1 Solution
 
pkerkhofCommented:
We have the same problem.
Restarting the SMTP solves the problem for that moment.
I suspect it has something to do with DNS-settings.

Peter
0
 
Mike_OrtonCommented:
Me too
0
 
BNettles73Commented:
Did you ever figure out what was wrong? I'm having this problem now ... http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_21073526.html ... any help would be much appreciated!

Thanks,
Brian
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
BNettles73Commented:
I resolved my issue by modifying the scan type of our AV software and the general config.

The VSAPI mode, which utilizes real-time scanning was causing an absorbent amount of resources to be utilized on the server, which caused messages to queue up in the messages awaiting directory lookups queue.

On another server where I had this issue, I found the AV software was setup by default to use reverse DNS on the SMTP scan ... I disabled this feature and everything worked fine.

The product I use is Sybari Antigen with ASM 8.0 ...  I changed the mode to ESE on our A/P Clusterered Servers and disabled the reverse DNS setting on our Internet Mail Servers.

From what I understand, the VSAPI mode for quite a few AV software programs causes all sorts of transport issues ...
0
 
BNettles73Commented:
Hard to imagine this question was open since 03/03 lol ... I didn't even realize that when I posted my response lol
0
 
moduloCommented:
PAQed with no points refunded (of 250)

modulo
Community Support Moderator
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now