?
Solved

samba server does not work

Posted on 2003-03-10
11
Medium Priority
?
228 Views
Last Modified: 2010-03-18
hi,
    i have linux 7.2(redhat)  and recently i installed the samba server .we have lan set up which connects 8 computers .now after installing samba although others can view my pc in the workgroup area in windows but nobody can can access it .i have created account for all the users in my pc but whenever others try to access my pc it shows an error tht it can't be accessed as u donot have permission to access it.
   so tht was my problem and i am sure experts out here can help me out.

     lokesh kumar
0
Comment
Question by:lokesh_kumar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 1

Expert Comment

by:-CrashOverride-
ID: 8104405
try installing the newest samba or if it does not work use the linux administrator
0
 

Accepted Solution

by:
miataman92 earned 172 total points
ID: 8106108
Make sure that you have the proper shares enabled. The version that I am running does not include a "default" share. You have to tell samba what directories or folders you want your users to have access too. That might explain why the can "see" the box but not be able to access it.
0
 

Expert Comment

by:JohnnyDog
ID: 8106587
first of all.  what version of winders you got runnin?  second, did you use the -a option or specify a password when you created these users?  are the users you created the same as the windows UID or linux UID or both?  did you remember /etc/init.d/smb start ?

--johnnydog
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 22

Assisted Solution

by:pjedmond
pjedmond earned 164 total points
ID: 8107560
Try adding this entry after creating 'mkdir /var/public', and 'chmod 777 /var/public'

[public]
      path = /var/public
      comment = Public Folder
      public = yes
      only guest = yes
      force directory mode = 777
      delete readonly = yes
      create mode = 777
      wide links = no
      force create mode = 777
      directory mode = 777

This is a folder readable/writable by everyone.

Now restart the samba server '/etc/init.d/smb restart'
And try browsing from windows.

Now for windows browsing from Linux:

First create a mount point 'mkdir /mnt/winshare'
Now mount the share:

mount -t smbfs -o username=myname,password=mypass //winpc/testshare /mnt/winshare

If DNS isn't set up for this pair then you will need to replace the 'winpc' with the appropriate ip address.

mount -t smbfs -o username=myname,password=mypass //192.168.0.5/testshare /mnt/winshare

You should then be able to browse the /mnt/winshare directory.
0
 
LVL 22

Expert Comment

by:pjedmond
ID: 8107593
If the above doesn't get things working, then I'm going to suggest that you are trying to browse with either a Windows 2000, or windows XP system - If so, then you need to create a machine account as well in the samba system. Ask for more help if this is the case.

Another common fault is that people forget to add samba passwords and accounts:

/etc/samba/smbpasswd

should have a single line for each user, along with the password hash!

man smbpasswd

if you haven't already added them.

Hope that the above helps
0
 

Author Comment

by:lokesh_kumar
ID: 8353094
sorry for replying so late.

 but i tried all the things u have told , i created /var /public directory and added the changes but it was of no and another new thing tht has come up is tht , i am also unable to bowse using nfs , others are  unable to mount the directories which i export from my system.

  tell me wht else can i do?

           lokesh
0
 

Assisted Solution

by:hiteshhit
hiteshhit earned 164 total points
ID: 8467207
Dear Lokesh,

I think this must be a problem of authentecation. You need to check wheather you are using Encrypted Password or not? If you are using Encrypted password than you need to touch smbpasswrd file(touch /etc/samba/smbpasswd) and need to creat smbpassword by commanding : smbpasswrd -a lokesh provide password and veryfiy it

If you are not using Encrypted Password than you need to modify registry of Windows Client.
Windows 95/98 : HLM\SYSTEM\CURRENT CONTROL SET\SERVICES\VxD\VNSETUP creat Dword key= EnablePlainTextPassword and keep value 1

The same problem I have faced in my system. What happen in your case is that once you enter use name and password it checkes to authentacate with Linux server but becasue of different encryption mode it gives you error stating that YOU DONT HAVE PREMISSION TO ACCESS the folder.  

Kindly revert incase it doesnt solve the problem.

Regards,

Hitesh
0
 
LVL 2

Expert Comment

by:mjdme
ID: 8580180
make sure smb.conf file is setup correctly
http://us4.samba.org/samba/ftp/docs/htmldocs/Samba-PDC-HOWTO.html

when connecting from your workstation u must use root and root password to auth.

edit your registry
http://www.wlug.org.nz/RequireSignOrSeal 

http://www.oreilly.com/catalog/samba/chapter/book/

also edit host and host allow file in samba and etc dir
0
 

Expert Comment

by:CleanupPing
ID: 9077694
lokesh_kumar:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

The Orion Papers

Are you interested in becoming an AWS Certified Solutions Architect?

Discover a new interactive way of training for the exam.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question