• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 229
  • Last Modified:

samba server does not work

hi,
    i have linux 7.2(redhat)  and recently i installed the samba server .we have lan set up which connects 8 computers .now after installing samba although others can view my pc in the workgroup area in windows but nobody can can access it .i have created account for all the users in my pc but whenever others try to access my pc it shows an error tht it can't be accessed as u donot have permission to access it.
   so tht was my problem and i am sure experts out here can help me out.

     lokesh kumar
0
lokesh_kumar
Asked:
lokesh_kumar
3 Solutions
 
-CrashOverride-Commented:
try installing the newest samba or if it does not work use the linux administrator
0
 
miataman92Commented:
Make sure that you have the proper shares enabled. The version that I am running does not include a "default" share. You have to tell samba what directories or folders you want your users to have access too. That might explain why the can "see" the box but not be able to access it.
0
 
JohnnyDogCommented:
first of all.  what version of winders you got runnin?  second, did you use the -a option or specify a password when you created these users?  are the users you created the same as the windows UID or linux UID or both?  did you remember /etc/init.d/smb start ?

--johnnydog
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
pjedmondCommented:
Try adding this entry after creating 'mkdir /var/public', and 'chmod 777 /var/public'

[public]
      path = /var/public
      comment = Public Folder
      public = yes
      only guest = yes
      force directory mode = 777
      delete readonly = yes
      create mode = 777
      wide links = no
      force create mode = 777
      directory mode = 777

This is a folder readable/writable by everyone.

Now restart the samba server '/etc/init.d/smb restart'
And try browsing from windows.

Now for windows browsing from Linux:

First create a mount point 'mkdir /mnt/winshare'
Now mount the share:

mount -t smbfs -o username=myname,password=mypass //winpc/testshare /mnt/winshare

If DNS isn't set up for this pair then you will need to replace the 'winpc' with the appropriate ip address.

mount -t smbfs -o username=myname,password=mypass //192.168.0.5/testshare /mnt/winshare

You should then be able to browse the /mnt/winshare directory.
0
 
pjedmondCommented:
If the above doesn't get things working, then I'm going to suggest that you are trying to browse with either a Windows 2000, or windows XP system - If so, then you need to create a machine account as well in the samba system. Ask for more help if this is the case.

Another common fault is that people forget to add samba passwords and accounts:

/etc/samba/smbpasswd

should have a single line for each user, along with the password hash!

man smbpasswd

if you haven't already added them.

Hope that the above helps
0
 
lokesh_kumarAuthor Commented:
sorry for replying so late.

 but i tried all the things u have told , i created /var /public directory and added the changes but it was of no and another new thing tht has come up is tht , i am also unable to bowse using nfs , others are  unable to mount the directories which i export from my system.

  tell me wht else can i do?

           lokesh
0
 
hiteshhitCommented:
Dear Lokesh,

I think this must be a problem of authentecation. You need to check wheather you are using Encrypted Password or not? If you are using Encrypted password than you need to touch smbpasswrd file(touch /etc/samba/smbpasswd) and need to creat smbpassword by commanding : smbpasswrd -a lokesh provide password and veryfiy it

If you are not using Encrypted Password than you need to modify registry of Windows Client.
Windows 95/98 : HLM\SYSTEM\CURRENT CONTROL SET\SERVICES\VxD\VNSETUP creat Dword key= EnablePlainTextPassword and keep value 1

The same problem I have faced in my system. What happen in your case is that once you enter use name and password it checkes to authentacate with Linux server but becasue of different encryption mode it gives you error stating that YOU DONT HAVE PREMISSION TO ACCESS the folder.  

Kindly revert incase it doesnt solve the problem.

Regards,

Hitesh
0
 
mjdmeCommented:
make sure smb.conf file is setup correctly
http://us4.samba.org/samba/ftp/docs/htmldocs/Samba-PDC-HOWTO.html

when connecting from your workstation u must use root and root password to auth.

edit your registry
http://www.wlug.org.nz/RequireSignOrSeal 

http://www.oreilly.com/catalog/samba/chapter/book/

also edit host and host allow file in samba and etc dir
0
 
CleanupPingCommented:
lokesh_kumar:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now