?
Solved

Mailscanner 3.13 on Debian

Posted on 2003-03-10
5
Medium Priority
?
330 Views
Last Modified: 2013-12-15
Hi,
I've installed the Debian package for Mailscanner 3.13. It's installed and using Exim as it's MTA. There is a lot of email that passes through this mailscanner. This has been running fine for a long time, but now for some reason when I start mailscanner, it takes up all the memory and takes about 5 minutes to scan two messages.

Does anyone know of a bug in mailscanner that would cause this? Or if there are any settings that might cause this? Or does anyone know if Mailscanner 4 works on Debian? Or if anyone else is using mailscanner at a site with LOTS of email, does it take up more then 100MB of memory?

Thanks for your help!
0
Comment
Question by:dankennedy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 15

Expert Comment

by:periwinkle
ID: 8104687
Did you upgrade spamassassin, at the same time, too?  I found that there was a problem with SpamAssassin 2.50 that was documented in the 'News' on the front page of the mailscanner.info site:

24/2/2003  SpamAssassin 2.50 was released a few days ago. Unfortunately there is a small bug in it which hits MailScanner really badly. I have made a small patch available which fixes it.

(download the patch at:

http://www.sng.ecs.soton.ac.uk/mailscanner/files/SA2.50.patch

)

To install it, do this:  

tar xzf Mail-SpamAssassin-2.50.tar.gz  
patch -p0 < SA2.50.patch  
cd Mail-SpamAssassin-2.50  
perl Makefile.PL  
make  
make test # This step is optional, but a good idea  
make install


I saw a similar problem when I used spamassasin (on RedHat) prior to patching it with mailscanner - if I didn't include spamassasin, the problem went away.

The news page claims that a 2.51 is coming out shortly, too.

If that isn't the issue, make certain that the logging is turned on in the MailScanner.conf file (/etc/MailScanner/MailScanner.conf ):

Syslog Facility = mail
Log Spam = yes

and then check the maillog (it's /var/log/maillog on RedHat - don't know if Debian is the same).  There may be a lot more information there!

0
 
LVL 2

Author Comment

by:dankennedy
ID: 8104804
I'm still using Spamassassin V2.20. The weird part is that everything was working fine, and nothing has changed as far as I know. Also, sometimes when I restart mailscanner it will run fine (using 8MB of RAM and passing messages through right away). And then you'll watch it, and about ten minutes later it will just start using more and more RAM until it gets to about 145MB. It is still running, and passing messages through, but it's just REALLY slow.

And in my config file

Spam Checks = no
Virus scanning = no

So all it really should be doing it passing it through.
0
 
LVL 15

Accepted Solution

by:
periwinkle earned 750 total points
ID: 8105194
If SpamAssassin is unable to contact the RBL, it sometimes behaves rather badly.  Try adding:

skip_rbl_checks 1

to the spam.assassin.prefs.conf and stop and start MailScanner - and see if this fixes things.  If it does, you ought to consider moving the RBL checks up into MailScanner where they seem to behave a little better if servers are unable to be contacted...
0
 
LVL 2

Author Comment

by:dankennedy
ID: 8264803
I found out that Spamassassin just takes that much RAM when it's under a heavy load. We put more memory in the system and now it's working with no problem. It's back down to using 10MB.

But thanks for the suggestions...

0
 
LVL 15

Expert Comment

by:periwinkle
ID: 8264836
Dan - that's good to know - I have seen some weirdness when SpamAssassin acts up - the latest version of SpamAssassin seems to fix this.
0

Featured Post

RHCE - Red Hat OpenStack Prep Course

This course will provide in-depth training so that students who currently hold the EX200 & EX210 certifications can sit for the EX310 exam. Students will learn how to deploy & manage a full Red Hat environment with Ceph block storage, & integrate Ceph into other OpenStack service

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Fine Tune your automatic Updates for Ubuntu / Debian
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month12 days, 15 hours left to enroll

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question