• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1510
  • Last Modified:

Unchecking Read-only flag on \Docs & Settings won't stay off

I'm on XP Home SP 1. Disk is FAT32. I dual-boot with Linux (but I don't think that's relevant) and for several weeks now I have been unable to save anything under C:\Documents and Settings. The whole lot is read-only. Unsetting the check box appears to do something but it lies! If I try this in Safe Mode as Administrator - same thing. Just can't get it to stay unchecked. Experts elsewhere speak of the 'Security Tab' and 'Taking Ownership' which sounds fine but I have no Security Tab in my Properties window. (Could this be purely a NTFS facility?) If anyone can suggest how I can get my Docs & Settings folders back to their original state I would be very impressed! I have a suspicion it's a bug in Service Pack 1, so I fear someone is going to tell me to restore to before that! Am I right? I was rather hoping someone could point me to a setting in the Registry...
0
RoyHinchliff
Asked:
RoyHinchliff
  • 4
1 Solution
 
CrazyOneCommented:
>>>Could this be purely a NTFS facility

Yes only NTFS has this.
0
 
CrazyOneCommented:
Cannot Change the Read-Only Attribute of System Folders
http://support.microsoft.com/default.aspx?scid=kb;en-us;326549

The information in this article applies to:
Microsoft Windows XP Professional
Microsoft Windows XP Home Edition

This article was previously published under Q326549
SYMPTOMS
You cannot remove the Read-only attribute from a system folder (for example, My Documents) by using the Properties dialog box for the folder.
CAUSE
The Read-only attribute causes Windows Explorer to verify whether the folder is a special system folder. If you removed the Read-only attribute, the folder would appear as a typical folder, and all customizations (such as customizations in My Pictures or My Music) would be lost.
STATUS
This behavior is by design.
MORE INFORMATION
The Read-only attribute on a folder is ignored by the file system. You can still delete, rename, and change a read-only folder in other ways. The Read-only check box for system folders is always unavailable (appears dimmed) instead of containing a check mark. You can remove or put a check mark in the check box to modify the attributes of the contents of the folder (files but not subfolders), but you cannot change the Read-only attributes of system folders.
0
 
CrazyOneCommented:
Have you done this

Start > Run sfc /scannow

and this

Start > Run chkdsk /r
reboot.
0
 
RoyHinchliffAuthor Commented:
Thanks a lot, CrazyOne. You're a Star!. All your answers were helpful. I can now save files in the subfolders which I have created under Docs & Settings, although strangely they still have the Read-only attribute. I guess it doesn't mean quite the same thing as it used to in earlier Windows and DOS. Anyway, running sfc seemed to fix something. Thanks again. If I had more points to give, they would be yours.
0
 
CrazyOneCommented:
You are welcome. :>)
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now