• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1182
  • Last Modified:

Our ms-dos program keeps giving us "not enough file handles" error boxes

We are an insurance agency.  We purchased an agency accounting software called AMS Prime in 1997.  Though a dos based program, it was designed to operate in both dos and windows 98.  When the program needed more file handles to operate, it automatically changed the config.sys in Windows 98 to conform to 151 files.  This allowed the program to operate without error boxes coming up.  When we purchased two new computers with updated Windows ME and XP, we started having problems with error boxes stating not enough file handles.

In starting the program in both Windows ME and XP the program called for more file handles and tried to change the config.sys.  But nothing happened.  The error box continued to state there were not enough file handles.

In researching this problem, we found that the system help screen addressed the issue with running dos based programs where they called for more file handles.  It required going into the msconfig and adding another environmnet called "files".  We did this and indicated the appropriate number of files being 151.  We started the dos program; and it was unable to read that there were 151 files available.  So, the error box continued to state "not enough file handles".  

The agency system that we are currently on works very well for our agency.  As a matter of fact, the manufacturer of the program has come out with a full working windows version.  But quite frankely, the older version works far better for us in what we do.  The newer version does not provide us with the same flexibility as the older version.  Hence, we do not want to upgrade to the newer version of AMS Prime.  We are hoping we can solve this problem and continue to use this older version.
0
nealdundas
Asked:
nealdundas
1 Solution
 
ILECommented:
there is a couple of solutions for this


go to the propertis of the sortcat of ms dos based program
go to the program tab
use advanced buttons and do whatever u wona do in the config sys and autoexec bat specialy for that shortcat


0
 
stevenlewisCommented:
You did reboot after the changes?
is this what you did?
WinMe has combined the autoexec.bat and config.sys as one file called environment which has put into the registry. You can go to Start-run, type msconfig and OK to open the system configuration utilities.
At the environment tab, it contains the lines contained in autoexec.bat.
In extra control of your system to override some defaults settings in Io.sys of WinMe, you can add the lines which you originally intended to put into either autoexec.bat or config.sys in the environment.
e.g.
(1) Go to Start-run, type msconfig and OK to open the system configuration utilities. At the Environment Tab, Click New button to enter New Variable:-

Variable Name: [LASTDRIVE]
Variable Value: [Z ]
OK.
Restart computer.
It is now showing like this in the Environment Tab : -
Variable Value
[x] LASTDRIVE Z

after making the changes, reboot and then check to make sure msconfig reflects the changes
0
 
psikicCommented:
Here is how I believe you can fix the problem in Windows XP (should work in Windows 2000 as well).  I do not have your software so I can't test it... but these steps should be worth a try.

-----
Go to Control Panel
Double click on System
In the box that appears (System Properties) click on "Advanced" tab
Click "Environment Variables" button
Under System Variables, Click "New" button
for Variable Name, type FILES
for Variable Value, type 151
Hit OK until all of the windows are closed
-----

Let me know if the software works after these steps.

psikic <http://cs.atu.edu/~bryan/>
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
dbruntonCommented:
I'd make it more than 151 files.  Try 300 or so to compensate for Windows doing stuff you don't want.
0
 
psikicCommented:
Sorry that didn't work... here is another thing you should try.  Add the line

PerVMFiles=225

to the [386Enh] section of the %windir%\System.ini file.

Source: http://www.windows-help.net/windowsMe/tip-0106.html

psikic <http://cs.atu.edu/~bryan>/
0
 
pbarretteCommented:
Hi Neal,

Also, keep in mind that on WinXP your DOS emulation environment reads from the CONFIG.NT and AUTOEXEC.NT files rather than the CONFIG.SYS and AUTOEXEC.BAT files.

These files can be found in C:\WINNT\SYSTEM32

pb
0
 
psikicCommented:
OK.. thanks pbarrette... Neal, just change files=40 to files=151 or files=225 in the C:\windows\system32\config.nt file... that should work...

Give him the credit, I think he is right.

psikic <http://cs.atu.edu/~bryan>
0
 
psikicCommented:
nealdundas has emailed me and told me that the solution:
PerVMFiles=225 added to the [386Enh] section of the %windir%\System.ini file is correct.  Could this question be closed and the points awarded?  Thanks.

psikic <http://cs.atu.edu/~bryan/>
0
 
pbarretteCommented:
Hi psikic,

Normally I'd say no. You can understand how people could abuse the system by saying "So and so emailed me saying I was right. Give me the points." Yet there is no proof nor is there input from the user.

In this case, however, we have written confirmation that your answer was correct for his WinME configuration:
http://www.experts-exchange.com/Operating_Systems/MSDOS/Q_20547013.html

Put in a request at "Community Support" or in "Cleanup" and I'll back you up.

pb
0
 
pbarretteCommented:
Hi Pasha,

Recommend points to psikic.

See this link for clarification, if needed:
http://oldlook.experts-exchange.com/Operating_Systems/MSDOS/Q_20547013.html

pb
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now