Over use of hard disk

I have a win2k server that doesn't seem to be living up to its hardware. It has dual 500 mhz processors and 2 GB of RAM but it is still slow at times. While running the performance monitor and task manager, I noticed that the server is accessing the hard disk far more than it should and ignoring the paging file. (Perfmon shows lots of disk access and very little paging)I would like it to utilize the RAM more and the paging file but it seems to want to go to hard disk directly. How can I increase RAM utilization or even the paging file instead of spinning my HD? Has anyone else ever seen this behaviour before? I would appreciate hearing from you.

More info: Paging file is set to 3070MB initial 4000MB max - it is hardly ever used; I have observed it barely being touched while the HD is grinding away and RAM still available (at the same time everyone in office complains about the speed of the system and tries to stress me out)
-All RAM detected (2,096,620 KB) so I doubt it is 'bad RAM'
-Users complain of hanging processes and slooooow response but when I start checking into it, the CPU is fine (usually under50%) and more than a GB of RAM is free
-Available physical memory is usually about 1.4 GB or so
-We run SP2
-I have not changed any default settings in windows (that I remember) so the various processes we run (Office and a real estate database program) shouldn't bypass the memory
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

I don't know if this will work on a server OS or not

Memory Performance Tweak

These Settings will fine tune your systems memory

management -atleast 256MB of ram recccomended

go to start\run\regedit -and then to the following key

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

1.DisablePagingExecutive -double click it and in the decimal put a 1 - this allows XP to keep data in memory now instead of paging sections of ram to harddrive yeilds faster performance.

2.LargeSystemCache- double click it and change the decimal to 1 -this allows XP Kernal to Run in memory improves system performance alot

3.create a new dword and name it IOPageLockLimit - double click it and set the value in hex - 4000 if you have 128MB of ram or set it to 10000 if you have 256MB set it to 40000 if you have more than 512MB of ram -this tweak will speed up your disckcache

Reboot and watch your system fly

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
This must be a oracle or sql server (or other dataserver) It must write all data to disk (logs or database) before it has finished it's transaction.

You should setup a SCSI disks, with SCSI controller with a 128mb memory (or more) and a battery -- that should speed things up? Do you have such a setup?
Do you have anti-virus real-time monitoring on?  Try turning it off, and if things improve, run it to monitor either incoming files (writes) only or outgoing (reads) only.
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

SirTravisAuthor Commented:
That was quick - thanks for the prompt responses.

Crazy: I'm not sure if I want to go messing in the registry with what appears to be winXP stuff. The first 2 keys do actually exists and large system cache is already enabled. The others appear (to me) as if they hobble the paging file and I would actually like to have it around still. I may try this out but I want to exhaust other possibilities before I start messing with my registry.

Anton: It is a data server and uses SCSI disks, but not a seperate controller. It is intergrated into the motherboard. The transactions are not supposed to be written before they are complete - is there a way to check this?

Anetwork: The AV is already set to scan only selected file extentions. I also doubt this would have anything to do with hard disk access.

SirTravis, MCSE
still perplexed
Those registy tweaks are universal settingd for Win2000 and XP
I think it most likely that an application or service is accessing the disks incorrectly.  Try turning any non-standard services off one by one (including your database) and see what happens.  Stop any applications that are running on the console.  

Once you have established whiich app/service is causing te problem, you can dig a bit deeper.

If the Windows installation is standard, and the hardware is working correctly, I think it unlikely you will be able to 'tune' your way out of the problem.
SirTravisAuthor Commented:
I have been trying out those registry tweaks that crazy one suggested and the server semms a little faster but it still 'goes to disk' too often IMHO. I will continue to dig deeper into this problem but I guess that comment is as close to an answer as I am going to get. (especially since I have no more points to contribute to it)

SirTravisAuthor Commented:
The reg.tweaks helped a bit - it appears that this is the closest to an answer to my problem that I will get. Thanks to all who contributed.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.