MIDI Hell!!! tried replacing all hardware, it must be me!!

I have a MIDI/Gameport on my system and a general midi keyboard. Well I have 2! I have tried both and only midi output works, i replaced the soundcard - same again midi-out no-in, i bought another cable, same again, i bought loads of midi software, again no-in only out. I checked both keyboard user manuals about setting them up for midi usage and they are both set up correctly. I have used umpteen different software packages and they are all set up correctly to recieve midi. Have I missed something. Is there a windows setting or a driver or something i have neglected to set up. I'm sure one of you must know whats going on. Can you help me?
WreckdeckAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
TheTechManConnect With a Mentor Commented:
Check Device Manager (Right click on My Computer, Properties, Devices on most Windows versions) and check that the MIDI device you want to use is enabled and functioning.  Then, in the MIDI software you are running, make sure that the software is set to receive information on the MIDI port.  Other points:  There's a thing called sync'ing.  You must sync the software midi clock to the external keyboard in order to set up communication between your keyboard and the PC.  Also, make sure that the MIDI software is recording on all MIDI channels (sometimes called 'all' or 'omni') and the keyboard is sending on all channels if possible.

I'd be glad to answer more questions on this if any of these items helps you out, simply post a reply.  I'm a MIDI musician myself... these are all the nomral issues I dealt with too!

Include what software you use if you can, it'll help.

Good luck!

Tech

* "Help...  it's not easy, but it comes back around when you need it!"
0
 
steve_groConnect With a Mentor Commented:
Something that you may have overlooked:
click the little speaker icon in the system tray and see if midi is muted.  From the playback control, you'll have to go Options > Properties to switch to the Recording volume control. When I'm doing any audio work (or play, rather) I open the playback control & minimize it, then open the recording control, and minimize it, keeps them handy.

If you don't have a speaker icon, you can get to it this way, it varies a little from os to os:

Control Panel > Sounds and Audio > Audio tab > Volume.  There should be access to both playback & recording volume controls (and mute checkboxes).

While you're there you can select "place volume icon in the taskbar" for easier access in the future.

You may have to look around a little if you're using something other than XP to find these settings, but they shouldn't be too different.

Regards,

-Steve G
0
 
prd00Commented:
Check your midi input device. Some new system has more than 1 input device. Try each one of them.
BTW, what sound card are you using? I would recommend Hercules GameTheatreXP for easier access. MIDI input and output all using normal MIDI cable, not gameport type cable.
Do you mean, when your software plays a song, it can play through the keyboard, but when it cannot record your keyboard record, right? Or, do you mean that when you press the keyboard tuts, there were no sound from computer? What windows are you using? Some (actually, all I knew) MIDI software doesn't produce any output when you press keyboard tuts, but it DO record it. There is a feature called MIDI echo on those software if you want to hear your keyboard sound from your computer.
0
 
akbossCommented:

============================
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
Accept a comment Split between TheTechMan and steve_gro
Please leave any comments here within the next seven days.
 
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!
 
akboss
EE Cleanup Volunteer
============================
0
All Courses

From novice to tech pro — start learning today.