VBScript CodePage

Sorry, but 75 points it's all I've got for now, once I'll get more - I'll add it all to my question.

This question  more or less  bugging me for about 4 years already.

I have Russian system codepage, I need it to be able to manage files with Russian names and to use non-Unicode applications.

When using numeric functions in ASP , I'm getting errors,
for example : Cdbl("86.53") will produce Microsoft VBScript runtime error '800a000d'
Type mismatch: 'cdbl'  
Due to my investigation, I have realized that this is because my VBscript thinks that "." (dot) is not a delimiter for numbers, and it wants "," (comma) to be used instead.

Even worse, Cdate() function thinks that Date should be in dd-mm-yy format not in mm-dd-yy  but let's say Microsoft Access Database thinks differently and all the insert, update and select functions with date are total mess unless if I'm writing date as a sting '01-mar-2003'.

In my control panel, regional settings - everything is set to English system (I.e. mm-dd-yy and "." as decimal symbol, not a ","), English language is set to be windows default.

I have scanned whole registry for "," as some data - didn't find any related keys,
Also Session.CodePage,  <@ CodePage=xxxx Language=VBScript%> , response.CharSet do not change this behavior.

I did not find any VBScript international settings in IIS control panel nor in Global.Asa

This is all annoying because I can't develop any pages at home (without replace(".",",") kind of things) and forced to test my ASP pages online only.

I don't mind any weird solutions like edit some dll's in HEX editor, I just want to get rid of Russian date and numbers Format in VBScript

Any help would be deeply appreciated.
LVL 3
DRY_GINAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
sybeConnect With a Mentor Commented:
<%
' set ASP to USA format for the whole session:
Session.LCID = 1033
%>

<%
' set ASP to USA format the page:
SetLocale(1033)
%>

see also:
http://www.experts-exchange.com/Web/Web_Languages/ASP/Q_20424961.html
0
 
David_CameronCommented:
Start > settings > Control panel > Regional Options
0
 
DRY_GINAuthor Commented:
Thanks sybe! It works! Can't believe my eyes!


0
 
sybeCommented:
glad to be of assistance.
0
All Courses

From novice to tech pro — start learning today.