problem with JSP in iPlanet server

1. i added the following lines in web-apps.xml

<jsp-servlet enable="true">
   <init-param>
      <param-name>use-precompiled
      <param-value>true
   


2. Enabled JSP's and Servlets
3. Added tools.jar to the JVM classpath


When i try to access the application I got the logon page. After submitting the logon page i am calling a bean for authenticating user.I can't able to access the bean because i am getting an error page 'This page cannot be displayed'.When i removed the code for calling bean it works fine.
i don't know why this happens pls help me.
I am using iPlanet 6.0 .Is i missed any step in configuration.
tgopalakrishnanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

girionisCommented:
> 1. i added the following lines in web-apps.xml

  I guess the XML is well formed and what you posted here is just an example.

  Do you get any error messages on the console or in the log files?
0
kennethxuCommented:
I think if you enable precomiled, you must compile your jsp page manually, did you do that?
0
kennethxuCommented:
BTW, the right xml should read as
  <init-param>
     <param-name>use-precompiled</param-name>
     <param-value>true</param-value>
  </init-param>
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

syd108Commented:
Did you use jspc to pre-compile ur's jsp ?

What Does the Server Need to Run JSP?
--------------------------------------------------------------------------------

iPlanet Web Server 6.0 includes the Java Runtime Environment (JRE) but not the Java Development Kit (JDK) due to licensing restrictions. The server can run servlets and precompiled JSPs using the JRE, but you need the JDK to develop new JSPs or to deploy uncompiled JSPs. For information about precompiling JSPs, see http://docs.sun.com/source/816-5689-10/jsp.htm#27609

Also see:
http://docs.sun.com/source/816-5689-10/jsp.htm

regards
syd
0
girionisCommented:
 Or even better:

<jsp-servlet enable="true">
 <init-param>
    <param-name>use-precompiled</param-name>
    <param-value>true</param-value>
 </init-param>
</jsp-servlet>
0
syd108Commented:
Gopal:
I did not address your invalid XML format i just assumed that u just used it here for example..like psuedo code.

The link that i gave you shows the valid xml format.

good day
syd
0
allahabadCommented:
Check class path; Are you giving full qualified name of your class in <jsp:useBean ?
0
tgopalakrishnanAuthor Commented:
Hello friends thanks for responding to my question.Just i placed the war file inside the webapps directory and using that file i deployed now i working fine in the previous case i placed the war file c:\ and tried it.
A new question
I want to create two virtual directories(Application URI) where one refers to local system(where iPlanet server runs) and other one refers to a different system which is in physical network connection.

I directly opened the web-apps.xml file and added the following two lines

For Local system
  <web-app uri="/LocalFiles" dir="E:\LOCAL_FILES" enable="true"/>

For Network sytem
  <web-app uri="/NetWorkFiles" dir="\\client01\D\NETWORK_FILES" enable="true"/>

While i am trying to access the URI's the uri which refers to the Local system is woking file and the IE displays all the contents of the directory.But on the other i am geting 'HTTP 404 Not found error'.so how can i map a virtual directory for a folder which is in network system.

We are using Windows 2000 and iPlanet server version 6.0
0
kennethxuCommented:
your iplent service run under local system accoutn which has no access to windows network resource. go to control panel, services and find iplenet service, change run as an administrator account.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
syd108Commented:
Map the network network location by going to ->
Explorer->Tools-->Map Network Drive

Good Luck
syd
0
kennethxuCommented:
why postings are deleted?
0
kennethxuCommented:
in services, run as domain user, domain\administrator.
0
girionisCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

- Points to kennethxu

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

girionis
EE Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
JSP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.