Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 203
  • Last Modified:

WIN2K Pro - other computers in my workgroup can't get to my shares

I changed the IP setting on my computer to a static ip (through the advice of a vendor fixing another problem). Now the other computers in my workgroup can't see my shares or map to me.

I checked the Local Policy Setting and the Access from the Network settings was blank. I tried to set it but the Effective Policy stays blank and then the Local Policy goes blank.

How can I get others to map to my shared printer and folders when my computer won't hold the local policy setting?
0
soccer123
Asked:
soccer123
  • 9
  • 8
  • 8
  • +2
1 Solution
 
ghanaCommented:
Are you sure that your static IP address is on the same subnet as the other computers in your workgroup? If you don't know please post IP address and subnet mask of your computer and another computer in your workgroup.
0
 
soccer123Author Commented:
I just changed my computer and took the static IP of, it should now roam around and get a new IP from my linksys router.

I'm still having the same problem.

I change the Local Settings - it looks good for a couple of minutes (I can map from another computer). Then it stops working and the settings are gone.
0
 
ghanaCommented:
When the settings are gone: Open a command prompt and type IPCONFIG /ALL to get your IP settings. What's the IP address at this moment? If it is 169.254.x.x then you computer was not able to contact the DHCP server and used APIPA (automatic private ip addressing) to obtain an IP address.

Another thought: Switch off "autosensing" in the properties of your NIC (network interface card). Sometimes this can cause network connection failure.
0
Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

 
soccer123Author Commented:
The DHCP server is the linksys router.
0
 
cprietomCommented:
ghana is right, probably your problem is that the static IP you set up was not in the same address space as the other users. Do the following to be sure about it:
1. Set the IP to a dynamic one.
2. Wait for a few seconds and type IPCONFIG in the command prompt. If the IP that appears is 0.0.0.0 or 169.254.x.x then your computer has not been able to obtain a dynamic IP. Type IPCONFIG /RENEW and see what happens.

If an error message appears within a few seconds then you should ensure that your DHCP server has not run out of IPs.

If everything works fine and you've got a valid IP address then set a static IP, but ENSURE that it is in the right address space and that it is not in use in the moment you set it (it's very likely that your network administrator has set a range of IPs to be used as static and not served by the DHCP).

_____________
Play with it!
0
 
ghanaCommented:
> The DHCP server is the linksys router.

I know. But if your computer isn't able to connect to the router (for example because of NIC failure) then it can't get an ip address.

Follow the steps provided by cprietom and let us know the result.
0
 
soccer123Author Commented:
I have access to other computers. They can't get access to mine. I see my computer on their My Network Place. When I try to get to my computer from others I get the "the user has not been granted the requested logon type at this computer" message.

I looked in the Local Policy for Access this computer from the Network and it's blank.

I set values in the Local Settings but they do not want to stay. When I reboot, the settings are gone.

0
 
ghanaCommented:
Yes, that's really not an IP problem...

Just an idea: http://support.microsoft.com/default.aspx?scid=kb;en-us;220862
0
 
MSGeekCommented:
I am confused after reading this post.

Several issues.  One if router is the dhcp server and you have changed the IP of your Win2k Pro box then how are the other computers finding the Win2kPro box.  If you are using DHCP I imagine they were initialy finding your workstation through the Master Browser and the Browsing Service.

It does not sound like you have set up any hosts or lmhosts files locally for name resolution.  If you open Explorer on one of their computers and type in the current ip of your Win2k Pro workstation followed by C$ what do you get?

\\192.168.1.10\C$

MSGeek
0
 
cprietomCommented:
If your effective setting for the policy "Access this computer from the network" is blank and it stays so even if you change the Local Setting I think the problem is that there is a more priority GPO that overwrites your local settings.

You should consider that the Local settings are ovewritten by all other group policies (Default Domain Policy is among them). So I suggest asking your network administrator which settings are on the server for your computer.

Give feedback of any changes.
_____________
Play with it!
0
 
soccer123Author Commented:
This system is my home system. So I am the network admin (I guess).

I'm working with a WORKGROUP - no Domains. I also read that the Group Policy (Domain) overrides the Local. But since I don't have a Domain - that shouldn't be possible.

Where would I check the Domain settings?

To MSGEEK - I changed my computer from static back to DHCP assigned.

I just don't understand my the Local Policy doesn't become the Effective Policy.

There is a brief period of time when I can see my computer from another, but when I reboot - it goes away.

Could something be wrong in my network settings?

Also, if I have to rebuild my system, should I goe to XP Pro? (Pentium III - 500)
0
 
cprietomCommented:
Ok, you should have started saying that it is a home network and not an enterprise one.

Some data I would like to know: how are you connecting your computers? Do you have several computers connected to a hub or do you have just 2 computers connected directly via a network cable?.

Anyway, other source of problems are the protocols. You have to ensure that you have the following components installed for your network on every computer that you want to be able to access and be accessed on your network:

"Client for Microsoft Networks"
"File and Printer Sharing for Microsoft Networks"
"NetBEUI Protocol"
"Internet Protocol (TCP/IP)"

To check if any of the previous protocols is missing you have to do the following:
1. Start > Settings > Network and Dial-up Connections
2. Righ click on "Local Area Connection" and choose "Properties".
After doing this you should be able to see a list of the clients and protocols currently installed for your connection.

If any of the components mentioned is missing, you should add it by doing the following:
1. From the window you opened in the previous two steps press the button "Install...", choose "Protocol" or "Client" (it depends on which of the components is missing) and press "Add...". Choose the right component and press "OK".

Try this and come back to type what happened.

____________
Play with it!
0
 
soccer123Author Commented:
This computer is connected to a linksys wireless router.

All of the protocols specified, exist.
0
 
MSGeekCommented:
Even if it is set to dhcp, did you try accessing it the way I suggested with it's current IP.  If it works, then restart the Win2k computer and try it again with the IP it receives at boot up.  If that works then the problem lies with name resolution on your 9X clients which rely upon NetBIOS and Browser services to find resources.

If that is the case, even though you are using dhcp, your IP's with that paticular device will remain the same for the most part, they could still change, bear with me here.

On the Win9x box search the windows directory and subdirectory for lmhosts file.  I am pretty sure it is in the root of the Windows directory.  Open the file in Notepad and scroll to the bottom.  On the last blank line enter the IP of your Win2k machine then a {TAB} then it's workstation name {TAB} #PRE, should look something like:

192.168.1.7       win200box   #PRE

When you save the changes to the file make sure Notepad does not add the ".txt. extension to the end, bydefault it will do this without asking.  Reboot the Win9x box when done and try browsing to the Win2k box.  If the IP has not changed for the Win2k box you have solved your problem.

At this point you need to roll the dice, continue using DHCP or go to static IP's and manually assign the ISPs DNS servers to the IP settings of all computers.  The other option would be to install Win2K server if you buy a copy and run WINS, DHCP and DNS on it.  Have fun.
0
 
ghanaCommented:
Have you already checked whether the local computer settings in the group policy snap-in are disabled as I recommended in my last comment?

If this snap-in is not available in the menu start mmc.exe and ad the snap-in "group policy". Then follow the description in the MS knowledge base.
0
 
soccer123Author Commented:
ghana - I checked the Disable Computer Config setting (and the other one) - both are unchecked.

Something I found in Service... Remote Access Auto Connection Manager was Started - it doesn't exist on any of my other servers. Could this mean anything?

Any advantage to going to Win2K Server or Win XP Pro?
0
 
MSGeekCommented:
Server will allow you to run WINS which supports name resolution for your Legacy clients, name resolution is critical to access shared resources.  Server you can also centrally manage all storage and printing, you can also run DNS integrated with DHCP.  This will help a lot with name resolution as well.
0
 
ghanaCommented:
> There is a brief period of time when I can see my computer
> from another, but when I reboot - it goes away.
> Could something be wrong in my network settings?

If only this would be the problem I would answer with "yes". But as far as I understood your problem, the configuration of the local policy (Access from the Network) will also be lost if you reboot your machine. That's the only reason why I assume there is a more common problem.

> Any advantage to going to Win2K Server or Win XP Pro?
No, this is not an usual W2K Pro problem. Although I don't like it: I would think about re-installing the operating system. This could be a faster solution.

Please have a look into your system event log. Are there any items that might correlate with the losing of your settings? Maybe your server service is going down or something like that?
0
 
soccer123Author Commented:
I was fearing that, but I think that may be the best option. There is definitely something unusual going on. I'm not a network guy but I do work with computers.

I hate having to move all my "non-Windows" files off, save my email stuff, etc... just to re-install the operating system.

If only MS could separate the Operating System from the User Applications so you could re-install without reloading all you apps - Oh Well.

I know what I'll be doing this weekend.

That's all of you for trying - I really appreciate the effort.
0
 
MSGeekCommented:
soccer123.. Nothing personal, but I think there was a case of tunnel vison here, looking and spending all time on local security policy (not that it was a bad idea.).

Have you tried the lmhosts file?  Or at least accessing the computer from another computer by typing in the \\ip address\C$   ?????
0
 
ghanaCommented:
> They can't get access to mine. I see my computer on their
> My Network Place. When I try to get to my computer from
> others I get the "the user has not been granted the
> requested logon type at this computer" message.

MSGeek, I had the same toughts like you that there could be a problem relating to IP configuration or name resolution. But since soccer123 has posted this comment I think it must be something else.

If the problem would be caused by a failure in name resolution, I would expect a message like "unknown host" or "invalid path" or "path not found" or something like that. But the message was "the user has not been granted the requested logon type at this computer". Would you agree that this message will only appear if:

1) the requesting computer was able to connect to the target computer - and -
2) the requesting computer did get exactly this message as answer when it tried to logon to the target computer?

So I would say the requesting computer must have been able to resolve the name of the target computer. Otherwise it wouldn't been able to establish a connection and to recieve this message. Please tell me if I'm wrong!?!
0
 
MSGeekCommented:
I don't believe your wrong, but if he indeed has client for MS networks installed on both his Win2k box and his 9x boxes and he tries to access the hidden share by ip address he should at least receive a pop-up prompt for username and password and not an out right denial.
0
 
ghanaCommented:
Even if the "Access from the Network" settings in the local policy are empty? I've never tested that... Because these settings mean nobody will be allowed to logon over the network it wouldn't be a bad idea if the pop-up prompt wouldn't be displayed. On the other hand - Microsoft is not known to have such good ideas...   ;-)
0
 
MSGeekCommented:
Good point, the policy "Access this computer from the network" has a default setting of "Everyone,Users,Power Users,Backup Operators,Administrators"

If that was blank the system would not know what to pompt for if anything at all.  Thanks.
0
 
soccer123Author Commented:
Just to let everyone know - I rebuilt my computer over the weekend and all is well.

To answer some of the questions:

Yes - I did try to ping my computer from another - worked

Yes - I tried to map from another - did not work (access issue, that's my I looked at the Local Settings)

I also tried to import the default sec settings  - looked good until I rebooted and then all of them were gone.

I opted to reinstall, lick my wounds and go on with life.
0
 
MSGeekCommented:
Please post a request in Community Support for this question to be closed.
0
 
soccer123Author Commented:
Please close this issue

Thanks to all
0
 
MSGeekCommented:
That won't close the question.  You need to go to the Community Support section of EE and post a question.  In that question paste the URL of this question and request they close it.
0
 
moduloCommented:
Dear expert(s),

A request has been made to close this Q in CS:
http://www.experts-exchange.com/Community_Support/Q_20553477.html

Without a response in 72 hrs, a moderator will finalize this question by:

 - Saving this Q as a PAQ and refunding the points to the questionner

When you agree or disagree, please add a comment here.

Thank you.

modulo

Community Support Moderator
Experts Exchange
0
 
moduloCommented:
Saving this Q as a PAQ and refunding the points to the questionner

modulo

Community Support Moderator
Experts Exchange
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 9
  • 8
  • 8
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now