?
Solved

Connecting Client to Win 2000 Server

Posted on 2003-03-12
14
Medium Priority
?
143 Views
Last Modified: 2010-04-13
I have installed a new Windows 2000 Advanced Server, with two other (Win '98) PC's connected.
Currently the server can see both the PC's and the PC's can see each other. However, when I try to view the server from the other PC's, it always points to an IPC$ connection and asks for a password - which doesn't seem to be the administrator's password. Also - the PC's can't see the printers connected to the server, but I'm hoping that resolving the issues above will also fix this.
 
0
Comment
Question by:frogboy5
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
  • 2
  • +1
14 Comments
 
LVL 10

Expert Comment

by:pcbrat
ID: 8120928
Do you have the DNS enabled in the client 98 machines under the network properties? You need to have the 98 machines in your AD DNS domain. Typically they are not set because 98's standard is Netbios.

If you enable it and then browse and see them let me know. I would like to help, but Ineed more info.

Dawne
0
 
LVL 16

Expert Comment

by:JammyPak
ID: 8121038
If you're getting a password prompt, it means that it located the server. The problem is that the user account which you are logged into the 98 box with does not exist on the Win2000 box.

98 does not prompt for a name and password (the way 2K, XP, etc will). This means you have to log in with the correct user account on 98. If the passwords are different, you'll get a prompt, it they're the same you won't.

JP
0
 
LVL 1

Expert Comment

by:asamaras
ID: 8121536
Hello,
think about a briliant new world where your win98 PCs are acting like clients... Well they do! The funny part is that Win98 transmit the computer name as Username and they prompt you for a password. Go to your Win2k box, open 2 user accounts named after the Win98 computers, grand them a password and voila. Yeh, you got to remember to put all the computers in the same workgroup.
Hope it helps
Cheers
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 

Author Comment

by:frogboy5
ID: 8123601
Hi,
OK, I realise I must seem stoopid, but I really can't find anywhere on the Win2K server to allocate a password etc.
In Computer Management, I've added the names of the other PC's in Local Users and Groups - although I've no idea whether they should be within a sub-group.
However - adding the PC name gives me property options such as User Profile, member of (presumably workgroup etc.), but still not much help.
Also - I have no idea where to look on the '98 PC's for DNS. I don't use any log-in name or password when starting the Win '98 PC's - maybe this is hidden from me somewhere?
Thanks for the responses so far.
0
 
LVL 10

Expert Comment

by:pcbrat
ID: 8123936
DNS settings are int the network neighborhood. Right click net neighborhood, go to properties, find your Network cards name and the TCP/IP that is next to it, go to properties, there you will find a DNS tab. Set the properties.

But answer me this if you are only using a standalone server then you are not running AD and DNS. So I dont believe that you will need your DNS tab. However you will need to make sure TCP IP is running.

As for adding the new users/workstations asamaras was correct in saying change the pcs that you see to a password, that would be when you see the users/pcs in computer management highlight one of them, right click and select set password. You dont need to worry about the profiles tabs unless you are mapping to a home directory and want to run logon scripts.

Hope this helps and keep us posted.

Dawne :)
0
 
LVL 16

Expert Comment

by:JammyPak
ID: 8127950
frogboy5, go back to Computer Management, Users and Groups. Right click on the user and select 'set password'.

don't worry about groups
0
 

Author Comment

by:frogboy5
ID: 8131654
Hi - sorry to be so painful about this, but I've set the passwords as directed, and the other PC's still can't connect to the server.
Let's get this straight - on the Server in Computer Management, I can see the name of the PC's listed under Local Users and Groups / Users. The Names correspond to the names within workgroups when I use Explorer with My Network Places/Entire Network/Microsoft Windows/Workgroup
The server can see all the shared directrories of both the PC's.
The PC's can see the server listed in Network Neighbourhood/Entire Network. When I click on this I'm asked for a password, but in the pop-up password box the server name is suffixed by \IPC$ (don't know why).
As I stated above, the password I entered on the server for these PC's is not accepted.
Any other suggestions?

0
 
LVL 16

Expert Comment

by:JammyPak
ID: 8131858
It's not the computer name that needs to be created on Win2000 - it's a user account (ex. bob). In Windows 98, choose logout, and see who you're logged into the 98 computer as. Or, delete all .pwl files on the 98 machine and restart - you will have to put a name and password into the Win98 logon screen - this is the name and password to create on the Win2000 machine. Sometimes it doesn't seem like you're logging into Win98 because it's automatic, but you actually are. Once you have the user accounts in sync, you won't get the password prompt anymore.

JP
0
 

Author Comment

by:frogboy5
ID: 8132646
Hey JP,
that's actually done the trick - amazingly the PCS's can now see the server!
Just one thing though (as per my original supplementary question), I can't seem to see the server printers from the client PC's. They are connected to the server via a USB hub. I thought they'd magically appear with the access to the server, but obviusly not. Any ideas how I can map to them?
0
 
LVL 16

Accepted Solution

by:
JammyPak earned 200 total points
ID: 8136244
Are the printers shared on the server? You'd have to share them, and then in the add printer wizard on the client you could point to them using \\<servername>\<printersharename>

Glad the rest is working -

JP
0
 
LVL 1

Expert Comment

by:asamaras
ID: 8141805
also you will need to add printer drivers to your win98 boxes. Alt use additional drivers on your Win2K box, so that the clients may download and install them.
By the way, Yes actually JammyPak is right, sorry for the wrong tip.

Sakis
0
 

Author Comment

by:frogboy5
ID: 8221189
Hello,
Could JP (or anyone else)please help again?
The client PC now keeps asking for a password when I try to use the server printer. When entered (correctly) it "greys" out the printer when viewed in settings, and attempts to print to it fail (documents just hang in the print queue). Have tried deleting and re-adding the printer.
The network connection to the server appears to be OK - I can view files etc. (after entering the same password).
Would be grateful for any ideas on how to stop this happening - would prefer the printer to connect automatically at start-up and stay connected.
Thanks
0
 
LVL 16

Expert Comment

by:JammyPak
ID: 8246311
I'm not sure what's happening here...strange one.

Unfortunately, when you add a network printer on a client, it doesn't reconnect to the server on login the way a mapped drive does. The printer mapping is there, but you still need to authenticate to the server before you can actually print.

One thing you may want to try is to add a line to your login script (or put a .bat file in the startup) that does this:

start \\<server>\<printershare>

this will force the client to connect to the printer when they login or boot. It would be best to put this after they have authenticated on the server (ie after they map drives, for ex). If you don't already have login scripts then this is a bit of a pain, but it may help.

JP
0
 

Author Comment

by:frogboy5
ID: 8593920
Hello again,
This all worked (as per JammyPak + other's suggestions), but has ceased working again!
I now cannot connect to either the printer (on the server via USB) or the server files from one of the '98 PC's.
I've tried the usual - re-setting the password on the server (within Local Users and Groups / Users) and deleting the password files to force password login on the '98 PC.
I'm again at a loss as how to rectify this - even more mystified as it worked for several weeks.
Cheers,
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
The Summer 2017 Scholarship Winners have been announced!
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question