?
Solved

Cisco PIX 515 VPN and internet access

Posted on 2003-03-12
15
Medium Priority
?
485 Views
Last Modified: 2010-04-12
I have a cisco pix 515 connected to both the inside/outside networks and have established internet browsing as well as vpn pptp dialin.  The vpn assigns an ip from my local pool, but i still cannot ping clients or servers on the inside network...  Beyond the resources inside, is it possible to allow clients on the vpn connections internet access over the vpn?

Any input would be great.
Thank you,
           Chris
0
Comment
Question by:royalelect
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
15 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 8122098
You need one of two things:

nat zero with access-list

i.e.
access-list NO_NAT permit <pool subnet> mask <local subet> mask
nat(inside)0 access-list NO_NAT

or

sysopt ipsec pl-compatible

0
 

Author Comment

by:royalelect
ID: 8123025
Can you reply with the lines i need in you example ab ove, but with proper ip addresses in the example.  I may be going about this with the wrong ones, if so, any help would be great.
Also, is there a way to get rid of the dmz/vpn ips/nameifs in the config to remove the nics?

Here is my running config:


PIX Version 6.0(1)                                                                        
nameif ethernet0 outside security0                                                        
nameif ethernet1 inside security100                                                      
nameif ethernet2 dmz security50                                                          
nameif ethernet3 vpn security75                                                          
enable password XXXX encrypted                                                
passwd XXXX encrypted                                                        
hostname rec-pix1                                                                        
domain-name royalelect.com                                                                
fixup protocol ftp 21                                                                    
fixup protocol http 80                                                                    
fixup protocol h323 1720                                                                  
fixup protocol rsh 514                                                                    
fixup protocol smtp 25                                                                    
fixup protocol sqlnet 1521                                                                
no fixup protocol sip 5060                                                                
no fixup protocol skinny 2000                                                            
names                                                                                    
access-list acl_out permit icmp any any                                                  
pager lines 24                                                                            
interface ethernet0 auto                                                                  
interface ethernet1 auto                                                                  
interface ethernet2 auto                                                                  
interface ethernet3 auto                                                                  
mtu outside 1500                                                                          
mtu inside 1500                                                                          
mtu dmz 1500                                                                              
mtu vpn 1500                                                                              
ip address outside 65.107.23.207 255.255.255.224                                          
ip address inside 192.168.5.254 255.255.255.0                                            
ip address dmz 10.1.1.1 255.255.0.0                                                      
ip address vpn 192.168.10.254 255.255.255.0                                              
ip audit info action alarm                                                                
ip audit attack action alarm                                                              
ip local pool vpn-pool 192.168.5.100-192.168.5.124                                        
no failover                                                                              
failover timeout 0:00:00                                                                  
failover poll 15
failover ip address outside 0.0.0.0                                                      
failover ip address inside 0.0.0.0                                                        
failover ip address dmz 0.0.0.0                                                          
failover ip address vpn 0.0.0.0                                                          
pdm history enable                                                                        
arp timeout 14400                                                                        
global (outside) 1 65.107.23.208                                                          
nat (inside) 1 192.168.5.0 255.255.255.0 0 0                                              
static (inside,outside) 65.107.23.0 192.168.5.0 netmask 255.255.255.255 0 0              
access-group acl_out in interface outside                                                
route outside 0.0.0.0 0.0.0.0 65.107.23.193 1                                            
timeout xlate 3:00:00                                                                    
timeout conn 2:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00
sip_media 0:02:00                                                                        
timeout uauth 0:05:00 absolute                                                            
aaa-server TACACS+ protocol tacacs+                                                      
aaa-server RADIUS protocol radius                                                        
http server enable                                                                        
http 192.168.5.0 255.255.255.0 inside                                                    
no snmp-server location                                                                  
no snmp-server contact                                                                    
snmp-server community public                                                              
no snmp-server enable traps                                                              
floodguard enable                                                                        
sysopt connection permit-pptp                                                            
no sysopt route dnat                                                                      
telnet 192.168.5.0 255.255.255.0 inside                                                  
telnet timeout 30                                                                        
ssh timeout 5                                                                            
vpdn group 1 accept dialin pptp                                                          
vpdn group 1 ppp authentication mschap                                                    
vpdn group 1 ppp encryption mppe 40                                                      
vpdn group 1 client configuration address local vpn-pool                                  
vpdn group 1 client configuration dns 192.168.5.194 192.168.5.1                          
vpdn group 1 client configuration wins 192.168.5.194 192.168.5.1                          
vpdn group 1 pptp echo 60                                                                
vpdn group 1 client authentication local                                                  
vpdn username XXXX password XXXX                                                      
vpdn enable outside                                                                      
dhcpd address 192.168.5.2-192.168.5.99 inside                                            
dhcpd dns 192.168.5.194 192.168.5.1                                                      
dhcpd wins 192.168.5.194 192.168.5.1                                                      
dhcpd lease 3600                                                                          
dhcpd ping_timeout 750                                                                    
dhcpd domain royalelect.com                                                              
dhcpd enable inside                                                                      
terminal width 80
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8123497
I always use a separate subnet for VPN users, not part of the inside LAN. i.e.

ip local pool vpn-pool 192.168.15.100-192.168.15.124

access-list NO_NAT permit ip 192.168.5.0 255.255.255.0 192.168.15.0 255.255.255.0
nat(inside)0 access-list NO_NAT

>static (inside,outside) 65.107.23.0 192.168.5.0 netmask 255.255.255.255 0 0            
You're going to have a problem with this line with that mask. What exactly are you trying to accomplish with the static map?
Suggest:
no static (inside,outside) 65.107.23.0 192.168.5.0 netmask 255.255.255.255 0 0            


>Also, is there a way to get rid of the dmz/vpn ips/nameifs in the config to remove the nics?

If you aren't using them:
nameif ethernet2 unused1 security50
nameif ethernet3 unused2 security75

no ip address dmz 10.1.1.1 255.255.0.0
no ip address vpn 192.168.10.254 255.255.255.0

To shut them down:
no interface ethernet2 auto
no interface ethernet3 auto          


SUGGESTION: Upgrade soonest to 6.2(2), and PDM 2.11
The PDM is Java GUI

           
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:royalelect
ID: 8123890
I have mad all of the changes above, however, clients still cannot ping other clients/server on the 192.168.5.x network.  I know i am a rookie at the cisco gear, but i added a line to the config:
access-list NO_NAT permit icmp any any
and still no ping...

Also, i placed the order for smartnet cat11 for the 515-ur, they say about a week...
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8133499
Can you post your new config
0
 

Author Comment

by:royalelect
ID: 8137414
Newest running config, still get valid ips on vpn clients, but they cannot ping/access inside/outside resources.


PIX Version 6.0(1)                                                                        
nameif ethernet0 outside security0                                                        
nameif ethernet1 inside security100                                                      
nameif ethernet2 unused1 security50                                                      
nameif ethernet3 unused2 security75                                                      
enable password XXXX encrypted                                                
passwd XXXX encrypted                                                        
hostname rec-pix1                                                                        
domain-name royalelect.com                                                                
fixup protocol ftp 21                                                                    
fixup protocol http 80                                                                    
fixup protocol h323 1720                                                                  
fixup protocol rsh 514                                                                    
fixup protocol smtp 25                                                                    
fixup protocol sqlnet 1521                                                                
no fixup protocol sip 5060                                                                
no fixup protocol skinny 2000                                                            
names                                                                                    
access-list acl_out permit icmp any any                                                  
access-list NO_NAT permit ip 192.168.5.0 255.255.255.0 192.168.15.0 255.255.255.0                                                      
pager lines 24                                                                            
interface ethernet0 auto                                                                  
interface ethernet1 auto                                                                  
interface ethernet2 auto shutdown                                                        
interface ethernet3 auto shutdown                                                        
mtu outside 1500                                                                          
mtu inside 1500                                                                          
mtu unused1 1500                                                                          
mtu unused2 1500                                                                          
ip address outside 65.107.23.207 255.255.255.224                                          
ip address inside 192.168.5.254 255.255.255.0                                            
ip address unused1 10.1.1.1 255.255.0.0                                                  
ip address unused2 192.168.10.254 255.255.255.0                                          
ip audit info action alarm                                                                
ip audit attack action alarm                                                              
ip local pool vpn-pool 192.168.15.100-192.168.15.124                                      
no failover                                                                              
failover timeout 0:00:00                                                                  
failover poll 15                                                                          
failover ip address outside 0.0.0.0                                                      
failover ip address inside 0.0.0.0                                                        
failover ip address unused1 0.0.0.0                                                      
failover ip address unused2 0.0.0.0                                                      
pdm history enable                                                                        
arp timeout 14400                                                                        
global (outside) 1 65.107.23.208                                                          
nat (inside) 0 access-list NO_NAT                                                        
nat (inside) 1 192.168.5.0 255.255.255.0 0 0                                              
access-group acl_out in interface outside                                                
route outside 0.0.0.0 0.0.0.0 65.107.23.193 1                                            
timeout xlate 3:00:00                                                                    
timeout conn 2:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00
sip_media 0:02:00                                                                        
timeout uauth 0:05:00 absolute                                                            
aaa-server TACACS+ protocol tacacs+                                                      
aaa-server RADIUS protocol radius                                                        
http server enable                                                                        
http 192.168.5.0 255.255.255.0 inside                                                    
no snmp-server location                                                                  
no snmp-server contact                                                                    
snmp-server community public                                                              
no snmp-server enable traps                                                              
floodguard enable                                                                        
sysopt connection permit-pptp                                                            
no sysopt route dnat                                                                      
telnet 192.168.5.0 255.255.255.0 inside                                                  
telnet timeout 30                                                                        
ssh timeout 5                                                                            
vpdn group 1 accept dialin pptp                                                          
vpdn group 1 ppp authentication mschap                                                    
vpdn group 1 ppp encryption mppe 40                                                      
vpdn group 1 client configuration address local vpn-pool                                  
vpdn group 1 client configuration dns 192.168.5.194 192.168.5.1                          
vpdn group 1 client configuration wins 192.168.5.194 192.168.5.1                          
vpdn group 1 pptp echo 60                                                                
vpdn group 1 client authentication local                                                  
vpdn username royal password 365000                                                      
vpdn enable outside                                                                      
dhcpd address 192.168.5.2-192.168.5.99 inside                                            
dhcpd dns 192.168.5.194 192.168.5.1                                                      
dhcpd wins 192.168.5.194 192.168.5.1                                                      
dhcpd lease 3600                                                                          
dhcpd ping_timeout 750                                                                    
dhcpd domain royalelect.com                                                              
dhcpd enable inside                                                                      
terminal width 80                                                                        
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8154654
They can access outside hosts by un-checking the box in their VPN client configuration, Networking, TCP/IP, Advanced, "Use default gateway on remote network"

What is the default gateway for systems on the internal network? Is it 192.168.5.254, or something else? If something else, does that gateway have a route back to the 192.168.15.0 subnet?

0
 

Author Comment

by:royalelect
ID: 8155287
The internal gateway is 192.168.5.254
0
 
LVL 1

Expert Comment

by:MaartenS
ID: 8157670
I got this config from the Cisco site.. It's a working config.. WITH nat tho.. I think it doesn't work becuz a pix is not a real router. This config is working with PPTP, IPSec and MPPE dialin. It's a working config since I have extracted mine from it...

I say compare urs with it. Good luck.

nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname goss-515A
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
names
access-list 101 permit ip 10.99.99.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
logging on
no logging timestamp
no logging standby
no logging console
no logging monitor
no logging buffered
no logging trap
no logging history
logging facility 20
logging queue 512
interface ethernet0 auto
interface ethernet1 auto
mtu outside 1500
mtu inside 1500
ip address outside 172.18.124.152 255.255.255.0
ip address inside 10.99.99.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool bigpool 192.168.1.1-192.168.1.254
no failover
failover timeout 0:00:00
failover poll 15
failover ip address outside 0.0.0.0
failover ip address inside 0.0.0.0
arp timeout 14400
nat (inside) 0 access-list 101
route outside 0.0.0.0 0.0.0.0 172.18.124.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00
h323 0:05:00 sip 0:30:00
 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
no sysopt route dnat
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client configuration address initiate
crypto map mymap client configuration address respond
crypto map mymap interface outside
isakmp enable outside

!--- CiscoSecure_VPNClient_key.

isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp client configuration address-pool local bigpool outside

!--- ISAKMP Policy for Cisco VPN Client 2.5 or
!--- CiscoSecure VPN Client 1.1.

isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5

!--- The 1.1 and 2.5 clients use Diffie-Hellman (D-H)
!--- group 1 policy (PIX default).

isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
!

!--- ISAKMP Policy for VPN Client 3.0.

isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5

!--- The 3.0 clients use D-H group 2 policy
!--- and PIX 6.0 code.

isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn3000-all address-pool bigpool
vpngroup vpn3000-all dns-server 10.99.99.99
vpngroup vpn3000-all wins-server 10.99.99.99
vpngroup vpn3000-all default-domain password
vpngroup vpn3000-all idle-time 1800

!--- VPN 3000 group_name and group_password.

vpngroup vpn3000-all password ********
telnet timeout 5
ssh timeout 5
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe auto
vpdn group 1 client configuration address local bigpool
vpdn group 1 client authentication local


!--- PPTP username and password.

vpdn username cisco password cisco
vpdn enable outside
terminal width 80
0
 

Author Comment

by:royalelect
ID: 8207831
PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security10
nameif ethernet3 intf3 security15
enable password jGjut2YtmN930.EK encrypted
passwd 9WJS7JiEJ3709zUB encrypted
hostname pix
domain-name royalelect.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
access-list acl_out permit icmp any any
access-list inside_outbound_nat0_acl permit ip any 192.168.15.0 255.255.255.224
pager lines 24
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown
interface ethernet3 auto shutdown
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
mtu intf2 1500
mtu intf3 1500
ip address outside 65.107.23.207 255.255.255.224
ip address inside 192.168.5.254 255.255.255.0
ip address intf2 127.0.0.1 255.255.255.255
ip address intf3 127.0.0.1 255.255.255.255
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn-pool 192.168.15.1-192.168.15.24
no failover
failover timeout 0:00:00
failover poll 15
failover ip address outside 0.0.0.0
failover ip address inside 0.0.0.0
failover ip address intf2 0.0.0.0
failover ip address intf3 0.0.0.0
pdm location 192.168.5.195 255.255.255.255 inside
pdm location 192.168.15.0 255.255.255.224 outside
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 65.107.23.193 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.5.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-pptp
no sysopt route dnat
telnet 192.168.5.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe 40
vpdn group PPTP-VPDN-GROUP client configuration address local vpn-pool
vpdn group PPTP-VPDN-GROUP client configuration dns 192.168.5.194 192.168.5.1
vpdn group PPTP-VPDN-GROUP client configuration wins 192.168.5.194 192.168.5.1
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username royal password *********
vpdn enable outside
dhcpd address 192.168.5.2-192.168.5.99 inside
dhcpd dns 192.168.5.194 192.168.5.1
dhcpd wins 192.168.5.194 192.168.5.1
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain royalelect.com
dhcpd enable inside
terminal width 80
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8211289
What issues are you having with this latest config?

0
 

Author Comment

by:royalelect
ID: 8211414
need to get the vpn clients access to 3 servers on the outside interface, is that possible?
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 300 total points
ID: 8211479
If the servers are located on the OUTSIDE interface (between the router and the PIX with public IP addresses?), the answer is not through the tunnel. The reason is that the PIX cannot re-direct a packet out the same interface it came in on.
Tunnel endpoint is the PIX, the only things you can access are systems on the internal interface.
If the client un-checks the "use default gateway on remote network" option on their client, then they can access the public ip addresses of those servers outside the VPN tunnel.
0
 

Author Comment

by:royalelect
ID: 8211675
ok, further explanation into this...
i have several servers with public(outside)and private(inside) connections, the public cards have the public default gateway that the pix also has, private nics do not have the inside gateway.  the pix cannot ping/communicate with servers without the internal gateway.
0
 

Author Comment

by:royalelect
ID: 8219992
after talking to cisco, this is possible, but with another pix...

     Thank you,
              royalelect
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Like many others, when I created a Windows 2008 RRAS VPN server, I connected via PPTP, and still do, but there are problems that can arise from solely using PPTP.  One particular problem was that the CFO of the company used a Virgin Broadband Wirele…
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Suggested Courses
Course of the Month8 days, 12 hours left to enroll

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question