?
Solved

Cisco 2600

Posted on 2003-03-12
16
Medium Priority
?
254 Views
Last Modified: 2010-04-17
I have several members that connect to a central server at my office.  My current issue is that some of my members connect through point to point ISDN lines.  I have a Cisco 2600 (IOS 12.1) to handle that.  All of my members connect fine to my main server address 192.168.1.10, but I need to make another server avaliable on 192.168.1.82.  I have no access lists on my 2600 or any of the routers at my members sites, but I do have ip routes to open my whole subnet.  I can ping 192.168.1.10 successfully from my off-site routers, but I cannot ping 192.168.1.82.  On the 2600 in house, I can ping both addresses.  I don't know why the second address is not avaliable and any help would be greatly apprecited.  Thanks.

David
0
Comment
Question by:FloppyDongle
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 4
  • +1
16 Comments
 
LVL 7

Expert Comment

by:pedrow
ID: 8123891
What are the routers at the endpoints?

Could you post relevant parts of the 2600 config as well as one of the spokes?

What do the routing tables look like on the spoke and hub routers?
0
 

Author Comment

by:FloppyDongle
ID: 8123958
Here is my 2600's config without all of the BRI ports:
Current configuration : 3378 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption

!
!
no ip finger
no ip domain-lookup
!
isdn switch-type basic-dms100
!
!
!
interface Ethernet0/0
 ip address 192.168.1.5 255.255.255.0
 half-duplex
 no cdp enable
!

!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
ip route 10.103.0.0 255.255.0.0 10.103.0.18
ip route 155.170.0.0 255.255.0.0 155.170.1.4
ip route 170.88.109.0 255.255.255.0 172.31.4.2
ip route 170.88.224.0 255.255.255.0 172.31.4.2
ip route 170.88.225.0 255.255.255.0 172.31.4.2

no ip http server
!
access-list 100 permit ip any any
dialer-list 1 protocol ip permit

end





Here is a remote config with the routes:

Current configuration:
!
version 11.1
no service udp-small-servers
no service tcp-small-servers
!
hostname
!
aaa new-model
enable
!
username
isdn switch-type basic-ni1
!
interface Ethernet0
 ip address 172.31.4.2 255.255.255.252
!
interface BRI0
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer idle-timeout 2147483
 dialer string 3774721
 dialer rotary-group 0
 dialer load-threshold 1 either
 dialer-group 1
 isdn spid1
 isdn spid2
 no fair-queue
!
interface Dialer0
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 2147483
 dialer string 3774721
 dialer load-threshold 1 either
 dialer-group 1
 no fair-queue
 ppp multilink
 ppp authentication chap
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 192.168.1.0 255.255.255.0 192.168.1.5
ip route 170.88.109.0 255.255.255.0 172.31.4.1
ip route 170.88.224.0 255.255.255.0 172.31.4.1
ip route 170.88.225.0 255.255.255.0 172.31.4.1
logging buffered
dialer-list 1 protocol ip permit
!
line con 0
line vty 0 4
!
end
0
 

Author Comment

by:FloppyDongle
ID: 8123977
Sorry, the router at the endpoint is a cisco 1600.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 7

Accepted Solution

by:
pedrow earned 600 total points
ID: 8125549
well, looks like you've got routing loop issues.

like this:
top router(hub) says:
ip route 170.88.109.0 255.255.255.0 172.31.4.2
ip route 170.88.224.0 255.255.255.0 172.31.4.2
ip route 170.88.225.0 255.255.255.0 172.31.4.2

bottom router (spoke) says:
ip route 170.88.109.0 255.255.255.0 172.31.4.1
ip route 170.88.224.0 255.255.255.0 172.31.4.1
ip route 170.88.225.0 255.255.255.0 172.31.4.1

These are opposite ends of a /30 network. So, hub says that to get to these networks, go to spoke. When it gets to spoke, it sees routes to those networks via the hub.

This is why I like dynamic routing protocols :)

Why do the spoke routers need anything other than a default route via Dialer0?

If you've got a hub/spoke switched network config, you might wanna go with ospf or eigrp as a dynamic routing protocol. It might make your life easier.

0
 

Author Comment

by:FloppyDongle
ID: 8125752
First, let me say that I am fairly new at this, and second I did not design and configure this setup.  I am not that familiar with dynamic routing, but I believe I need the loop because we have a pix 525 infront of our server, and it is a mix of ACLs and outside routes, when the network request from the spoke routers come in to the hub and then go to the pix to the server, it has to have a way to return the original address back to the spoke.  In our system the network printers have to have a static ip address associated with there prfile it can run on my server.  The printers ip address has to be loacl to the members network.
  The hubs routes:
ip route 170.88.109.0 255.255.255.0 172.31.4.2 point back to spokes local ip interface, and the spokes ip route destination is the default gateway for our members networks.  Everything works fine except I can't hit any other ip's on my extranet (192.168.1.x).  I don't know why that is.  192.168.1.10 works great, but that is it.  The spoke routers are sending all of the 192.168.1.x request back to my hub, but then it dies.  However the hub can ping the address that I am trying to reach.  Thanks for your help.

David    
0
 

Author Comment

by:FloppyDongle
ID: 8125824
I figured it out, thanks for the help anyway.

David
0
 

Expert Comment

by:SpideyMod
ID: 8138922
A request for refund has been made.  Experts you have 72 hours to object to a refund and state why.  I will return at that point to finalize.

FloppyDongle,
If you have figured this one out, please indicate your answer in a comment here so it can add value to our database.

Thanks all.

SpideyMod
Community Support Moderator @Experts Exchange
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8139458
FloppyDongle,
If you can comment as to what the issue really was and how you fixed it, we can at least add this problem/solution to the database, and still refund your points.
0
 

Author Comment

by:FloppyDongle
ID: 8141714
The issue was that we are not using any addresss translation, and I needed to put IP routes in the device I was trying to add so that it could route the address back to the proper gateway.  Thanks for your help.

David
0
 

Expert Comment

by:SpideyMod
ID: 8143118
lrmoore,
Good enough for a refund?  I have to defer to your great expertise in this area.

Thanks.

SpideyMod
Community Support Moderator @Experts Exchange
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8143216
I think Pedrow did nail it:
>well, looks like you've got routing loop issues.


As verified by FloppyDongle:
> needed to put IP routes in the device I was trying to add so that it could route the address back

Perhaps reduce value (perhaps to 100 points) and give pedrow some credit for pointing the direction?
0
 

Author Comment

by:FloppyDongle
ID: 8143334
Lets give Pedro 150.  I think that sounds fair.  Thanks

David
0
 

Expert Comment

by:SpideyMod
ID: 8143366
Points reduced to 150 per request.  You may now accept Pedro's answer.  Thanks all or bringing this to a successful conclusion that everybody can live with.

SpideyMod
Community Support Moderator @Experts Exchange
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8143721
thanks!
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8144011
as a final note, with a multi-router environment like this you might wanna investigate moving to the use of a dynamic routing protocol like eigrp or ospf.
0
 

Expert Comment

by:SpideyMod
ID: 8144129
Thanks.  I'll go ahead and force-accept this so we can be done with it.

SpideyMod
Community Support Moderator @Experts Exchange
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question