• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 296
  • Last Modified:

Unable to ...

Hi,

  Why do I get  "Unable to open include file's"   When Compiling to Object. or Run. How to go about it ?


Rgds
0
wzm
Asked:
wzm
  • 4
  • 3
  • 2
  • +3
1 Solution
 
akshayxxCommented:
Hi wzm,
we can answer the 'why' question only iff u tell exactly what u did, what command did u give ,
compiler ., OS , and other enviroment around you

Cheers!
0
 
wzmAuthor Commented:
Just the sample Hello.c and using tc.exe command and on a Win98 OS. - (which referring to <stdio.h>)

0
 
akshayxxCommented:
hmm now other experts can take on from here, i work on linux mostly,
btw did u check for any settings in the tc editor, and are u able to see the file on ur harddisk ?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
umangjoshiCommented:
may be path to the directory where your .h files are stored is wrong
0
 
cb068Commented:
Set the complete path of the .h file,
for example,if it is c:\include\stdio.h then use
#include "c:\include\stdio.h".
Before that find out where the .h file you are using is located using dir/s *.h command (mostly it will be in the tc\include directory
0
 
wzmAuthor Commented:
Hi cb068,

 Yes It is in tc\include; I've event set the path to it
 C:\TC\INCLUDE; - but still..
 
 but i'havent try with #include ... yet.

 S.O.S
0
 
wzmAuthor Commented:
Again cb068,

 No the syntax aint correct It should be like this "<   >".
 But still no. And Even I let it blank just #include < >  the message is the same.


 S.O.S
 wz
 

0
 
cb068Commented:
Did you try,

#include "c:\tc\include\stdio.h"

as it is in the syntax?? (please check if the file is there in that directory or not)
0
 
cb068Commented:
Please show me your code and I will be in a better position to answer your question....
0
 
cb068Commented:
You need not use "< >" in include....even "  " is sufficient while specifying absolute path
0
 
Mayank SAssociate Director - Product EngineeringCommented:
It is very simple:

Since you have the header files in the "c:\tc\include" directory, and you're using TC on Win 98, so you should go to the 'Options' menu on the Turbo C ++ editor, then choose 'Directories', and set the 'Include Directories' path to C:\TC\INCLUDE. Also, I guess the 'Library Directories' path must be wrong too, so just set it to C:\TC\LIB.

Hope that much helps!

Mayank.
0
 
rajeev_devinCommented:
may be the path specified in your #include does not match with the actual path. check it out
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 4
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now