how to enable file sharing win98


i'm using win98 and i'm trying to share my drive c:\, unfortunately the sharing feature is disabled when you right click the drive/folder. taking note that i have checked the file and print sharing under the network neighborhood.  

thanks in advance for those who can shed a light on my problem.

LVL 1
CenterisAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

suhasjsCommented:
You will first need to enable File & Printer sharing from Control Panel -> Networks (I don't remember the exact window name. u should be able to find it easily)
0
suhasjsCommented:
oops, i see that u appear to have already enabled this!
0
ridCommented:
Check properties for network client - logon properties. Primary logon should be Microsoft Network logon. I think you must do a login at startup, even if you use blank password.

Verify that your protocol(s) are properly installed.

Regards
/RID
0
KocilCommented:
Are you sure that the file and print sharing have been turned ON ?
If yes, the next posible culprit is your network is not up. Maybe you just pulled out your PCMCIA card (if you are working in a notebook).


0
SuperCitrixManCommented:
First look in your device manager, check and make sure your NIC drivers are intalled and working properly.  If you have no weird conflicts in the device manager then go to next step.

(Make sure you have OS CD on hand)
Right click network neighborhood, go to properties, check and see if Microsoft Networking is installed (most likely is) if it isn't there install it and that will fix it, if it is remove it (we will put back later.

Leave that up for a minute...

Go to start - Find - Files or Folders...
Search for *.pwl under your C:
Delete anything that shows up
(these are just dumb Win98 profiles they don't really do anything but cause problems, I'm removing them just incase you have a password problem, these deletes all windows type passwords)

Exit out of the find.

Back to the Network Neighborhood, we just removed MS Networking, hit okay... Yes to reboot.

We come back up with a Windows logon screen.  Type a username but no password and hit enter.  This clears out any password problems you may be having.  If you get asked for a password again leave it black and hit enter.  You will never see this again.

Now go back to Network Neighborhood and reinstall Client for MS networks, Also add File Print Sharing.  Set it up so that Primary Network Logon is Windows Logon, MS logon is not required for F/P sharing.   Hit Okay... yes restart.

When it comes back up you should not have any kind of logon screen it should bring you directly to a desktop, if you get a logon, check you settings you missed something or MS wasn't listening and you need to change that Primary Logon to Windows Logon again.  Anyway all we just did was reinstall your F/P sharing and cleared out any dumb profile jams.  You should be good to go.

Let me know what happens.  If C: still won't let you share we may need to pull out a tool to see if you are doing a system share on it, doubt it though, never seen Win98 do a system share, unless you have Exchange on it or something but who would do that...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.