Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Installing new fonts

Posted on 2003-03-13
4
Medium Priority
?
247 Views
Last Modified: 2013-12-06
How can I install new font in Red Hat Linux 8.0
Font like Tahoma.ttf

Thanks
Motaz
0
Comment
Question by:Motaz
  • 2
  • 2
4 Comments
 

Accepted Solution

by:
kreg earned 500 total points
ID: 8129581
Actually all you have to do in Redhat 8 is make a folder called .fonts in your home directory and put the font or fonts there, that is it.

Now if you want the fonts available for everyone on the system Here is what is in the release notes:

Red Hat Linux now uses Xft for fonts in GNOME and KDE, which uses fontconfig for configuring fonts. The old style Xft config file /etc/X11/XftConfig is no longer used or supported, having been replaced by the new unified fontconfig method of configuration. The fontconfig config file can be customized by editing /etc/fonts/fonts.conf file.

If you have fonts that you would like to add to your configuration, you can copy them to ~/.fonts (or /usr/share/fonts), and run fc-cache directory. The fonts will then be available.
0
 
LVL 7

Author Comment

by:Motaz
ID: 8135678
Thanks kreg for your reply, I copy it to my home directory and dit works for some applications, and another applications cann't see that font.

I tried your another solution, but I don't know here to copy  that file in /user/share/fonts and I cann't rn fc-cache-1 text file, it is not a script file.
Please tell me how can I run fc-cache-1 text file
Motaz
0
 
LVL 7

Author Comment

by:Motaz
ID: 8135772
I enable to run it in root user fc-cache in the directory /home/azzoz/.fonts
but still cann't get this font in all applications such as Kylix, and Open Office.

I get this font only in KText editor

Motaz
0
 

Expert Comment

by:kreg
ID: 8135904
Open Office is different... You need to run the Printer Set and there is a fonts installer there... basically you are just telling Openoffice where your fonts are.

Kylix I am not sure.

There are two font subsystems on Redhat... there is fontconfig which is what you used earlier with the fc-cache and there is the X core font subsystem, and therein lies your problem. Some apps aren't aware of the fontconfig system which is becoming the default.


For the X core font subsystem this is what I have done in the past with Older versions of Redhat:

http://www.justlinux.com/nhf/Fonts/Where_Are_My_True_Type_Fonts.html
0

Featured Post

[Webinar On Demand] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension . This reminded me of questions that come up here at EE along the lines of, "How can I tell the type of file from its cont…
Fine Tune your automatic Updates for Ubuntu / Debian
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses
Course of the Month11 days, 12 hours left to enroll

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question