?
Solved

Setting up WinXP with win98 client

Posted on 2003-03-13
15
Medium Priority
?
308 Views
Last Modified: 2013-11-16
Hi there

This is my first attempt at setting up a network. My main pc (that will be the server) is running XP Home edition, and has a Realtek RTL8139 Family PCI Fast Ethernet NIC installed.

The only client I have plugged in is a Win98 (non SE) with the same Realtec card. Connected to each other via a crossed cable.
The sole purpose of this network is for Internet sharing on the single 512K ADSL line I have.

Now I followed the WinXP network wizard 'TO THE LETTER' ... and installed the Win98 client via the floppy it creates. Set up the network name (default MSHOME on both pc's) and it all seemed to install fine. Upon trying to 'SEE' the other computers (on both the XP & 98) nothing shows up.
Now I know the cards are connecting together ok, If I shut down the win98 machine the XP machine tells me the network has been disconnected.

Is there something Im failing to do (I was under the impression that the wizard was all It took)

Thanks in advance - Matthew
0
Comment
Question by:o0matski0o
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
  • 3
  • +1
15 Comments
 
LVL 7

Expert Comment

by:dansoto
ID: 8130379
Do you only have on NIC on the XP machine?  If so, you need at least two.  One should be connected to your ADSL connection and the other should have the crossover to the 98 machine.  The second NIC should also have an internal IP Address (which the wizard should have assigned).

- dan soto -
0
 

Author Comment

by:o0matski0o
ID: 8130485
Hi -dan soto-

Thanks for your swift response.

Sorry I wasn't very clear in my post, BOTH machines each have a NIC card (when I said 'same' I meant identical card types).

Now I have checked the IP on the 98 machine, and its default setting is 'auto configure' (which seems to lag the machine on boot)
The XP machine also has auto configure set too.

Should I bet manually setting the IP's ?

Many thanks - Matthew
0
 

Author Comment

by:o0matski0o
ID: 8130518
Hi -dan soto-

Thanks for your swift response.

Sorry I wasn't very clear in my post, BOTH machines each have a NIC card (when I said 'same' I meant identical card types).

Now I have checked the IP on the 98 machine, and its default setting is 'auto configure' (which seems to lag the machine on boot)
The XP machine also has auto configure set too.

Should I bet manually setting the IP's ?

Many thanks - Matthew
0
Put Machine Learning to Work--Protect Your Clients

Machine learning means Smarter Cybersecurity™ Solutions.
As technology continues to advance, managing and analyzing massive data sets just can’t be accomplished by humans alone. It requires huge amounts of memory and storage, as well as the high-speed power of the cloud.

 
LVL 7

Expert Comment

by:dansoto
ID: 8130536
Sorry myself because I just reread my post and could have been clearer.  What I meant to ask was .. does your XP machine have 2 NICs?
0
 

Author Comment

by:o0matski0o
ID: 8130774
No the XP machine has just the one NIC, It has no internal LAN, only the plugged in card
0
 
LVL 7

Expert Comment

by:dansoto
ID: 8130902
hmm.. then I'm wondering how you have both the ADSL and the crossover on the same NIC ?

The configuration should be...

PC1 = XP Home
PC2 = Win98

PC1 should have two NICs.  One connected directly to the ADSL and left alone.  The second ideally would have a static IP adress (usually 195.168.0.1  SN=255.255.255.0).

The NIC on PC2 ideally would have a static IP on the same network (192.168.0.2 SN=255.255.255.0 GW=192.168.0.1).
Although you can use dynamic IP's (assigned by PC1's DHCP) I find it easier to troubleshoot with static IP's.

If you still want to use the Network wizard, you still need to have a second NIC in PC1.

0
 

Author Comment

by:o0matski0o
ID: 8131714
Hi

sorry the ADSL is plugged via a USB modem.

Now I've managed to find something. I checked my Lan card configurations, and swapped both cards from the default 'auto' Link Speed/Duplex mode to 10Mbps Full Duplex mode.

Now both pc's can see each other & you can access each of their respective shared folders/files (although sending large files is somewhat slow, and the lights on the NIC's flicker) but they only work on 10Mbps ... if I switch to 100Mbps they ignore each other again.

So now that they can talk to each other - what would I need to do to get the 98 machine to use the XP's ADSL access ? any ideas ??

Many thanks for helping so far.

Matthew
0
 
LVL 7

Expert Comment

by:dansoto
ID: 8131776
ok..
since you are able to see the other PC, the wizard should have configured it fine for you to use ICS.  What happens when you try to browse the web from the 98 machine?
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 8132549
first do you have link lights on the NIC's? this will indicate they are connceted and working
next can you ping each mahcine?
have you shared something on each machine (if not they won't show up in the other mahcine

http://www.wown.com/j_helmig/wxpwin9x.htm
and from a great expert lrmoore
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, et al.

-------------

Next, check your XP networking setup:

http://support.chartermi.net/support/pipeline/windows/winxp_network.html

Although this link says to set netbios over tcp/ip to "default", follow the instructions below...

-------------

Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..

----------------

For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)

----------------

Client for Microsoft Networks needs to be the primary network logon for all other machines

----------------

All machines are in the same workgroup


Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP

Click Start, click Control Panel, and then click Network and Internet Connections.

Click Network Connections.

Right-click Local Area Connection, and then click Properties.

Click Internet Protocol (TCP/IP), and then click Properties.

Click the General tab, and then click Advanced.

Click the WINS tab.

Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.

Click Close to close the Local Area Connection Properties dialog box.

Close the Network Connections window.

Step 2: Start the Computer Browser Service

Click Start, right-click My Computer, and then click Manage.

In the console tree, expand Services and Applications.

Click Services.

In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.

Close the Computer Management window.

References:

http://support.microsoft.com/default.aspx?scid=kb;en-us;318030

http://support.microsoft.com/default.aspx?scid=kb;en-us;314366

http://support.microsoft.com/default.aspx?scid=kb;en-us;315267

http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm

http://www.michna.com/kb/WxNetwork.htm




and for ICS
for step by step

see here

www.practicallynetworked.com/sharing/sharing.htm

http://www.annoyances.org/exec/show/ics


0
 

Author Comment

by:o0matski0o
ID: 8137682
Many thanks

Armed with all this info, I have managed to set the network up to a certain point. Now both machines can ping each other, share files & also share the printer.

Now the only thing (and main thing) that is not working is the Internet Sharing.

To recap :

Server XP machine currently on IP 192.168.0.1
Pings Client ok
Shares files with client ok
Shares printer with client ok
ICS all set & verified (as per instruction above)
Internet working ok on this machine.

Client 98 machine currently on IP 192.168.0.2
Pings server ok
Shares files with server ok
Shares printer with server ok
ICS status (icon in taskbar notification area) shows ICS switched on.
Test browser - NO CONNECTION


So basically everything seems to be running, but when you open the browser (ie6) on the 98 client it tries to connect to a page, but returns 'This page cannot be displayed' regardless of what URL you input.

Ive run the LAN connection setting wizard in IE - maybe its something im not setting there ?

Any ideas ?

Many thanks - Matthew
0
 

Expert Comment

by:andrewparsons
ID: 8139529
as well as an ip address you also need to set a default gateway and primary DNS Server on your win98 workstation.
to do this go to start --> settings --> control panel --> network --> TCP/IP -> Realtek xxxx --> properties
click on gateway tab and enter 192.168.0.1 and click add
then click on DNS configuration tab
enable DNS, in host box enter win98
in the 'DNS Server search order' enter 192.168.0.1 then click add.

restart the computer then give browsing the internet another whirl
0
 
LVL 41

Accepted Solution

by:
stevenlewis earned 300 total points
ID: 8139822
ICS status (icon in taskbar notification area) shows ICS switched on
you turned on the ICS on the wrong mahcine
ICS should be turned on on the host
on the host (the one with the modem)  go to the connection that you want to share, and share it
uninstall ICS from the 98 box first. ICS can only be running on one mahcine (the one that connects to the internet)
so, make sure that the LAN NIC on XP is set to 192.168.0.1
and then on the 98 box
ip 192.168.0.2
gateway 192.168.0.1
dns enabled and use the dns ip provided by your isp or 192.168.0.1
from a prompt on the host type
ipconfig /all |more
make note of the ip assigned by your isp
then on the client
from a dos prompt
type
ping 127.0.0.1
ping 192.168.0.2
ping 192.168.0.1
ping the isp assigned ip of the host
ping 206.169.61.185
ping www.experts-exchange.com
please post the results here


0
 

Author Comment

by:o0matski0o
ID: 8140514
Thank you andrewparsons.
I had set the gateway on the client, but alas still no responce when using the browser.

stevenlewis : I have set the ICS on the host, what I was refering to was the ICS icon on the client showing the Internet/Gateway/Client chain was active.

Anyhow - Yippee! you cured my problem stevenlewis! ..... but strange enough on another question by another user !

The problem was my MTU - I had to add a $tring to my registry to include MaxMTU 1472 (after finding the max MTU by pinging my ISP gateway)

Now everything is sorted - im even entering this answer from the Win98 client :)

Another happy customer ....
0
 

Author Comment

by:o0matski0o
ID: 8140541
Many thanks - everything sorted!
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 8140686
o0matski0o Glad we could help
Steve
0

Featured Post

2017 Webroot Threat Report

MSPs: Get the facts you need to protect your clients.
The 2017 Webroot Threat Report provides a uniquely insightful global view into the analysis and discoveries made by the Webroot® Threat Intelligence Platform to provide insights on key trends and risks as seen by our users.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will inform Clients about common and important expectations from the freelancers (Experts) who are looking at your Gig.
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question