• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 277
  • Last Modified:

CD-ROM Detecting Problem

In my CPU, I fixed the CD-ROM, inserted the cable, first end to IDE-1, core end to Hardisk and last end to CD-ROM, set the jumber setting by following instruction on the hard drive and the CD-ROM. Surprised, even though I set the correct jumber setting, it doesn't detect a harddrive as Master, but detect the CD-ROM as slave. Then I removed the CD-ROM, tried with harddisk only, this time it detected correctly. In BIOS setting also, cannot detect the Master with CD-ROM, without CD-ROM I can detect the Hardisk as Master. Can any one advice me whether the problem with installation method or in CPU?

0
osmjahir
Asked:
osmjahir
1 Solution
 
DanielSJCommented:
I think it is jumper issue. Recheck Master and Slave position. Sometime has to jump in BIOS setup to detect HDD and CD there too. Recheck and and let see what happens.
0
 
ShadowWarrior111Commented:
The best way is not to put the hard disk and CD ROM together on the same IDE cable. Plug the CD ROM to another IDE cable as all motherboard come with two IDE port.
0
 
lchristiansenCommented:
ShadowWarrior111 is correct.  Always try and keep harddrives and cd/dvd rom drive on different IDE lines. It is possible that the diffence in data speeds could be causing your problem. The reason is that the max data speed on the hard drives are faster then the cd/dvd rom drives.  And since each IDE channel has two Parallel connections per channel this means that each channel will not operate faster then the slowest device.  For example you just upgraded your harddrive to ATA 133 for better performance and you CD rom is still at ATA 33 and both are on channel 1.  You will not gain anything and will never notice a differnce because you will not go faster then 33mps.  
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
DanielSJCommented:
I think we can setup whatever we want as long as it is correct setup (Jumpers, Cable, BIOS, etc). If BIOS is not detecting 1 of drives, then there is problem. Also, if OS can not recognize drives, then there is problem. Yes, better way is not to put CD and HDD in same IDE cable, but it is not an issue to no recognize or detect the drives. OS or BIOS must detect or recognize the drives. If you have motherboard drivers, then try install the IDE control driver, let see what could be else.

Regards,
0
 
GuillonCommented:
Try setting the jumpers on both the hard drive and CD-ROM to cable select.
0
 
55chevyCommented:
As DanielSJ stated, it definitely sounds like a jumper issue.
Many harddrives have a jumper setting to set it as a Master (in a dual drive setup with a Slave drive) or a different jumper setting if the drive is to be used all by itself without a Slave drive affixed to the same ide ribbon cable.

If such a harddrive was set up as a Master (with no Slave attached) then there would be a good chance that the BIOS would not detect it without the Slave drive attached to the same ide cable.  You mentioned that this is the case.  Recheck those Hard Drive jumpers!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now