Boot up hang

I am trying to repair a W2K boot up problem where the system hangs when a hard drive is attached.
When a hard drive is not attached the system will only then boot up from the floppy.
The boot order is set to boot from floppy first then hard drive second.

Am I missing a trick?

tomteaAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Mayank SConnect With a Mentor Associate Director - Product EngineeringCommented:
Check that the jumper has been put at the appropriate position on your hard-disk. In case the jumper is required and is missing (or in an incorrect position), then if you don't put a floppy either, it won't boot because the first boot device (floppy) and second boot device (hard-disk) will both fail.

Mayank.
0
 
pratiganCommented:
Yes... obviously the harddrive setting are not correct.  as Mayank indicates you need to check the jumpers on the harddrive to set to master.  Double check the IDE connection and powersupply connections to make sure that connected properly, red of power supply facing the IDE connection.  Also the IDE cable black line facing the red powersupply connection.  Next check your BIOS to ensure the harddrive is set... use Auto.
You should be all set.  
0
 
CeLLuSCommented:
Yes, check the jumper setting on your hard drive, if I’m not mistaken this hard drive is probably the only thing that is hooked up to the IDE cable.  If this isn’t the case, remove everything from the IDE cable except the hard drive.  This way you can make sure it’s the hard drive that is causing the problem and not something else.  This thing can also happen if you recently add new hardware that is not compatible with your system.  Anyways set the hard drive setting to master and start your system.   If you are still having the same problem get another hard drive that you know is working properly and swap it to see if the hard drive is bad or incompatible with you system, yes I know sounds strange but it could be the case.  What kind of HD is it?  You can change the setting in your bios to boot from HD first but it really shouldn’t matter if you boot from the floppy and then from the HD.  A bad IDE cable could also be causing this problem (assuming it is not SCSI).  What kind of system is it?  Do you hear and beeps or some kind of noises when you start your system with the HD installed?


Good Luck,    
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
tomteaAuthor Commented:
OK thanks for the responses. To fill you in further:
- This is the only drive hooked up to the system.
- I did recently install an IDE controller card to support a new array, which is now removed.
- I have used other hard drives, and had the same response.
- Differernt cables have been used.
- I set the BIOS settings to DEFAULT - and have been able to use a boot CD/floppy - and have been able to try to repair the W2K system - which recognises the W2K install on the hard drive, but once the bootable CD's and floppys are removed it hangs once more on restart.

Could the BIOS be corrupted in some way by trying to add the new IDE controller (Fsat Track 100 TX2)? If so how do I correct this?
0
 
SunBowCommented:
ditto,
Basically, if IDE you should have it configured specifically as Master and placed alone on Primary IDE cable. If drive was not delivered with unit it may be pre-configured as Cable Select, which sometimes does not function well for automatic config, or as a slave, assuming purchaser already has a Master - which won't work out when assumption not met.

If drive is on Secondary IDE, odds are user also has other device such as CD that is older and slower. Having an HD and CD on same cable can also lead to malfuction. So ensure HD is Primary Master to start out with, and go from there.

On bootup when you check BIOS for boot sequence, also check its config option for whether to allow multiple drives or to censor the primary or secondary etc. Many bios do have such a defined limit, but I have yet to have problem result from just letting BIOS permit all possible IDE configurations, whether they are used or not. So ensure that they are permitted.
0
 
SunBowCommented:
> Could the BIOS be corrupted in some way by trying to add the new IDE controller

Not really. What more likely happens is that the controller has its own builtin BIOS, that kicks in after the mobo BIOS completes its POST. So that is what you'll have to configure. Some of them permit config using other keystroke, such as <cntl>A for Adaptec. For yours, you'll best handle by reviewing documentation, or pay visit to vendor's website for support of product.

Can you remove controller and test plugin to Mobo?
0
 
Mayank SAssociate Director - Product EngineeringCommented:
>> - This is the only drive hooked up to the system.

Once, my system gave me the same problem though it had only one drive hooked to it - it was the jumper which solved it.

>> have been able to use a boot CD/floppy - and have been able to try to repair the W2K system - which recognises the W2K install on the hard drive, but once the bootable CD's and floppys are removed it hangs once more on restart.

Then why don't you use a CD which has the installer for Windows?

Mayank.
0
 
CeLLuSCommented:
If you have removed the IDE Controller and you still aren't able to boot from your HD and you are sure that the settings are correct on both your BIOS and HD jumpers (HD as master and on primary ide) than as a last resort I would start considering flashing the BIOS.  What kind of motherboard do you have.  Visit your motherboard manufature support website to see if they have anything on issues similiar to yours and also download the latest version of your BIOS available.  I would also visit the manufacture website of the IDE controller you recently installed.  Could it be possible that this problem started after you installed the IDE controller.  

Good Luck,
0
 
sathishkumar_sriCommented:
If you have installed a new IDE controller card previously then the card probably disabled the on-board IDE controller. Try enabling it from the BIOS. If the status in the BIOS is shown as enabled. Disable it and restart the system and then enable it.
0
 
LucFEMEA Server EngineerCommented:
tomtea,
No comment has been added lately (322 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: Award points to mayankeagle http:#8135680

Please leave any comments here within 7 days.

-- Please DO NOT accept this comment as an answer ! --

Thanks,

LucF
EE Cleanup Volunteer

0
 
Mayank SAssociate Director - Product EngineeringCommented:
Please proceed with that recommendation.
0
All Courses

From novice to tech pro — start learning today.