Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 337
  • Last Modified:

IE shows jpeg but not gif files

I've been doing some web design and came across the following problem: when I open an html document locally, all the jpeg's show, but the gif's dont.  This is odd because when I'm online, both jpeg and gif files view correctly.  It would making web designing easier for me if I could actually see the gif's that I'm trying to place on my site.  Any advice?


chris
0
murf518
Asked:
murf518
  • 4
  • 4
  • 2
  • +2
1 Solution
 
stevenlewisCommented:
check the code, and make sure the names are correct, and they may be case sensative
also make sure the path is correct
0
 
murf518Author Commented:
ive check this thoroughly,

the path and names are correct.  ive saved the gif files with the same name, with the same path as jpegs and the jpegs show.  any other suggestions?
0
 
BillDLCommented:
Are these .gif files animated or static?
Are you viewing the final pages in "Edit" mode or in your browser as a standalone web?

The reason I asked about the edit mode is that maybe they are animated gif's which start on a blank before displaying the actual content frames and you would not always see them depending on which editor you are using and whether the animations are set to repeat any number of times when the page is previewed or loaded into the browser.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
ChapMansCommented:
I need to know if the gif were saved locally. If not that is the reason why the gif file are not showing when you view the html locally.  Try to re upload the gif locally and see if that will help.
0
 
MereteCommented:
are your gif's stored on your hdd, and they don't open, go to view at the top of your page eg in my docs, then folder options>file types> cheak that the gif is there under g usually, and cheak if your jpeg are there also. Notice what your jpeg are opening with. if the gif is not there make a new type .in description type>> type in gif file
ok. when you try to open the gif does it now ask you to open it with? if so I chose internet explorer as gif's are usually animated pictures. Hope this helps. regards Merete
0
 
murf518Author Commented:
ok - heres the situation:

1. the gif files are static, not animations
2. it is listed under folders->view files along with jpeg
3. gif files open fine when when i try and open them, but don't show on the webpage im making
4. all the paths and file names are correct
5. i havent ftp-ed the page yet, when i say that i cant view the files ,i am refering to locally, with everything on my computer

any other suggestions?
0
 
BillDLCommented:
No, sorry murf, the only other idea I had was that maybe the images have been optimised when you saved them and partially transparent pixels are blended in such a way that they may be viewable in your image editor, but some of the encoding is lost or cannot be interpreted and displayed on a web page.

Either that or maybe you optimised them as "interlaced" and somewhere in the decoding, the display is being slowed down to a crawl so that it appears that they are not going to show at all. Probably a logical thing here which you have tried already, but does anything different happen when you "Refresh" the web pages?

Unfortunately these are only half-baked ideas maybe to jolt another suggestion from somebody else, and apart from going through the whole process of optimising the .GIF's again to check this, I can't suggest any further explanations.  I've never seen this before.

Sorry
0
 
BillDLCommented:
Here's another idea (assuming you are using Internet Explorer): Go to Tools > Internet Options > Advanced tab and find the "Multimedia" section.  Try unchecking "Smart Image Dithering".  This is the only thing I can think of which might cause it to differentiate between a .GIF and a .JPG image.

I reckon maybe you should ftp just a few linked pages as a test to see if this is isolated to your PC's settings, or maybe write the web to CD and try it on somebody else's PC.
0
 
MereteCommented:
just a last thought, have you cheaked the preferences or settings for your web page in powerpoint or frontpage, could be some settinmgs there stopping them that maybe linked somehow. Its most curios...Regards Merete
0
 
ChapMansCommented:
3. gif files open fine when when i try and open them, but don't show on the webpage im making

Recheck the path again, this problem happened to me when I change the path where the photos are located.  I transferred them to a different folder and I forgot to edit the HTML that was coded on the web page.

And also check the filename if they are the same with those files you've saved in your FTP Space.
Hope this help.
0
 
murf518Author Commented:
whats weird is that if i ftp the files, all the gifs view fine.  its just locally that they dont show in internet explorer.
0
 
murf518Author Commented:
fixed it-

i realized that corel photoshop had stolen the gif extension.  i uninstalled corel since i use photoshop anyway.  then created the gif file type.  when its has its own file type and isnt in with corel's, everything is fine.  i had tried creating the gif file type before but couldnt since it was already listed under corel.  thanks for all the suggestions, they were all useful, , but i think BillDL gave the most useful advice that pointed me in the right direction.
0
 
BillDLCommented:
I use Corel Printhouse Magic, Corel Photohouse, Paint Shop Pro, Irfanview, and a good few others.  I have selectively kept as many files associated with Paint Shop Pro for this very reason and just use the Shift + Rt-Click > Open With approach to open them with a chosen application other than Paint Shop Pro.

I did find that Corel seems to be the guiltiest at assuming that you want them all associated with it.

I am puzzled, though when you say that "Corel had stolen the .gif file type and that you therefore couldn't Save As .gif because it was already listed under Corel".  A file association usually only means that the file type will "Open With" that associated application when double-clicked.  No matter how many imaging applications you use, there whould always be a "Save As" option to save it as a .gif, and that .gif file should always be truly that.

If you were to simply rename a .bmp file as a .jpg file, it won't become a .jpg file and Windows Paint will tell you this.  The file's whole makeup is created by the programme as it is saved into that file type.

This factor should also have absolutely nothing to do with the fact that the image won't display on a web page unless the file is not truly a .gif file ie. it has been renamed as another file type or became corrupted by the application when it was being saved.  Try and rename a .txt file as a .gif and see if it will display when linked onto a web page.

It looks like your image editor hasn't been saving them with the proper compression algorithms possibley due to some corruption as I touched on when I said earlier: "the images have been optimised when you saved them and partially transparent pixels are blended in such a way that they may be viewable in your image editor".

I'm glad you have sorted this out, and good luck with your web design.  See you in the JavaScript section :-)
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now