Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 269
  • Last Modified:

Windows 2000 DNS Suffix Issue

Hi everyone,

I just upgraded an NT domain from 4.0 to Windows 2000 Active Directory. Now I am having a problem with only some Windows 2000 Pro workstations. They can log into the domain no problem. But their DNS is not working right. They are pointed to the proper W2K DC DNS server.

However, when you go into the properties of My Computer and then the Network Identification tab, the Full Computer Name shows the computer name without the AD DNS suffix (.local). If you go into Properties and then More from here, you can set the Primary DNS Suffix to ".local" and then everything works fine.

I've done a lot of these upgrades, and never seen anything like this. Again this is only on some of the W2K computers. Others dynamically changed their computer name as they were supposed to and everything works fine.

As another note, there is a DNS suffix being pushed out by DHCP for the company's public web server XYZCompany.com. This is an appended DNS suffix so they can access the website internally. Could this be the problem? When we created another zone in DNS called XYZCompany.com and added a few necessary host records, the computers with DNS problems could resolve things no problem.

So the questions are, why hasn't the primary DNS suffix change dynamically on some of the computers and why is this XYZCompany zone addition a working temporary solution.

Thanks for any thoughts.

--Jim
0
jimmyj352
Asked:
jimmyj352
  • 6
  • 5
  • 2
  • +3
1 Solution
 
pjbcbaCommented:
Just a thought from looking at my own W2K workstation (manual clean install, not upgraded)

My computer also only shows its short name under My Computer / System Properties.

If I run ipconfig /all in a command prompt, I notice that my DHCP assigned domain suffix *is* listed cirrectly, but as "Connection Specific" to the LAN card, and the computer's Primary suffix is blank.

So is it the case that the machines that appear to have no primary suffix have multiple network adapters (and that can include dial-up or virtual adapters)?
0
 
jimmyj352Author Commented:
I just had her (the customer) run IPCONFIG /ALL on a "working machine" where the information on Network Identification shows the correct full computer name and then on a "non-working machine" where it does not.

On the working machine, it show the DNS suffix as the ".local"

On the non-working, it show the DNS suffix as the XYZCompany.com

That makes sense to be where the problem is at, but why on only some computers... how can that be fixed before Monday when all the users roll in?

Thanks.
0
 
VahikCommented:
try using ipconfig /flushdns and then ipconfig /registerdns and go to non working computer tcp/ipconfiguration make sure the ip in the DNS is typed to correct DNS like "local"
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
VahikCommented:
I was talking about the IP address of the DNS
0
 
jimmyj352Author Commented:
I'm having her try the IPCONFIG /FLUSHDNS and /REGISTERDNS, but most of these workstations were already off, so I thought the DNS cache would be started over regardless.

-- Jim
0
 
VahikCommented:
check the DNS tcp/ip also make sure is the right dns typed in.  they should flush dns when u start the computer but sometimes the machines dont flush dns from their cache specialy when a new dns is been added to domain.
0
 
VahikCommented:
If this think doesnot work there is another thing u could try .One of the machines that has problem us disjoin and join again to domain see if that works better.
0
 
robcom99Commented:
If these computers were upgraded from NT4, it could be that some of them had the domain manually set to XYZCompany.com in TCP/IP network properties while others did not.  If this was the case, that domain name would have been transferred to the DNS suffix for the machine.  You can check on those machines that are not working by looking at the properties for the local area connection.  Click on advanced and then do to the DNS tab.
0
 
trywaredkCommented:
Remove the workstations from the domain, reboot, and add them to the domain again.

Remember to have the password for the local admin user, or have a local user, being member of the local admin group before You remove the workstation from the domain

Many Regards
Jorgen Malmgren
IT-Supervisor
Denmark

:o) Your brain is like a parachute. It works best when it's open
0
 
jimmyj352Author Commented:
I can remove and add them to the domain, but why wouldn't I just do what we tried... appending the .local to the machine name in Network Identification. That's what needs to be done and is much simpler.

I'm looking to find out why this isn't happening dynamically like it is supposed to... I already know how to fix it manually.

Thanks for the thoughts though.

-- Jim
0
 
VahikCommented:
have u checked the box in ur DHCP server under DNS

"automaticly update DHCP client information in DNS"
0
 
jimmyj352Author Commented:
That will update their A records and PTR records in DNS on the server using DNS Dynamic Updates, but won't make a difference as far as changing the client side...
0
 
VahikCommented:
yes but once u check that box u have the other box availabe "enable updates for DNS clients that do not support dynamic updates" even though win2000 should update dynamically.
0
 
jimmyj352Author Commented:
That will still only be server-side updates though...
That box is for 9x and NT clients so they get their records put in or updated in DNS, but it still doesn't do anything on the client side... or am I looking at this wrong?

--Jim
0
 
cempashaCommented:
This question is still open and getting old. If any of the comment(s) above helped you please accept it as an answer or split the points who ever helped you in this question. Your attention in finalising this question is very much appreciated. Thanks in advance,

****** PLEASE DO NOT ACCEPT THIS AS AN ANSWER ********

- If you would like to close this question and have your points refunded, please post a question in community support area on http://www.experts-exchange.com/Community_Support/ giving the address of this question. Thank you      

Pasha

Cleanup Volunteer


0
 
trywaredkCommented:
:o) Glad I could help you - thank you for the points
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 6
  • 5
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now