configure peer to peer

Ok...

Right now, I've got 3 computers running through a linksys router.  

Win95, win98, and WinXP


All three now see the internet after my last Q:
http://www.experts-exchange.com/Miscellaneous/Lounge/Q_20550280.html



I've got all three getting their IP's automatically now that I've fixed the DHCP settings in my router.

However, right now the Win98 and Win95 machines can see each other through Network Neighborhood, but WinXP can't see the network, and they can't see the WinXP machine.


What did I mess up???  



BRUNO
LVL 18
brunoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stevenlewisCommented:
Well I don't know for sure, but you may be using NetBEUI ont he 95/98 boxes
check and see, and if so, add it to the XP box
http://support.microsoft.com/support/kb/articles/q301/0/41.asp

now having said that
http://www.wown.com/j_helmig/wxpwin9x.htm
and from a great expert lrmoore
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, et al.

-------------

Next, check your XP networking setup:

http://support.chartermi.net/support/pipeline/windows/winxp_network.html

Although this link says to set netbios over tcp/ip to "default", follow the instructions below...

-------------

Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..

----------------

For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)

----------------

Client for Microsoft Networks needs to be the primary network logon for all other machines

----------------

All machines are in the same workgroup


Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP

Click Start, click Control Panel, and then click Network and Internet Connections.

Click Network Connections.

Right-click Local Area Connection, and then click Properties.

Click Internet Protocol (TCP/IP), and then click Properties.

Click the General tab, and then click Advanced.

Click the WINS tab.

Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.

Click Close to close the Local Area Connection Properties dialog box.

Close the Network Connections window.

Step 2: Start the Computer Browser Service

Click Start, right-click My Computer, and then click Manage.

In the console tree, expand Services and Applications.

Click Services.

In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.

Close the Computer Management window.

References:

http://support.microsoft.com/default.aspx?scid=kb;en-us;318030

http://support.microsoft.com/default.aspx?scid=kb;en-us;314366

http://support.microsoft.com/default.aspx?scid=kb;en-us;315267

http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm

http://www.michna.com/kb/WxNetwork.htm




0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stevenlewisCommented:
Bruno, XP home or Pro?
0
brunoAuthor Commented:
it's Pro....

gonna take me some time to go through all your suggestions there....first thing I noticed tho is i think i turned on the firewall setting in the advanced settings...will try to turn that off.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

brunoAuthor Commented:
yup, turned it off, and right away all my other stuff showed up.


good enough for now.

will look over some of your other suggestions probably tomorrow or monday night.

now that this is working, i'm off the bar!

Will leave open just for now, but the points will be yours.  Guess I should do some more research before going into the advanced settings next time.



BRUNO
0
brunoAuthor Commented:
ah nevermind no need to leave open, that certainly did the trick and got me access to my files.

if i want to deal with the firewall at a later date, i'll just ask more q's...


Thanks man!


BRUNO
0
stevenlewisCommented:
OK, you may have some permission issues with accessing the folders on Pro
If so, turn off simpified sharing
http://www.microsoft.com/windowsxp/expertzone/tips/september/stevens1.asp
and
Run local security policy editor from control panel admin tools and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled and make sure guest account is enabled


then on the individual floder you want to share, right click choose sharing, name it, then click the security tab, and add the accounts youwant to have access (or add the guest account if you aren't really security consious, or security isn't a concern)
0
stevenlewisCommented:
Bruno, again a pleasure *grin*
BTW, I leave the default firewall off (not very configurable), and use zonealarm on mine
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
File Sharing Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.