Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 315
  • Last Modified:

Mounting problem

Hi,

On my G4 OS9.2.2 I have 2 Drives. then I stared one day it asked if I wanted to initialize the slave drive??? and it did not mount. I tried to fix it in disk program in application folder but it failed then I tried Norton 6.0.3, it failed. I can see the drive and probably format it, but I need the information on the disk badly. Is there something else to do? can I format in a other way? only the drivers? or can I fix the drive? It's a Seagate Barracuda 40Gb.
0
shoreside
Asked:
shoreside
1 Solution
 
weedCommented:
If rebuilding the volume structure in Drive 10 or Disk Warrior doesnt work (you might want to get either of those programs) youre probably out of luck. If a drive is having physical problems there's often not much you can do.
0
 
rsandeCommented:
if that doesn't work, try hooking it up to another computer and see if they can see it. if so, copy your files off, reform, and move your files back on. you might want to persuade your friend to keep your files for you just in case it doesn't work, or you can transfer them via lan, net or cds.

I've had issues with seagates before too :'(
0
 
goldmanlockeyCommented:
If none of the above mentioned utilities work, and you have an OS X installer disk, boot off of this and run "First Aid" from the disk utility.  This essentially is equivelent to running FSCK from the command line.  Repair it repeatedly until it reports no errors and then reboot into OS 9.  If all else fails, and the data is important, send it to drivesavers.com for recovery (can be expensive however).
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
aregnerCommented:

It sounds like your disk driver has become corrupted causing your disk not to mount at startup.  I say this because you can get Norton's to locate missing disk (doesn't require loading the disk driver) and check the data on the drive.  

Update your disk driver using apple's Drive Setup application located in the Utilities folder inside the Applications folder.
0
 
SwiftAngelCommented:
I have a Seagate as well in my power mac...On G4s there has been some concern(correct me if i got the make wrong) that the hard drive controllers can suddenly become corrupted and will go through drives like a laser printer goes  through paper. Try switching the  drives...run the slave in Master and disconnect the other drive. This might boot the drive(if you have a burner burn all your important info using this drive..) But  if might ruin its chances at becoming a valuble slave again because it might need to be formatted in order to rescue the drive itself.
0
 
phowsonCommented:
Wiebetech sells a little device that will allow you to convert the drive into a firewire drive. I think they run about $150 or so. Simply remove the drive and the jumpers and plug it into the wiebe tech thing (can't remember the name) and plug it into the computer. This will eliminate the issue of it being a slave drive and should allow you to mount the drive on the desktop. Make sure you get the bus powered one and then you won't have to worry about plugging in another device. Then you can get a new hard drive to replace the flaky one (if I remember correctly the G4s can take up to a 120GB HD) and hopefully copy everything over from the old flaky drive, reformat it and use the space on the old drive for storing music for iTunes.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now