?
Solved

Dual boot Mandrake 9 & Win XP trouble?

Posted on 2003-03-16
14
Medium Priority
?
288 Views
Last Modified: 2013-12-06
First I am new in the Linux world (must add I do enjoy it so far), I have it installed as the only OS on one of my boxes now. I tried to do a dual boot with Win XP and Mandrake 9, to which when it comes to the boot screen, where you make a selection (linux....or windows) after i select Linux it hangs on the INIT screen and won't do anything. It will still boot into windows after a shutdown and I select windows. I was looking for an answer to this problem, because I am also wanting to do a dual boot of the same using WIn XP home & Mandrake 9 on my latop. I have partition 8. So all I need know is wisdom & knowledge, and thats why I'm here. LOL Please any help will be much appreciated.
0
Comment
Question by:operatr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
14 Comments
 
LVL 2

Expert Comment

by:EmbeddedMind
ID: 8149771
First what bootloader are you using? You're not using the Boot Magic software are you? And how did you install each os, I mean what order? Also, what boot loader are you using for MDK is it LILO or GRUB ?
*Embedded
0
 

Author Comment

by:operatr
ID: 8149843
Bootloader? = "don't know, sorry"
Bott Magic? = not sure
OS order of install? = Win first then Linux
MDK boot loader? = Not sure I just put it in the CD drive and went through the steps... I know that was probably stupid, and feel free t treat me that way, just teach me about what i did wrong so I won't look like an idiot all my life...well just tell me how to fix it, don't worry bout the idiot part it would be a waiste of your time LOL
Thanks for the quick reply
0
 
LVL 20

Expert Comment

by:Gns
ID: 8150779
From this we infer that you have written LILOs frist stage loader to the MBR (Mdk9 defaults to LILO on the MBR), and that LILO (for some reason as yet undetermined) wont boot linux...
To make sure:
Is the "Choose operating system" screen semi-graphical and does it mention any "identifying strings" like "Welcome to Mandrake" or "Operating System Chooser"?

Did you make a bootfloppy for Mdk?

We will try to determine why it fails, as well as the best order of bootloaders (and which to use), but it might be an iterative process taking a bit of time:-).

Some basics:
An operating system needs "help" starting.
Programs that perform this help are often called "boot loaders" or "bootstrapers" (since they literally get hold of the bootstraps (provided by BIOS etc) and take of into flight (like Baron von Münchausen(sp?))).
For windows XP/2k/NT the boot loader is called ntloader. For linux there are several (depending on the CPU/architecture for non-ix86, you have MILO, SILO etc). On ix86 you have a choice between LILO or GRUB mainly (loadlin don't work with NT and up).

The BIOS will try to load a boot loader from the Master Boot Record (MBR). This is a very small area (512 byte) on the harddrive the the BIOS percieves as the "first" drive. All drives in an x86 architecture system will have this reserved area, but only the first will be used. Older windows versions (DOS graphical shells really;-) relied entirely on the BIOS finding the drive/partition and thus IO.SYS (which can be viewed as the DOS bootloader:-).
Further there is a small reserved area (also 512 byte) at the beginning of each partition that is called a "partition boot record", where an operating system might store a boot loader too.

Now, there really is to little space in the boot record to store a program that can do all the fancy boot stuff todays OSes need, so the bootloader usually only stores a small "first stage loader" there that can find "the rest" (called the second stage loader) which will present you with menues and such ... and finally boot up the selected OS.

So to boot any operating system, you need to use a bootloader that knows how to start that OS. When you use one bootloader to start another (that in turn start the OS you want), that is called "chainloading".

Our goal here is thus to either chainload LILO or GRUB from the ntloader, or the other way round.

The process of booting is dependent on several factors ... which might not want to play (BIOS is usually the prime suspect;-).

Don't hesitate to ask if something is unclear, we've all been "idiots" at some stage of our lerning;-).

And do provide the info I asked for... It'll be a starting point in unraveling what's up.

-- Glenn
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:operatr
ID: 8153447
The help is plentiful, and I am thankful. In answer to the questions:
Choose operating system? = it says nothing that you mention, it is a somewhat GUI, where the text using shows things being loaded. It just does the first line, something like, "Mandrake blaa blaa 2.3****...INIT" and thats all.
Bootfloppy = no 'ser, do i need too

I hope this clears the confusion a lil better, I am willing to take the time. I am actually having trouble with my fathers PC (the one I speak of) he has seen Linux on my box, and said hey lets try this on mine, but don't lose windows yet. So here I am. LOL
0
 
LVL 20

Expert Comment

by:Gns
ID: 8154605
It would have helped to have a bootfloppy, since then you could have booted up Mdk from that, and let us inspect things that matter to bootloaders "from the Linux side", so to speak.

This complicates things a little bit.

Hm, while we're thinking on what could be the best strategy onward, could you please tell us as much as possible about the machine?
How many hard disks are there, how big, is it a "branded" computer (compaq, dell whatever...)?
That type of thing.

Also note that what you told us now ... looks like you actually boot linux, and that it gets quite some way before somehow failing...
This might be an X setup problem, in that case, tell us a bit about the graphics adapter, monitor, mouse...

-- Glenn      
0
 

Author Comment

by:operatr
ID: 8161045
The machine:
Gateway AMD 950, 512 MB Ram, CD-RW, 1 40GB Hadr drive, GRaphics card is a 16MB not sure of brand came with unit I will try to get this info soon.
Hope this helps. Thanks
0
 
LVL 20

Expert Comment

by:Gns
ID: 8162914
While waiting for that, could you try the following:

At the "select OS" screen, instead of choosing an OS, press the escape key (<Esc>).
This should switch you to a textmode bootloader if using LILO. The prompt should read
LILO:
At that prompt, you can type
linux 3<Enter>
This should start loading linux, but boot up without the possibly missconfigured X.
After a successful bootup you should be presented with a login: prompt.

Report back here if the above is true for you.
To reboot, you can press the magic three-finger-salute (<Ctrl>-<Alt>-<Delete>;-).

-- Glenn
0
 

Author Comment

by:operatr
ID: 8163048
ok, when I do the above procedure (<Esc>), I come to a Linux boot floppy. prompt. I type linux 3 and it goes back to saying Booting 2.38 but then freezes again. Not sure what I have done here. I may be the first to make Linux not work. LOL Anyway I will stay at it, as long as the help is here. If needed I guess I could wipe Linux off the drive couldn't I, then start all over with just Windows on the drive? I am game for most anything to get it working.
Thanks Glenn
0
 
LVL 20

Expert Comment

by:Gns
ID: 8165090
And there is no error messages "at the freeze time"?

-- Glenn
0
 

Author Comment

by:operatr
ID: 8172008
No se'r, it just stops  the cursor stops blinking and all.
I have been out of pocket and away from the machine, but i will get all the details gathered this weekend if i can. I am still trying to find a way to do the dual boot on my laptop also, but i will get this one first and learn from it. Thanks Again.
0
 
LVL 20

Accepted Solution

by:
Gns earned 240 total points
ID: 8173197
Ok, we need to go into the installed Mandrake and see what can be found there (if anything).

The installation media contains a good enough rescue mode boot.

Could you try verifying that it can boot this by
1. insert installation CD #1 into the drive
2. Boot up:-)
3. At the first "splash screen", press <F1> (or whatever, Just do it as it says on the screen;-). This should bring you to a prompt.
4. type in "rescue<Enter>" at the prompt. This should attempt to boot up a minimal system that can be used to access/modify the installed system.
5. After a while you should be presented with a command line (and just before that be informed that your ondisk system has been mounted at /mnt). You can then "switch" to the ondisk system with "chroot /mnt<Enter>".

This should lead to you running the rescue modes kernel, while in all other respects running on the ondisk system.
You can now inspect your /etc/lilo.conf file, run "fdisk -l" (you should copy that info to paper/floppy and present your findings here.
It could be a large disk problem, but I'm not too sure about that.
Look at the /var/log/boot and /var/log/messages files to see if there is any prominent errors in them... probably near the end. If you could quote the last bit here, that might help too.

Use "less -e <filename>" to look at textfiles... You should be able to copy files to /mnt/floppy with the cp command (worst case: you'll have to "mount -t vfat /dev/fd0 /mnt/floppy<Enter>". Be sure to have a floppy in the drive, and remember to "umount /mnt/floppy<Enter>" before removing it).

What else... Ah yes, How old is the computer model in question? If it is more the 4-5 years old... there might be some irritating BIOS issues ...

-- Glenn
0
 
LVL 20

Expert Comment

by:Gns
ID: 8173212
Ah, sorry you answered the last bit already... I'm a sloppy reader;-).

-- Glenn
0
 

Expert Comment

by:CleanupPing
ID: 9087698
operatr:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
LVL 2

Expert Comment

by:TheWeakestLink
ID: 9288599
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
Accept comments from Gns as answer
Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

TheWeakestLink
EE Cleanup Volunteer
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will explain how to establish a SSH connection to Ubuntu through the firewall and using a different port other then 22. I have set up a Ubuntu virtual machine in Virtualbox and I am running a Windows 7 workstation. From the Ubuntu vi…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses
Course of the Month15 days, 2 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question