?
Solved

98SE pc not visible to XP Pro pc in NW

Posted on 2003-03-17
17
Medium Priority
?
293 Views
Last Modified: 2012-05-04
I have been searching for help on this for days.  I guess its way past time to just ASK!

Caveat:  I am in waaay over my head on all this.  I don't know XP very well, and did not come to it through NT or 2000.  I also don't fully grok the nuances of networking, so forgive me if I seem a bit dense or something at first.

OK.  My situation is similar to this other posting here which I have combed through for tips already:  http://www.experts-exchange.com/Networking/Q_20482550.html  However it is more similar to the situation he briefly mentions his friend having, than to his own problem.

I have:
Win XP-Pro Notebook and Win98SE notebook connected to Siemens Router with four-port switch, and from there, to the internet via DSL modem.  The DSL works fine on both machines.  

The 98 machine finds the XP machine in Network neighborhood, but the XP machine does not find the 98SE machine, although it did ONCE - after I first enabled "NetBIOS over TCP/IP" on the XP machine, which had been on "auto" (apparently auto ='d "off").  

I can ping the 98 machine both by IP address and by name, but NET View gives "system error 53".  (searching for that error string is what led me to the NetBIOS point, here:
http://support.microsoft.com/?kbid=263648

It has not worked since that one time, and unfortunately I don't know what changed.  I made no adjustments to the settings. Only subsequent power off / reboots on each machine, more than once.  
I figure there maybe something inthe XP startup sequence that somehow reset the change I made, but the NetBIOS setting is still enabled.  I then repeated the instructions from the KB article but it did nothing.

Config data:
router has DHCP enabled.  
Both machines are in workgroup MSHOME
XP machine is logged on to user account with administrator status.
98 machine is logged on as default user (i.e. there no multiple users configuration)

XP machine was configured by the XP NW Connection wizard using the option "connect through a residential gateway", and here are the connections that resulted:
<a href="http://www.djlong.net/debug/nw_connections.jpg">Network connections </a>

I have TCP/IP, NetBIOS and IPX/SPX enabled.  Here are the XP machine configuration settings:
<a href="http://www.djlong.net/debug/nwbridgeprops0.jpg">Bridge Properties</a>
<a href="http://www.djlong.net/debug/nwbridgeprops1.jpg">Bridge Properties</a>

Here are the TCP/IP properties settings:
<a href="http://www.djlong.net/debug/tcp_props0.jpg">Bridge Properties</a>
<a href="http://www.djlong.net/debug/tcp_props1.jpg">Bridge Properties</a>

Here are the TCP/IP Advanced Properties:
<a href="http://www.djlong.net/debug/tcp_adv0.jpg">Bridge Properties</a>
<a href="http://www.djlong.net/debug/tcp_adv1.jpg">Bridge Properties</a>
<a href="http://www.djlong.net/debug/tcp_adv2.jpg">Bridge Properties</a>

From the other posting, I also added LMHosts files on both machines, and edited the browser registry key to value of AUTO, from FALSE.

TIA for any assistance in this.

0
Comment
Question by:djlong
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
  • 4
17 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 8154285
Start with all the basics. I think you need to remove the bridge and use only the Local Area Connection

Some information networking XP to non-XP. XP has a whole new setup and must be adjusted to be backward compatible.
=============
Differences between Windows XP Home and Professional
http://www.wown.info/j_helmig/wxpdifs.htm
=============
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, PC-cillin AV, VPN Client such as Raptor Mobile, Cisco VPN, et al.
---------------
Next, check your XP networking setup:
http://support.chartermi.net/support/pipeline/windows/winxp_network.html
Although this link says to set netbios over tcp/ip to "default", follow the instructions below...
---------------
Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
----------------
For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)
----------------
Client for Microsoft Networks needs to be the primary network logon for all other machines
----------------
All machines are in the same workgroup
----------------

Enable NetBios over TCP/IP in WIndows XP
==========
Step 1: Turn On NetBIOS over TCP/IP
Click Start, click Control Panel, and then click Network and Internet Connections.
Click Network Connections.
Right-click Local Area Connection, and then click Properties.
Click Internet Protocol (TCP/IP), and then click Properties.
Click the General tab, and then click Advanced.
Click the WINS tab.
Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
Click Close to close the Local Area Connection Properties dialog box.
Close the Network Connections window.

Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.

References:
http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
http://support.microsoft.com/default.aspx?scid=kb;en-us;314366
http://support.microsoft.com/default.aspx?scid=kb;en-us;315267
http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm
http://www.michna.com/kb/WxNetwork.htm
0
 

Author Comment

by:djlong
ID: 8154427
Thanks for the help.

I double checked all factors given and they are already in place as outlined in your list.

The only factor not specificaly addressed in your listing is the Bridge. Maybe removing it is correct, but before I do remove it, I have to say that while I'm not sure exactly what it does:

a) nothing worked before the Bridge was put place

b) the XP nw wizard set that up when I chose the option "my computer connects to the internet through a gateway" - which seems to be the only appropriate choice given my setup

c) the 98 machine WAS visible at one point from the XP machine, and the Bridge was in place at that time.

so, I THINK it is more likely some other element than the presence of the Bridge, but then, I could also be wrong on that.  Think I need more data there

c)
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8154547
I do belive that it has to do with the bridge setup.
See if you're situation is close to this one:
http://www.lpt.com/windowsnetworking/regusers/wxpbrdge.htm

If not, then the bridge is not needed and probably getting in the way.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:djlong
ID: 8154997
OK.  I removed the Bridge and both pcs are still able to get online, which was my primary concern for not removing it.  So you and you may be right that it was not needed.  Thanks for that link which was useful in getting the overall concept more clearly

As to the main problem I am having, though, there is no change.  The 98 machine can still see the XP machine, and the XP machine can only see itself.

I can still ping the 98 machine from XP machine by name or IP address, yet Net View gives "system error 53" (if I use the 98's name), and "system error 51" (if I use its IP address).  So, somehow, although the physical connection is intact at the adapter level, the XP machine can't locate the path to 98 machine?

Everything else it per the first list of things you posted, including ensuring that "NetBIOS over TCP/IP" is still enabled in the properties of the LAN adapter.

Its weird, because the first time I enabled NetBios over TCP/IP, it worked.  Now that makes no difference. So it would seem that the variable is in that level of operation, and that is outside my current familiarity.

Any other ideas?  
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8155129
One more idea. Open Device Manager, at the top menu, View/show hidden devices.
In the device view, under network adapters, see how many of those listed you can delete. If possible, delete them all, then reboot the system and let it re-find the proper drivers for the current adapters.
0
 

Author Comment

by:djlong
ID: 8155699
Holy cripes ! That was a really bad idea !  

I did it, and found out afterwards that I couldn't access anything, and I had no idea what had been changed.  

Couldn't see any place that any setting was changed, yet I couldn't get on the web or ping the 98 machine or the router.  

Lucky for me, there was a recent restore point (yesterday AM) that I could go to.  Whew !  Next time, I'll remember to make a new restore point before trying anything that foolish.

in any case, the hidden devices were the PCI Ethernet adapter and all the "WAN Miniport" connections.  The Ethernet deleted, but none of the WAN miniport ones would.

I guess it was pretty foolish to delete adapters when they were communicating just fine.  With ping's possible it just doesn't seem to me it is in the adapter / hardware level.  There has got to be some stupidly simple answer to WHY enabling NetBIOS over TCP/IP first handled it, but now doesn't.  

Anyway, I'm back to where I was when I started, at least: the internet access works on both machines, without the Bridge, and I can ping the 98 machine, but can't see it or access any shares on it from the XP machine.

Learned quite a bit so far today. That's for sure!

0
 
LVL 41

Accepted Solution

by:
stevenlewis earned 200 total points
ID: 8156220
try un-enabling NetBIOS over tcp, reboot and re-enable
may just jar it back
on the XP box type net view (from a prompt) and post the results here
also on the XP box
Run local security policy editor from control panel admin tools and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled and make sure guest account is enabled


0
 

Author Comment

by:djlong
ID: 8156437
My friends, thank you for the willing help.  
I think I cracked this bad boy just before I received the last comment.   The answer was, as I feared, too simple for my untrained eye:

I didn't actually have NetBEUI installed.  (see the earlier screen shots, http://www.djlong.net/debug/nwbridgeprops0.jpg
http://www.djlong.net/debug/nwbridgeprops1.jpg )
 
XP does not in fact support or install NetBEUI.  
I had installed some other thing called
"NWLink IPX/SPX/NetBios Compatible Transport Protocol"

In case this helps anyone else, I found this out by finally ending up here:
http://www.wown.info/j_helmig/winxpnet.htm
Now that I have installed the actual NetBEUI from the XP CDRom, it works just fine.

stevenlewis:
your comment included to check local security policy.
When I tried to run that, I got this message:

     Snap-in failed to initalize.
     name: group policy
     CLSID: {8FC0b734-A0E1-11D1-A7D3-0000F87571E3}

This was going to be my next two-day web search, but maybe you can tell me how to fix that? I had more than one snap-in give me that message. How do I re-install them?

Doug Long
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8156459
If TCP/IP was working correctly, you would not need Netbeui. You definately don't need IPX/SPX.
0
 

Author Comment

by:djlong
ID: 8156549
Well, as with the Bridge, you may be right, but I don't know enough to make that determination.  Here is my present undrstanding. Correct me if I'm off the mark:

The router is providing internet access to each machine, and that requires TCP/IP, obviously.

The two machines (and later a third) are able to share resources locally as long as "file and printer sharing" is enabled.

Enabling "File and Printer Sharing" over TCP/IP is a potential security problem.

Using IPX/SPX or NetBEUI is the recommended work around to having file and printer sharing enabled over TCP/IP.

Doug
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 8162705
Hmmm, not sure about the Siemens router (I have a d-link)
but mine has a firewall, I use rcp for file and printer sharing, and the firewall prevents unauthorized access. I also use Zone alarm (It may be overkill but...)
and I have no security problems
I don't allow ports 137, 138, or 139 to be open (from the outside)
you can use www.grc.com to test your sheilds and probe your ports
I agree with lrmoore, NetBEUI isn't needed if tcp is working correctly (bound to the NAC, and configured correctly, etc)
But also feel NetBEUI is a no brainer (no config needed) and on a small network can be a viable solution (not recommended on a large network, it is a very chatty protocol, relying on broadcasts)
Even with NetBEUI, security is still recommended
go to www.grc.com and run the tests, and check the firewall on your router, and get ZA to be sure!
0
 

Author Comment

by:djlong
ID: 8164544
Thanks for clarifying. I always like to find out that I don't know what I don't know.  

The Siemens does have a NAT. And a firewall I think (only had this thing up for thre days ...)  I will definitely check Gibson's site tomorrow.

As for a opting for the no brainer over getting TCP/IP configured correctly, I gotta say I have precious brain left after the table banging I've been doing the last 48 hours over the thing. Plus I'm outta time for it.

But I do have to get back to that lack of MMC snap-ins shortly.  Any direction there?  The msc file is there. How do you (re)install it?
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 8177681
the first thing to do is check event viewer, and see if there are any error messages (services didn't start, etc)
I was only able to find one reference to snap in failed to itialize
http://www.dbforums.com/t392706.html
0
 

Author Comment

by:djlong
ID: 8177812
steven - thanks for even looking.  I found it myself late last night.  Here is a link to the post, in case it ever come up for anyone else you try to help:

http://www.annoyances.org/exec/forum/winxp/r1046272010

0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 8177861
Glad you got it!
I was golfing yesterday and didn't get in here :~)
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes you might need to configure routing based not only on destination IP address, but also on a combination of destination IP address (or hostname) and destination port number. I will describe a method how to accomplish this with free tools. …
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question