xp and 98 not seeing each other

I'm trying to set up a little network at work. My PC is on XP pro, the other is 98 (if i remember right). I can get the 98 pc to see my XP but it can't access anything, it just shows the computer. But i can't even open the network workgroup browser on the XP machine. I've tried it with IP addresses being automatically assigned and static. neither works.

I'm using a hub, but i ge the same problem when i'm trying to do it with just a crossover cable and no hub.

I've done a fair bit of networking(just simple stuff mainly) but i can't figure this out, i know it's going to be something simple, it always is.

Can anyone help?
stu.
LVL 1
sturobinson17Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lrmooreCommented:
Some information networking XP to non-XP. XP has a whole new setup and must be adjusted to be backward compatible.
=============
Differences between Windows XP Home and Professional
http://www.wown.info/j_helmig/wxpdifs.htm
=============
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, PC-cillin AV, VPN Client such as Raptor Mobile, Cisco VPN, et al.
---------------
Next, check your XP networking setup:
http://support.chartermi.net/support/pipeline/windows/winxp_network.html
Although this link says to set netbios over tcp/ip to "default", follow the instructions below...
---------------
Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
----------------
For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)
----------------
Client for Microsoft Networks needs to be the primary network logon for all other machines
----------------
All machines are in the same workgroup
----------------

Enable NetBios over TCP/IP in WIndows XP
==========
Step 1: Turn On NetBIOS over TCP/IP
Click Start, click Control Panel, and then click Network and Internet Connections.
Click Network Connections.
Right-click Local Area Connection, and then click Properties.
Click Internet Protocol (TCP/IP), and then click Properties.
Click the General tab, and then click Advanced.
Click the WINS tab.
Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
Click Close to close the Local Area Connection Properties dialog box.
Close the Network Connections window.

Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.

References:
http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
http://support.microsoft.com/default.aspx?scid=kb;en-us;314366
http://support.microsoft.com/default.aspx?scid=kb;en-us;315267
http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm
http://www.michna.com/kb/WxNetwork.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stevenlewisCommented:
Hi Stu, long time no see :~)
in addition to the great advice above
Run local security policy editor from control panel admin tools and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled and make sure guest account is enabled


0
stevenlewisCommented:
BTW, you did share womething on the XP box?
you can disable simplified sharing
http://www.microsoft.com/windowsxp/expertzone/tips/september/stevens1.asp
and share individual folders
0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

doulike2420Commented:
The easiest way to solve your problem is to first get on the XP machine and then go through the Network Setup Wizard.

To start the Network Setup Wizard, click Start, click Control Panel, click Network and Internet Connections, and then click Network Connections. Under Network Tasks(on the left), click Setup a Small or Home Office Network.

***I am assuming that you will be using the hub.***

Steps:
1. Click next.
2. Click next.
3. Select OTHER, then click next.
4. Select first option (connect through HUB) and then click next.
5. Click next through the next screen or two
6. When you come to the screen that asks to give the computer a name and description:  Give it a name and description and then click next
7. On the next screen, select a workgroup name(just use the default name (MSHOME)
8. Click next on the next screen to confirm your decisions.
9. After a short delay, put a floppy disk in the floppy disk drive, then Select CREATE A NETWORK SETUP DISK and then click next.
10. Click Finish.
**********************************************************
11. TAKE THE DISK FROM THE DRIVE, PUT IT IN THE WINDOWS 98 MACHINE AND REPEAT THE STEPS ABOVE.(the ONLY DIFFERENCE is the computer NAME and DESCRIPTION.  Use the SAME WORKGROUP (MSHOME) for both machines.)


0
tommcseCommented:
Hi Stu,

On your XP machine, enable the guest account and set a password for it.  This should allow the 98 machine to browse the XP machine.
0
CleanupPingCommented:
sturobinson17:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
lrmooreCommented:
RECOMMENDATION: Points awarded to: lrmoore
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.