?
Solved

can't telnet to self in Mandrake 8.1

Posted on 2003-03-18
5
Medium Priority
?
273 Views
Last Modified: 2010-03-18
I met same question but not be solved today.
I use the Mandrake 8.1 and install full package.
And I had checked the /etc/services and I ping the localhost
have no any problem.
I can ftp to localhost
  can ping to localhost
but telnet get the answer 'telnet: Unable to connect to remote host: Connection refused'

I had entered 'ALL:LOCAL' and 'ALL:127.0.0.1'
in the file '/etc/hosts.allow'

I try my best but can't telnet to self.
0
Comment
Question by:delphifeng
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 

Expert Comment

by:suguinha
ID: 8160941
I don't know if mandrake uses inetd or xinetd.
If it's inetd, edit the /etc/inetd.conf file and uncomment (IE: Remove the # char) the telnet line. Then, killall -HUP inetd.

This is because telnet is not currently enabled on your system.

If mandrake uses xinetd, well, I've never used it, but there's a configuration file related to the telnet service. It's probably marked as "not enabled" in it (Open it with a text editor, If I'm not mistaken, /etc/xinetd/telnet or something like this, I've only seen this one time when one friend was working with his RedRat machine). After finding this out, restart xinetd as well.

You don't have to add that line to hosts.allow. If there's nothing in hosts.deny, then by default it's all authorized.

0
 
LVL 19

Accepted Solution

by:
Gabriel Orozco earned 100 total points
ID: 8169730
mandrake does not install a telnet daemon by default.
you need to surf the cd's and then install from there, or use the mandrake tool to download the server from ftp :)

once installed, you need to go to /etc/xinetd and edit the file telnet.d or something called telnet, and change where it says "disable = yes" to "disable = no" and restart xinetd:  killall -HUP xinetd

and that's it.
0
 

Expert Comment

by:CleanupPing
ID: 9077636
delphifeng:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question