?
Solved

Small Business Server, Linksys DSL Router, DHCP, Can't see both server and router

Posted on 2003-03-18
8
Medium Priority
?
203 Views
Last Modified: 2010-03-18
Running Small Business Server 2000 w/ 5 clients. I have assigned (on Server 2000) workstations with ip addresses in the range of 192.168.16.0 thru 255. When I use a static IP address on a workstation, I am able to access the server, but not the internet thru the router. If I change to "obtain IP address automatically" I am able to access the internet, but not the server (when Router is set to DHCP enabled).
I have tried disabling the DHCP on the router and assigning the router an ip address in the range listed with Active Directory on the Server, but obviosly still having problems.
My question is: Do I need to somehow inform the server of the router, and if so how?

Any help would be appreciated.

Thanks,

John
0
Comment
Question by:johnwoodeye
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 1

Expert Comment

by:vwinkeler
ID: 8162792
First off I think you have 2 differnt subnet going
192.168.16.0 server
192.168.1.0 Linksys

I think the eazy thing to do is put the Server at an address in the Linksys subnet ( 192.168.1.2) and leave the Linkys to hand out DHCP address ( I'm thinking they start at 192.168.1.100)
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 8162807
I suggest using static ip's, but you must enter all of the correct info
default gateway (the linksys router LAN interface)
and dns server entries (use the ones p[rovided by your isp, or less preferably, the linksys LAN interface, by default it is 192.168.1.1 but if you have changed it, then use the value you changed it to)
0
 
LVL 1

Expert Comment

by:GrindCrusher
ID: 8162988
A couple of solutions here.
1. Disable DHCP on the router and let your server handle the DHCP

2. Disable DHCP on the server and let the router handle it

3. Disable DHCP on both and configure each machine to have static address as stevenlewis

vwinkeler  is correct about 2 differant networks .

I would opt for option #2 for the less administrative overhead required when any changes are required

0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 

Author Comment

by:johnwoodeye
ID: 8163285
Thanks for the help. I disabled DHCP on the server, enabled DHCP on the router, and configured the routers' LAN IP address to 192.168.16.41 which is within the range we set on the server. I can now access web and server as long as workstation is set to obtain IP and DNS automatically.

Settings I attempted on workstation:

IP address:   192.168.16.31
subnet mask:  255.255.255.0
default gateway: (left blank and tried listed Gateway on router)

DNS server address: 192.168.16.2 (server address)
alternate :  left blank

Can you tell me what I'm missing? I would like to have static ip addresses for each workstation.

 




0
 
LVL 41

Accepted Solution

by:
stevenlewis earned 600 total points
ID: 8163329
>192.168.16.2 (server address)
should be either the isp's dns server or your router interface
preferably your isp's dns
definately not your servers ip (unless youhave setup dns correctly

>default gateway: (left blank and tried listed Gateway on router)
you need to define a gateway (the door out of the network to the internet) and it must be the router interface
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 8163344
to test use ping from a prompt
from a prompt on the host type
ping 127.0.0.1
ping 192.168.0.x Where x is the ip of the client)
ping the router
ping 206.169.61.185
ping www.experts-exchange.com
please post the results here


0
 

Author Comment

by:johnwoodeye
ID: 8163544
Unfortunately I don't understand everything about the network (that will improve over time, I guess), but I changed the default gateway on the workstation to the same IP address as the LAN IP address on the router and listed DNS servers as the same as those listed on router.

Happily it all seems to work. Thanks tons.  

John
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 8163600
>Unfortunately I don't understand everything about the network (that will improve over time, I guess
I'm sure it will! We all started out not knowing much, and learning along the way.
Glad we could help
Steve
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Greetings, Experts! First let me state that this website is top notch. I thoroughly enjoy the community that is shared here; those seeking help and those willing to sacrifice their time to help. It is fantastic. I am writing this article at th…
Resolve DNS query failed errors for Exchange
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question