My Exchange Server Is not allowing my ColdFusionMX server to "RELAY"

First of all, I am a one man show, where I've tried to learn a little about everything--enough to be dangerous. Here is the basic network setup.  Please understand that it may seem very disorganized, but this is as best as I've been able to pull from the texts.  I

ENVIROMENT:

Connection Type:   DSL
Router:            Lyknsys
                   Static IP address on router 64.45.237.68 (Static IP)
                   Router Internal Address  192.168.1.1      
                   Host: dns           Domain: heloc.net
                   Forwards:
                   Port  25 Requests    to 192.168.1.2
                   Port 110 Requests    to 192.168.1.2
                   Port  53 Requests    to 192.168.1.2
                   Port  80 Requests    to 192.168.1.2

                   (I have a good connection to the Net)

Internal Network:

SERVER1            NT4.0SP6  Backoffice Running the following services
ISLAND             Private IP 192.168.1.2 The Public IP is on the Router's NIC.
                   IIS 4.0
                   DNS--I handle primary DNS and Granitecanyon.Com does my secondary
                                      Network Properties > DNS Tab > HostName:ISLAND   Domain: Island1
                                      > DNS Service Search: 64.45.237.68 (Static IP)
                                                            204.117.214.10(Assigend by ISP)
                                                            119.2.252.10 (Assigned by ISP)
                                      > Protocol Tab > TCP/IP > 192.168.1.2
                                                                255.255.255.0    
                                                             GW 192.168.1.1

                                      > Advanced Tab > IP Addresses: 192.168.1.2
                                                                     
                   Exchange Server 5.5 (I'm able to receive and send email on my workstations)
                   CANNOT RELAY ANYTHING FROM THE COLDFUSION SERVER.
                   


SERVER2            NT4.1SP6  Backoffice Running the following Services
CASASNUEVAS        Private IP 192.168.1.15
                   IIS 4.0
                   ColdFusion MX
                   Network Properties > DNS Tab Same as SERVER 1 with the exeption of Int. IP 192.168.1.15.

WORSTATION1        WIN98
                   Private IP 192.168.10.10

I'd like to fine tune the setting on the Exchange server so that I can use the ColdFusion Server on SERVER2.  If you see any other setting that may be wrong, please let me know...


jcperez2000Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David WilhoitSenior Consultant, ExchangeCommented:
I assume you have an internet mail connector? In that case you can use the IMC to allow .15 to relay mail for you, on the routing tab of the IMC properties. If you need an exact answer, tell me what the settings on the IMC are currently. Also, service pack level.

d
0
jcperez2000Author Commented:
Thank You For Responding.

Is there a difference between an "Internet Mail Connector" and the "Internet Mail Service?"

ColdFusion Executes well, however, the messages are not getting relayed.  The Mail Log states 550 Relaying is Prohibite...

Here are my settings. Thanks again.

Exchange 5.5 SP4

IMS > Internet Mail Tab
      Attachement Outboud > MIME Checked
      Character Sets > MIME >Western European (ISO8859-1)
                   NO MIME > Western European (ISO8859-1)
      Specify By Emai Domain > heloc.net
                               fairtaxusa.org
                               islandfinancial.com
                               southchase.com
                               lanuevazona.com
                               labuya.com
                               plenallanzo.com
                               islandrealty.net
   
      Enable Message Tracking > Checked
      Advanced Options: Have Not messed with so should be
                        default.

IMS > Connections Tab
      Transfer Mode > Inbound & Outbound
                    > Advanced > Default
      Message Delivery > USE DNS
      Specify by Email Domain > HELOC.NET
                                ISLANDREALTY>NET
                                ISLANDFINANCIAL.COM
      Accept Connections > From Any Host
                         Specify by host > NONE

IMS > Routing Tab
      Reroute Incoming SMPT > Checked
                            > Routing
                              charlieperez.com
                              fairataxusa.org
                              heloc.net
                              islandfinancial.com
                              mail.heloc.net
      Routing Restrictions > Host & Clients with Ip Checked
                             192.168.1.15  SM 255.255.255.0

                           > Hose & Clients with Internal..
                             192.168.1.15



     

     

0
David WilhoitSenior Consultant, ExchangeCommented:
No, no difference between the 2

Now,on the routing tab, you don't need the FQDN of your mail server, take it out.

Do you have a host record for the coldfusion server on your primary DNS? If not, sset up a hosts file on the exchange server for .15, see what happens. And restart the IMC

d
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jcperez2000Author Commented:
How do I set up a Host file on the server for .15?  My primary dns is dns.heloc.net.  Do you mean for me to add an "A" record under heloc.net looking at 192.168.1.15?

Thansk Again..
0
David WilhoitSenior Consultant, ExchangeCommented:
Well, you wouldn't want a primary DNS server to have a private IP address listed, so unless you want the world to know about .15 by way of an external address, the cleanest way would be to open the hosts file on exchange, and add a line for .15. I still don't know if this will resolve your issue, but it's wortha try. Truthfully, still trying to figure out why it isn't working, and DNS is all I can see.

D
0
jcperez2000Author Commented:
This is what I did.  I took out dns.heloc.net from the primary and in fact I unchecked Reroute Incoming SMPT. I also deleted all the entries from >Reroute Incoming SMPT.  

The moment I did this VOILA...It worked.  However, I'm concerened that I may have opened a public relay. How could I check for this...

Thanks for your help..
0
jcperez2000Author Commented:
Yes I was right. Now, I can use the SMPT service from the CF server, however, someone has already discovered my open relay....I went back and closed it for now.

Is there a way arround this. When I turn on my website, it will be heavily dependant in "send to friend" deals and mass email as well.

Right now all of my domains with the exception of the mail server are listed on the IMS > Rounting > Reroute Incoming SMTP mail.

For now I've checked off Rounting > Routing Restrictions > Host and Clients with this Ip addreses, and this has closed the Open Relay....

I tried adding the IP address of the CF machine as a host under "Host and Clients connecting to these internal addreses" and it doesn't work.

Any suggestions.......Thanks
0
David WilhoitSenior Consultant, ExchangeCommented:
What service pack is Exchange on right now? This is weird, the steps you've taken should work.
0
jcperez2000Author Commented:
SP4
0
jcperez2000Author Commented:
WIll you be able to help out on this issue. The only way to allow for the hosts to use the SMTP is by CHECKING
Routing Restrictions > Host and Clients Connecting to these internal addresses (Which displays the internal addresses of my PCs)

Now the moment I check this box, I can send SMTP mail. However, the queue fills up with over 2000 outbount pending messages....and my Outlook client goes crazy, with "unable to deliver outbound message...."

Evidently someone is attempting to relay through my service...

Thanks againg for your continued assistance...

Charlie Perez
0
jcperez2000Author Commented:
Good Morning,

I haven't yet heard from you.  Will you be able to assist me with this question?

Thank You,

Charlie
0
David WilhoitSenior Consultant, ExchangeCommented:
Hi,

Sorry, your post got lost among the many messages I had. Refresh me...tell me what your EXACT IMC setup looks like now. What firewall, what ports are open, what email client are you using. This shouldn't be as difficult as it's been so far.

D
0
David WilhoitSenior Consultant, ExchangeCommented:
" Port  53 Requests    to 192.168.1.2"

close that! unless you are running a public DNS server, this is unnecessary, and it's a big security hole.

d
0
jcperez2000Author Commented:
I run a DNS server....on port 53.  I use a Lynksys BFSR41 Router.  Whatever, firewall protection is offerec by this box is all I have. I use Outlook 2000 as the email client.

Thank You.

PS. The basic problem is that I can't get Exchange to allow the internal addresses to relay.

Why do I need to do this.  I run a ColdFusion Serve which uses a CFMAIL tag. It looks for SMTP on the mail server.  I use this tag to send out mail from our TELL A FRIED links on the website and send out Mass emails as well..

0
David WilhoitSenior Consultant, ExchangeCommented:
So DNS is running on the server, publicly? I'd be willing to bet that the Exchange server and the ColdFusion server are a bit confused. Try pointing either server to another DNS server besides yours. Since all services are running on 1 box (DNS and Exchange) resolution might be a bit skewed.

"220 island.island1 ESMTP Server (Microsoft Exchange Internet Mail Service 5.5.26
55.55) ready"---There is a later version of this, I stronly suggest you go and get it from MS.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.