Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 180
  • Last Modified:

Login problems to exchange 2000

Server: WIN2K Server+SP3, Excange2000+SP2, Active Directory Service, latest NAV Virusdefinition with daily scan
Client: Win98/ ME with office 97/2000, latest NAV Virusdefinition with daily scan
Problem: I have one file+internal mail server(exchange 2K). Client PCs can login to the network without any problems. SOME of our Win98/ME clients have problems to login via Outlook97/2000 to exchange2K. After around 10 times entering the password, the small number of Win98/ME client computers are able to login to the exchange2k. As I said only some Win98/ME clients have this problem, most Win98/ME clients are working well. Any idea what the reason for this problem is?
0
vpc_bits
Asked:
vpc_bits
  • 8
  • 5
  • 2
  • +1
1 Solution
 
slink9Commented:
Have you tried uninstall/eraser97/reinstall?  Have you tried Repair on the O2k clients?
0
 
vpc_bitsAuthor Commented:
That is what we are just trying to uninstall/reinstall. Problem is not only with 97. Repair on the O2K clients, we already tried it, but it was not helpful. Thanks
0
 
slink9Commented:
Using Eraserxx between the uninstall/reinstall will remove files that uninstall misses - http://support.microsoft.com/default.aspx?scid=kb;en-us;239938
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
TordanCommented:
Just a possibility.

I had a similar issue to this once, and it turned out to be a DNS issue.

Exchange 2000 requires a properly configured DNS and Active directory. Failer to have these will cause clients to fail to auth properly.
0
 
vpc_bitsAuthor Commented:
Thanks,
we will try.
0
 
vpc_bitsAuthor Commented:
We tried it, but we still have the same problem.
Thanks
0
 
vpc_bitsAuthor Commented:
Hello Tordan,
it seems, that we have the problem which you descriped.
How have you fixed it?

In our case:
Exchange server name: vpchn (IP 197.0.0.3)
Client IP: 197.0.0.66
ping from client: ping vpchn -> 197.0.0.66 instead 197.0.0.3

All Win98 PCs who have this problem has the same result, ping resolution is to client IP address, what is wrong. All other 98 PCs are working well and are able to make a name resolution from vpchn to 197.0.0.3.

We also reinstalled (format c:) the PC, but same problem.

Thanks  
0
 
TordanCommented:
hmmmm. ok lots of stuff to cover here.
I don't know much about how your network is configured so if i tell you the obvious don't be offended. /grin

first is: are you using static IP addresses or a DHCP server?

you can do this with static addresses but it is not the 'recommended method' i am going to explain this from a DHCP configuration point of view. If you MUST use static addresses adjust accordingly.

!!!! you can only have one dhcp server on your network at a time. the first possibility is that you might have two. If you have another server or a router (from your ISP maybe?) it might be providing DHCP services. this alone could be causing the issue. Check this first.  Your new Exchange 2000 server would have DHCP server on by default, check there too.

! you may choose any one device to provide dhcp services but the 'recommended method' is to use your win2000 server.
If you choose this, then see here:
HOW TO: Install and Configure a DHCP Server in an Active Directory Domain in Windows 2000
http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3B300429

!!! Now you must make sure that the DNS server is on and properly configured on your win2000 server. It is installed by default. for exchange to work properly you MUST run the dns server on your win2000 server. (or some other win2000 server in your active directory forest... but we won't go there now) this support doc should cover most of the bases:
HOW TO: Configure DNS in a New Workgroup Environment in Windows 2000
http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3B301197

++ assuming that you domain name is foobar.com - i personally recommend that you set your active directory to be called something like foobar.local - however if you server is already vpchn.foobar.com then leave it that way.

++ if you ISP provides you DNS services then add those servers to the 'forwarders' section of your dns server.

+ set the servers IP stack to use only itself as a dns server.

+ try surfing.
+ ping vpchn from the server command line. it should work.

! for windows 98 to resolve properly it also recommended that you have WINS correctly setup and configured. (this is fairly easy. mostly just make sure that it is On and running on your win2000 server.

! setup your dhcp server to provide your win2000 server as primary dns server, and primary wins server (if you only have one server then provide the same address as both primary and secondary wins). It should also provide your router (not itself - unless your server is your network router -VERY NOT recommended-) as the default route.

! set the win98 workstations to use dhcp if they are not already.

! start menu/run/winipcfg - do a release all, then a renew all. the reboot the workstation. make sure that you can properly ping vpchn

at this point your outlooks should work.
at very least you will have a nice network. /grin.

i hope that all helps.
Tordan
0
 
vpc_bitsAuthor Commented:
Hello Tordan,

first thank you very much for your detail information. We checked all our installation & configuration again. It is like you already wrote. We have 1 DHCP & DNS Server, ...

We fixed the problem by disabling DNS on all 10 "problem PCs (Win98 & ME)". It is working now, but we still don't understand why.
We will investigate and try to understand what the reason is.

We close the problem request.

Thank you very much
0
 
TordanCommented:
weird,
what exactly do you mean by 'disabling DNS'? that might give me a clue as to where you problem lies.

also if you accept one of my answers i will get my 50 points. /grin

Thanks,
Tordan
0
 
vpc_bitsAuthor Commented:
We disabled DNS at the problem PCs under the TCP/IP configuration of each problem PC (TCP/IP, properties).

Thanks
0
 
vpc_bitsAuthor Commented:
I am closing this question

Thanks
0
 
SpideyModCommented:
A request for a refund has been made.  Experts, you have 72 hours to object.  

SpideyMod
Community Support Moderator @Experts Exchange
0
 
TordanCommented:
I certainly do object. I pointed out the problem quite nicely i think.

from the thread i think that it is evident that the old win9x boxes had a hard coded and incorrect DNS setting and by turning that off he was then receiving the correct setting from dhcp.

0
 
SpideyModCommented:
Here's what I am doing in this case.  I am awarding the answer to Tordan because technically the information provided should have solved the problem, but other factors on the machines may have blocked the resolution.  I have also given vpc_bits the 50 question points back as the resolution used was to turn off DHCP and was posted here.  Hopefully this satisfies everybody.

SpideyMod
Community Support Moderator @Experts Exchange
0
 
TordanCommented:
Works for me.
/grin
0
 
vpc_bitsAuthor Commented:
Thanks
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 8
  • 5
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now