Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Can't get apache running!

Posted on 2003-03-19
9
Medium Priority
?
206 Views
Last Modified: 2010-03-04
Got this error help!

I'm trying to install a apache server, but it aint going like it should, I'm behind a router and that was giving me problems with Apache 1.3 (i think) now I got 2.0.44 and I get this error :\ huh!

local ip: 192.168.2.100

Local host: co135213-a.almel1.ov.home.nl (217.120.228.241) (grabbed it from mirc)

OS: win xp

the first error:
[Wed Mar 19 09:49:59 2003] [error] (OS 2)Het systeem kan het opgegeven bestand n
iet vinden.  : No installed service named "Apache".
Note the errors or messages above, and press the <ESC> key to exit.  22...

Could someone plz explain how I can get apache running, plz!


hope i gave you guys enough info, if i didnt plz say
0
Comment
Question by:PhReAk
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 51

Expert Comment

by:ahoffmann
ID: 8165314
think the error message is self-explanating (at least for people understanding dutch:)
  There is no apache service running, 'cause it is not installed (or cannot be found).
Probably you missed a reboot?
0
 
LVL 15

Expert Comment

by:samri
ID: 8165772
ahoffmann, I know you knew spanish... how about dutch :)

PhReak; or maybe you need to redo the installation.  Btw, on my machine; the service name for Apache2 would be "Apache2".  (my machine is Win2K,  and I think it should not be too much different in XP too).

try running "services.msc" and see if "Apache2" is listed in the service list.  If not, restart the machine, and/or redo installation.

0
 

Author Comment

by:PhReAk
ID: 8165898
Het systeem kan het opgegeven bestand n
iet vinden.  

--> system can't find the given file

I installed it for like 5 times in a row and it ain't in the services list, (services.msc) apache2 or apache. (even after rebooting...)
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 15

Expert Comment

by:samri
ID: 8165989
Which version that you use; EXE or MSI package?

I would recommend that you use the MSI packages (as I do have some problem with EXE (or ZIP) in the past).

http://nagoya.apache.org/mirror/httpd/binaries/win32/apache_2.0.44-win32-x86-no_ssl.exe
http://nagoya.apache.org/mirror/httpd/binaries/win32/apache_2.0.44-win32-x86-no_ssl.msi

If you already tried the MSI?  Then, check if you had IIS or PWS installed.  Try to remove them.  And remove apache as well, make sure your XP is clean, reboot, and reinstalled (again!).  And make sure you had Administrator rights.

chhers
0
 

Author Comment

by:PhReAk
ID: 8166570
I'm not using IIS but I'm not familiar with PWS..what's that? (feels really dumb) and I'm using the MSI packages
0
 
LVL 3

Accepted Solution

by:
WysG earned 750 total points
ID: 8167223
I've gotten a similar error
It was due to another Service to run on port 80.

If you got Oracle 9i installed, it install Apache witch run on port 80 by default

So check in the service list, a service that could use port 80 (Any Webserver like IIS ou Personal Web Server(PWS) use 80 as port by default

Find this service, stop it, and reinstaller Apache, it should install the service without any problem
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 8167808
 netstat -an
will tell you which ports are used
  net start
will tell you which services are running

samri, don't know dutch, just can understand a bit 'cause it's close to german (or vice versa;)
0
 
LVL 15

Expert Comment

by:samri
ID: 8167981
ahoffmann - I salute you for being multilangual - english, spanish, german, and who knows what next.  Btw, do you know "bahasa malaysia" by any chance -- it's close to indonesian language (slightly better :)).
:)
-------

PhReAk, another option to know what is (already) running on port 80, you could try to do a "telnet localhost 80", and type in anything, then hit enter (return key) twice, then you will get some error message -- which normally tells you what server it is (in most cases).

However, AFAIK, Apache will still install, and the service will get registered, even though "somebody" already took port 80 -- it's just cannot run since it (apache) cannot bind to port 80.

What we have here it, the service itself is not installed (registered).

-- perhaps we need to get M$ Experts here.
0
 

Author Comment

by:PhReAk
ID: 8183519
Thnx for your help! :) was the port 80 err.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my time as an SEO for the last 2 years and in the questions I have assisted with on here I have always seen the need to redirect from non-www urls to their www versions. For instance redirecting http://domain.com (http://domain.com) to http…
In Solr 4.0 it is possible to atomically (or partially) update individual fields in a document. This article will show the operations possible for atomic updating as well as setting up your Solr instance to be able to perform the actions. One major …
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
Suggested Courses
Course of the Month11 days, 17 hours left to enroll

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question