Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 268
  • Last Modified:

8139too corrupted module

Hi,

I have a Linux Redhat 8.0 machine with two ethernet interfaces.  I have Realtek 8139C+ cards, and was interested in changing the link speed to 10mb Full Duplex.

I downloaded a diag. application from http://www.scyld.com/diag/index.html (rlt8139.c) and went ahead changing the link speed with the -A flag.  This did not work, as it was still in half-duplex afterwards (I played with a bit, with --force, etc), so I figured it may not support the C+ model of the card.  I obtained another copy of 8139C+ drivers for Linux Kernel 2.4, which had only been tested upto 2.4.2, but went ahead and overwrote the existing object module (in /lib/modules/kernel/drivers/net/), and attempted to install this module.  

Unfortunately not only did this fail, but all interfaces where not accessable anymore through ifconfig.  I have brought this machine offline temporarily until I resolve this problem.  When I attempt to re-add the interfaces it complains with the errmsg, "error fetching interface information, device not found", also upon bootup it does not correctly load 8139too module correctly anymore when bringing up the 1st ethernet interface.

I would like to retrieve my original copy of the 8139too module.  This is a barebones installation so does not have any kernel source, however I do have access to a few other Redhat 8.0 machines with 8139too.c in kernel/drivers/net within /usr/src.  How would I be able to compile this to overwrite the module in /lib/modules/kernel/drivers/net/, so everything works fine once again (ie: like from scratch).  It is possible to set some runtime options such as speed, correct?  How would I also be able to do this so it uses 10mb Full Duplex straight away?  

Any information or assistance would be greatly appreciated.

Thanks and Regards.  

0
excile
Asked:
excile
  • 2
1 Solution
 
SpurgeonCommented:
Make sure you are running the same kernel on all machines, try to compile new modules
--------------------------
cd /usr/src/linux-2.4.*
make menuconfig
--------------------------

now turn on te module in the kernel config...

now type:

make clean modules

and search for the module ...

put it on a floppy and transfer it to your machine. now it should be working again :)

good luck,

spurgeon

0
 
excileAuthor Commented:
excellent, thankyou for your help.

cheers :)
0
 
SpurgeonCommented:
you're welcome
0
 
CleanupPingCommented:
excile:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now