?
Solved

Patchadd failed

Posted on 2003-03-19
12
Medium Priority
?
794 Views
Last Modified: 2013-12-27

Hello!

I`v tried to install patch on Solaris8 with:
patchadd /path/to/patches/112396-02




action failed with error:
>>>>>>>>>>>>>>>>>>>>
Checking installed patches...
Verifying sufficient filesystem capacity (dry run method)...

Patch 112396-02 failed to install due to a failure produced by pkgadd.

See /var/sadm/patch/112396-02/log for details

Patchadd is terminating
<<<<<<<<<<<<<<<<<<<<




Looking at log, I find out, that there is problem with accessing some file:
>>>>>>>>>>>>>>>>>>>
This appears to be an attempt to install the same architecture and
version of a package which is already installed.  This installation
will attempt to overwrite this package.

/path/to/patches/112396-02/SUNWcsr/install/checkinstall: /path/to/patches/112396-02/SUNWcsr/install/checkinstall: cannot open
pkgadd: ERROR: checkinstall script did not complete successfully
Dryrun complete.
No changes were made to the system.
<<<<<<<<<<<<<<<<<<<

All files exists, so I don`t really understand, where is the problem?

Thanks in advance.

Btw, If i need to instal several patches, where one depends from other. Is there any efficient way, how to make them installing in proper order?
0
Comment
Question by:shifted
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
  • 2
  • +2
12 Comments
 
LVL 4

Expert Comment

by:Otetelisanu
ID: 8165652
1. You must root
2. Check you disk space df -k /
3. Check if the patch is insatlled.
0
 

Author Comment

by:shifted
ID: 8167400
*) Disk space is more than enough.

*) with "patchadd -p | grep 112396" no results were returned. So this package is not installed.
0
 

Author Comment

by:shifted
ID: 8167412
Interesting, that checkinstall calls himself. Maybe this is the problem?

/path/to/patches/112396-02/SUNWcsr/install/checkinstall: /path/to/patches/112396-02/SUNWcsr/install/checkinstall: cannot open
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:shifted
ID: 8167686
So the actual problem is, that installing everything I got error about "cannot open" on file ".../checkinstall"
Why it so? The file actually exists!

Any ideas?
0
 
LVL 18

Expert Comment

by:liddler
ID: 8167705
Don't know whether it helps, but the readme says

Problem Description:

This revision was created to enable installation of the
        108528-14 patch that depends on this patch for installation.
        No additional bug fixes were integrated into this patch.

This is the kernal patch, - are you running a much later kernel patch?
0
 
LVL 18

Expert Comment

by:liddler
ID: 8168017
just re-installed it (with patchadd -u) and got no problems at all on system:
SunOS 5.8 Generic_108528-18 sun4u sparc SUNW,Ultra-5_10
0
 

Author Comment

by:shifted
ID: 8169035
Unfortunately patchadd -u didn`t helped.

I starting to think, that there is some different problem than only patchadd. Why it is pkgadd, who produces a problem? Maybe som system environment have some misconfigurations?
0
 
LVL 3

Accepted Solution

by:
jwelter earned 750 total points
ID: 8169084
Does showrev -p | grep 112396 indicate any rev of the patch?

I always cd to the parent directory of the patch, and do patchadd -d patch_number, FYI.

Is the patch unbundled/untarred/uncompressed?

Maybe download it again -did you get a signed or regualr patch?

JW

0
 
LVL 3

Expert Comment

by:jwelter
ID: 8170346
correction: cd to patch parent & patchadd patch_number
0
 

Author Comment

by:shifted
ID: 8172083
I didn`t find theoretical base of solution, but everythig goes well, when I copied patches from deep internal catalogue of my home directory (/export/home/myaccount/long/path/patches) to /var/spool/patches an as I copyying as a root - ownership of that patch although changed to root (it was downloaded as ordinary user account).

Thanks anyway.
0
 

Expert Comment

by:gCGBD
ID: 8182934
I've run into this a few times now this week.  Let me report on some of the things I've tried.  I've probably
installed patches on 30 or so boxes in the last two weeks.  I've had patches fail with this error on 3 so far.

On the first two that failed I was successful at installing the patch by simply moving it to a different partition.  (from /export to /) Some partitions seemed to work, and others didn't.  I don't know why (yet).

I have boxes which should be identical, and it will work on one, and not the other.  Same patch sets, same packages, the file systems were even constructed the same way.

I noticed this first with patches for Solaris 8, on Veritas Volume Managed slices off of the local disk.  It was broken on a vxfs filesystem but worked on a ufs filesystem.  The Veritas patches seem to be up to date.

Just a couple hours ago I ran into the same problem on a Solaris 7 box with DiskSuite.  I tried installing off of a non-DiskSuite managed partition, to no avail.

You can edit /usr/sbin/patchadd, look for the line which says "pkgadd_DEBUG="no"" and change it to a yes.

It doesn't really tell you anything more.

I agree that the force and the no backup options don't help with patchadd.

truss -f patchadd <patchnumber>  does reveal a little more
interesting data.  Grepping for checkinstall I get this:
# grep checkinstall truss.out
22794:  access("7_Recommended/106541-23/FJSVhea/install/checkinstall", 0) = 0
22800:  open64("7_Recommended/106541-23/FJSVhea/install/checkinstall", O_RDONLY) Err#13 EACCES

So - interestingly the parent process can access the file, but the child process fails.

I ran some scripts to create and destroy and open files in the same directory, set them in an infinite loop - and never had an error.

The problem is consistent on the boxes where it is broken.
The problem never appears on the boxes where it isn't.

Googling I came across your post hoping to find an answer.  I'm glad I'm not the only one battling this issue though.

0
 

Expert Comment

by:gCGBD
ID: 8183005
Doh!
The next link down in my google search showed me the answer.  From 1998 on the SunManagers list...

"The path to the patch has to be accessible to the user 'Nobody'".  

A quick check and one of the upper trees had no x bit for the world.  I changed it, and voila!  It works.

Here was the next link down:
http://www.sunmanagers.org/archives/1998/0273.html
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Let's say you need to move the data of a file system from one partition to another. This generally involves dismounting the file system, backing it up to tapes, and restoring it to a new partition. You may also copy the file system from one place to…
My previous tech tip, Installing the Solaris OS From the Flash Archive On a Tape (http://www.experts-exchange.com/articles/OS/Unix/Solaris/Installing-the-Solaris-OS-From-the-Flash-Archive-on-a-Tape.html), discussed installing the Solaris Operating S…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Suggested Courses
Course of the Month13 days, 17 hours left to enroll

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question