?
Solved

Implement a T1 failover network

Posted on 2003-03-19
7
Medium Priority
?
352 Views
Last Modified: 2010-04-17
Situation:
We currently added a T1 (Verizon) to our existing partial T1 line (UUNET). We planned to use the Verizon as our primary connection and UUNET as a failover/fault-tolerance  backup.

hardware:
Cisco 3620 with 2 DSU units.
1 Sonicwall firewall

    Verizon       UUNET
        |                       |
        |                       |
        |                       |          
     +----------------------+      
     |      Cisco 3620     |         1
     +----------------------+      
                   |
                   |
                   |
             +------+
             |switch|                    2
             +------+            
                   |
                   |  
            +--------------+            
            |   Firewall   |           3
            +--------------+              
            |                 |
            |                 |
+-------------------+   +----------------------+        
 |LAN (Static IP)|   |DMZ (Web server)|  4
+-------------------+   +-----------------------+      



Question:
What will be the easiest solution to this?
0
Comment
Question by:Qris
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 480 total points
ID: 8173357
BGP between you and the two ISP's, each isp advertising only default.
You will need to register with ARIN and get a bgp AS number.

An alternative would be a product such as Fatpipes' Warp box:

http://www.fatpipeinc.com/warp/index.htm
0
 

Author Comment

by:Qris
ID: 8174138
Using BGP will require major equipment upgrades, is it possible to achieve my objectives without getting into the BGP scene?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8174923
Not with two different ISP's. You don't need full internet route tables, which certainly would require hardware upgrade, if the ISP will cooperate, then you only need then to give you a default, and broadcast your subnet through their external BGP. This does not require hardware upgrades.

The other alternative to BGP is something like the Warp/Extreme boxes from Fatpipes
0
The Ideal Solution for Multi-Display Applications

Check out ATEN’s VS1912 12-Port DP Video Wall Media Player at InfoComm 2017. Kerri describes how easy it is to design creative video walls in asymmetric layouts and schedule detailed playlists ahead of time with its advanced scheduling feature.

 

Author Comment

by:Qris
ID: 8182627
Is there any configurations needed in the cisco router? Thanks.

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8183388
For which solution:
For BGP, yes.
http://www.cisco.com/warp/public/459/40.html#3

For Fatpipes, I'm not sure how that works.
0
 

Author Comment

by:Qris
ID: 8195895
After reading the articles it come to my interpretation that the BGP is for a load sharing network, instead of the fail over network that we needed. My initial thought was something simple like the HSRP service on the CISCO router, am I missing something here?
0
 
LVL 3

Expert Comment

by:RouterDude
ID: 8198431
There is a solution that will work on a 2500 router, just set one up in fact. The one side setups up a static route with 0.0.0.0 0.0.0.0 ip route to the primary T1, then the other ISP can have the subnets from the other ISP in their BGP filter list provided you get them an LOA from your BGP upstream to add their IP's to the filter. The backup T1 can run EIGRP provided the backup ISP is running a Cisco network. On the EIGRP network redistribute static and connected should be added as well as a route-map defaultroute with disables the default route to the other ISP. You will only need a /30 for your serial interface for the backup T1.

Ex:

Interface Serial0
IP address 10.10.10.2 255.255.255.252
encaps ppp
Backup interface Serial1
Backup delay 30 60
!
Interface Serial1
ip address 192.168.1.2 255.255.255.252
encaps ppp
!
router eigrp 10101
redistribute connected
reditribute static route-map defaultroute
network 10.10.10.0
network 192.168.1.0
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 Serial0
!
access-list 50 deny 0.0.0.0
access-list 50 permit any
!
route-map defaultroute permit 10
 match ip address 50

Basically interface serial1 will be down acting as a backup, and in the event serial0 goes down, for 30 seconds serial1 wil come up and bring up eigrp neighbor 192.168.1.1 and start routing over that network. When Serial0 comes back up, serial 1 will shut down and EIGRP will drop and flush the routing table sending traffic back over the first T1 which has the default route pointing to it.

0

Featured Post

Supports up to 4K resolution!

The VS192 2-Port 4K DisplayPort Splitter is perfect for anyone who needs to send one source of DisplayPort high definition video to two or four DisplayPort displays. The VS192 can split and also expand DisplayPort audio/video signal on two or four DisplayPort monitors.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question