?
Solved

cocoon under oracle 9ias - xerces SAXParser not found

Posted on 2003-03-19
2
Medium Priority
?
334 Views
Last Modified: 2010-05-18
I am not sure if this is the correct forum to post this in.  If I am in error, please let me know.

My problem is this.  I have 9ias R2 running on NT.  I have set up Cocoon2 in my OC4J_home.  When I run Cocoon, I get the error:  java.lang.ClassNotFoundException: org.apache.xerces.parsers.SAXParser.

I have read several posts, most of which say something like "start OC4J as follows..." and it gives a java -classpath statement that places the xerces.jar before the xmlparserv2.jar.  

The only problem with this is that I am using 9ias and cannot find the script to edit that has this command in it.  Under 9ias, I start oc4j with: dcmctl start -ct OC4J. I have tried everything I know, including editing the dcmctl.bat and putting xalan and xerces in there.  Nothing seems to work.

Does anyone have any idea how to make 9ias recognize the xalan and xerces jars?

Thanks.
0
Comment
Question by:cspearman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 9

Accepted Solution

by:
vzilka earned 2000 total points
ID: 8204880
Start your Oracle9iAS instance.
Open OEM in http://localhost:1810/emd
Go into the details window of the OC4J instance
Click on the server properties link (on the lower end of the screen)
Scroll the new window down.
Enter the command line parameters (the -classpath).
That's all.
0
 

Author Comment

by:cspearman
ID: 8239970
Thanks!  I am now getting an error that I am going to post as a different question.  Please look at it if you get a chance!
0

Featured Post

The Ideal Solution for Multi-Display Applications

Check out ATEN’s VS1912 12-Port DP Video Wall Media Player at InfoComm 2017. Kerri describes how easy it is to design creative video walls in asymmetric layouts and schedule detailed playlists ahead of time with its advanced scheduling feature.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Convert websphere application server default chained Certificates from 1024 to 2048 keysize or higher size and also you can change signatureAlgorithm . Please make sure Websphere Application Server fixpack 7.0.0.23 or Above. The following steps a…
Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question