Export selected tables?

I am using Oracle 8, with exp80 and trying to export only a few selected
tables. From the Windows XP or Windows NT Dos prompt
I use exp80 Userid=user/pass then with asks Tables I put a t
and it begins asking for tables names and this works fine.
I then tried to run by a batch job with the following.
exp80 sysytem/mang fromuser=user touser=user file=c:\select.dmp tables=(
table1, table2, table3) log=c:\select.log full=n buffer=4096.
I get ORA-06402 error NETCMN invalid driver designated.
What could I be doing wrong?
thom_lsbAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bkowalskiCommented:
This is the explanation for that error message:

Error:  ORA 6402  Text:   NETCMN:  error receiving break message  Cause:  The SQL*Net driver detected that its server has unexpectedly exited. Action: Check the network operating system and resubmit the connect string.

But there is a problem with your export.  You do not use fromuser or touser in an export, take those out and it should run o.k.
0
thom_lsbAuthor Commented:
What do you mean by server has unexpectedly excite.
What should I use instead of fromuser & touser?
Thanks for your response.
0
bkowalskiCommented:
The error message indicates that possibly your server was not available. Are you sure the server was up when you ran the batch job? Does it run at night, did you test it during the day?

You don't use anything instead of fromuser, touser, take them out of your command line statement:

exp80 system/manager file=c:\select.dmp tables=(table1,
table2, table3) log=c:\select.log full=n buffer=4096
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

thom_lsbAuthor Commented:
Yes the server is available, I did export form DOS command
and it worked but batch won't.
You mean i don't need a user name and password?
Thanks again for your response..
0
bkowalskiCommented:
The username and password is system/manager in this scenario, those are still there.  The fromuser and touser parameters are for import, not export, so I've taken them out.

This is what I would do. Put all parameters in a paramter file, for example select.par, which would look like this:

buffer=4096
file=c:\select.dmp
full=n
log=c:\select.log
tables=(table1, table2, table3)
userid=system/manager

And then your command line would be simple:

exp80 parfile=select.par
or
exp80 parfile=c:\select.par

or whatever the path might be.
0
bkowalskiCommented:
If batch still won't work, try using the connect string in your user parm:

userid=system/manager@testdb

where testdb is a connect string in your tnsnames file.
0
thom_lsbAuthor Commented:
Niether of these work.
I'm open to anything.
Thanks,
0
DanielztCommented:
try this:

 exp80 user/pass@service_name file=table_dump.dmp tables=table_a,table_b,...  log=table_dump.log

you need to find service name from your tnsnames.ora.




0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
thom_lsbAuthor Commented:
This worked at the DOS command line and I also
made a batch file with that in it and it worked.
0
thom_lsbAuthor Commented:
It worked at DOS command line and I made
a batch file and it also worked.
Thanks for your quick respones and excellent suggestions.
Ed
0
bkowalskiCommented:
Didn't I say to use a connect string in my post 03/19/2003 12:12PM PST???
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.