?
Solved

Lilo problems.  Possibly from UDMA.

Posted on 2003-03-19
6
Medium Priority
?
283 Views
Last Modified: 2013-12-15
I have an A7V266-E board from Asus, with onboard Promise UltraDMA 100.  I
have 2 HDs installed.  The first one, (hde) is my drive with Win XP, and my
second one (hdg) is my linux (Slackware 8.1) drive.  I followed a dual booting guide exactly (to
dual boot using ntloader using dd to copy the boot sector), and lilo only gets to L, and then loops 01.  
In fact, the only way I can get into the system is to boot from the CD.  
I edited my lilo.conf, and added lba32, but still no fix.  Linux can see the
drives fine once I boot from CD.

The drive that contains XP, and a copy of the linux boot sector, is FAT32
formatted, so no blaming of NTFS.

Here is a copy of my lilo.conf:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
lba32
append="hdc=ide-scsi"
boot = /dev/hdg1
map=/boot/map
install=/boot/boot.b
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# Normal VGA console
vga = normal
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hdg1
  label = Linux
  read-only
# Linux bootable partition config ends
0
Comment
Question by:ganvar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 2

Accepted Solution

by:
haydes007 earned 225 total points
ID: 8182068
NTFS? Why would I blame NTFS? LILO and NTFS coexist peacefully on my machine. If NTLDR boot method is not working for you, you can either put LILO into the MBR of the first hard drive on the primary controller or just use GRUB(better option). I never had much success with NTLDR loading Linux but perhaps another epert can help in that area if you so choose.
0
 
LVL 3

Expert Comment

by:droswell
ID: 8205084
Agreed. Make a small /boot partition on the primary disk and install grub there.
-Dan
0
 

Expert Comment

by:CleanupPing
ID: 9079532
ganvar:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 10040257
Problem solved? anyway here is the info about nt loader with linux http://www.tldp.org/HOWTO/Linux+NT-Loader.html and here is the linux boot loader info for your reference http://www.syrlug.org/contrib/boot-loaders.html
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses
Course of the Month9 days, 17 hours left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question