Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 649
  • Last Modified:

installation CD booting problem in Alpha server

OpenBSD is most closely related to FreeBSD, so I am posting it here since there isn't exactly a forum for FreeBSD and FreeBSD isn't Unix.

I currently have a Digital Server 5000 Model 5305 6533A. The processor in the machine is Digital Alpha 21164. There is 384MB RAM on this machine. Windows NT 4.0 Server was previously installed on this machine.

Now, I am trying to install FreeBSD 5 on it. I read the documentation on how to setup FreeBSD on the machine and it says that I first need to go to SRM mode (as opposed to be in the AlphaBIOS mode) and boot into the FreeBSD CD-ROM from there.

I first went to the Alpha setup menu by pressing F2. From there, I pressed F6 for Advanced Menu. I pressed <TAB> a few times until I came to Console Selection. I can choose between Windows NT Console (AlphaBIOS), OpenVMS (SRM) and Digital Unix Console (SRM). So, I chose Digital Unix Console (SRM) and then when I restart the machine, it will boot to this prompt.

After that, in order to boot from the FreeBSD CD-ROM, according to http://people.freebsd.org/~bmah/rel...tion-alpha.html , I should type 'boot xxxx' where xxxx is the SRM name of the CD-ROM. To find out what is the SRM name of the disks in the machine, I should type 'show device'.

So, I typed 'show device'. The output that I got was:
polling ncr0 (NCR 53C810) slot 1, bus 0 PCI, hose 1 SCSI Bus ID 7
polling floppy0 (FLOPPY) PCEB - XBUS hose 0
dva0.0.0.1000.0 DVA0 RX23
polling dac0 (Mylex DAC960) slot 2, bus 0 PCI, hose 0
dra0.0.0.2.0 DRA0 2 Member RAID 0
polling ncr1 (NCR 53C875) slot 0, bus 2 PCI, hose 0 SCSI Bus ID 7
polling ncr2 (NCR 53C875) slot 1, bus 2 PCI, hose 0 SCSI Bus ID 7
polling tulip (DECchip 21140 - AA) slot 2, bus 2, hose 0
ewa0.0.0.2002.0 00-06-2B-00-15-A9 Twisted Pair



There was no mention of any CD-ROM, so I was thinking that it was not detected. Well, I even typed in 'boot dva0' and it accesses the floppy drive, meaning dva0 refers to the floppy drive.

To make sure that my Alpha server detects the CD-ROM drive in the first place, I typed 'set OS_type NT' to set it back to AlphaBIOS and restarted the machine to see what are the devices that are initialized. And one of the devices that I could see initialized was the CD-ROM drive. It'll say
"Initializing AIC78XX #0 ...
Device CD-ROM SCSI ID:4 DEC RRD46 (C) DEC 1337"

That means the machine sees the CD-ROM drive. If that's the case, why is it that when I type 'show device' I don't see any mention of the CD-ROM drive?

I hope you can help me with this problem, because I would really like to install FreeBSD on this Digital Alpha machine of mine.

Thank you.


Kingsley
0
kenviro
Asked:
kenviro
1 Solution
 
jacksunCommented:
FreeBSD 5.0 iso images on the ftp site had a problem related to bootable cd's. I downloaded the iso, burned it and couldn't get it to install from the cd. After hours of messing around we figured out their was a problem with the cd drive after booting, it seems to drop the device.
Go to the freebsd site (freebsd.org), get the alpha floppies, and do the install over ftp, or download the 4.7 iso's and burn them.
0
 
charlie250Commented:
The answer is in your transcribing of the AlphaBIOS info.
Specifically the "Initializing AIC78XX#0"
This means you have an Adaptec card in your machine that
is hooked to the CDROM. Adaptec cards are NOT seen by SRM
in most alphas though I'm told the newer DS10's and others
do support some. AlphaBios supports this card fine though.
Your choices are:
1. Network BOOT
2. Floppy Boot
3. dd the miniroot to another hard disk and boot from that.
4. Replace the scsi card with a supported one.
Note: FreeBSD will probably support the card fine so as long as your hard disks are connected to a card that can be seen by srm, you can still use the card..
Personally, I'd go floppy boot.

Charles
0
 
gheistCommented:
Install any supported (eg different) boot scsi controller like symbios
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
kenviroAuthor Commented:
Assuming I go for the floppy boot, here's what I think I should do. According to FreeBSD/alpha 5.0-RELEASE Installation Instructions at http://jamesthornton.com/freebsd/5.0/installation-alpha.html, it says:

"Get two blank, freshly formatted floppies and image copy kern.flp onto one and mfsroot.flp onto the other. These images are not DOS files. You cannot simply copy them to a DOS or UFS floppy as regular files, you need to ``image'' copy them to the floppy with fdimage.exe under DOS.  

I assume that after I've made my set of floppy disk, I will boot the Alpha with the disks that I've made. During the booting process, there'll be an instruction to put in the FreeBSD ISOs that I've made into the CD-ROM drive and the installation will continue from there.

Am I right to say that?
0
 
gheistCommented:
Why you browse around internet once you have full instructions here:
ftp://ftp.freebsd.org/pub/FreeBSD/releases/alpha/5.0-RELEASE/INSTALL.HTM
You are right!, you need to switch or reprogram system firmware to Tru64/VMS mode if ir was running NT,
check out NetBSD/alpha too for different piece of documentation if you run into undescribed problems
(these manuals are intended to be read while installing not before and then bringing them back from memory)
Most valuable excersise would be installing FreeBSD/i386 and then much more will be clear about setup path
0
 
charlie250Commented:
Yes, kenviro you are correct. After the os boots from floppy it should be able to see the cdrom on the Adaptec
card.
I'll mention another issue specific to the 5305 that I ran into.
Does your machine have a symbios scsi/nic combo card?
Your transcribing seems to indicate so.
If that's the case you may have problems with FreeBSD.
My 5305 used to hang when this card was probed as it seems
to have limited *BSD support in general.

I resolved that issue for myself by removing the card and replacing with a Qlogic 1040 and DE500.
However, it is worth trying the install anyway to see how you go.
Also note, you have a NCR53c810 SCSI controller on board on your machine.
You could move your cdrom from the Adaptec to that controller and if the Adaptec card is not integrated, you could remove it totally.
So to summarise:
1. Move the cdrom from the adaptec card to the onboard ncr scsi (it should be a 50 pin connector on the base board).
2. Boot to srm and do a show dev and you should then be able to see the cdrom.
3. Try an install bearing in mind you may have problems with the scsi/nic combo card that may also be in your system.
Regards
Charles
0
 
sherisalamiCommented:
I had a similar problem.  My CD ROM ( ISO image) was bootable but it was not an exact copy of freeBSD. In that case if u had an error booting, it could mean that your cd rom is not bootable ( in which case u have to burn another cd as an ISO image not a regular file) or it is corrupted and you will only be trying to install something tha will never install! Best thing to do after burning your cd is to do a checksum, make sure it burnt correctly.  Best of luck
0
 
gheistCommented:
What I said in short Charlie250 explained in detail.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now