?
Solved

Windows XP locks up every minute for 3 seconds

Posted on 2003-03-19
10
Medium Priority
?
395 Views
Last Modified: 2007-12-19
I have a strange problem which may be hardware related or it may be O/S related but it is definitely storage related so I am posting it here. I have an ASUS P4B533-E motherboard which supports RAID on 2 IDE buses. I recently changed the configuration of the disks on this Windows XP Pro machine so that there is one disk on the primary IDE (master), 1 disk on the Primary RAID (slave) and 2 disks on the Secondary RAID (1 master and 1 slave). The O/S is installed on the Primary IDE. I am experiencing a lockup of the computer about every minute for about 3 seconds. When I disable the RAID controller, this lockup disappears, however, I need the RAID controller to support the number of disks I have installed. This did not happen when all of the disks were on the RAID controller. Does anyone know if this is an known ASUS RAID controller problem or do I have a hardware problem?
0
Comment
Question by:miis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +4
10 Comments
 
LVL 1

Expert Comment

by:Covenant
ID: 8172447
Odd one this, there is nothing wrong in theory with the way you have set up the disks.

I would run disk test utility on all your drives just to eliminate the possibility that by conincidence when you changed your disk configuration one of the drives developed a fault.
Next try unplugging one disk at a time, then one channel at a time to see if an individual disk or channel is causing the problem.
Also check your IRQ list and see if the RAID controller is conflicting with any other devices.

Try this and let us know if it makes any difference.
0
 
LVL 1

Expert Comment

by:Covenant
ID: 8172450
Oh, btw, when you changed the system drive from the RAID controller to the onboard IDE, did you do a clean install or just swap it over?

0
 

Expert Comment

by:sathishkumar_sri
ID: 8172750
Try installing the BIOS update for your sytem board. You can download the BIOS update here:

http://www.imd.com.my/drivers.htm
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 4

Expert Comment

by:pratigan
ID: 8173424
Do you also rebuild the RAID configuration whne you changed around the cable setup.  
0
 
LVL 10

Expert Comment

by:pbarrette
ID: 8181817
Hi miis,

Why do you have the only device on the PrimaryRAID set as a Slave? Why not set it as master? Some controllers (and devices) don't like it if you only have 1 device and it isn't set as Master.

pb
0
 

Author Comment

by:miis
ID: 8188665
Sorry for the delay in responding but I have been rebuilding my PC and have been offline for a few days.

I checked the BIOS and I am running the latest version (1011) from the ASUS web site. I did a clean Windows install onto the C: drive which was the primary master on the normal IDE controller. I left the other 3 disks on the RAID controller as described. The problem persisted! Note that the RAID automatically reconfigured the remaining 3 disks as individual "arrays" and did not report any errors on bootup. The RAID WIndows utility reported that there wasn't a valid array, but I already knew this and at this point I did not want an array, just the IDE controller capability.

I then transferred one of the disks to the slave on the primary IDE and tried again. The problem was still there. I finally backed up the data on the remaining 2 disks and made then both master on the RAID controller and set them up as a RAID 0 (stripe) array. The lockup finally went away! It appears that the RAID controller must have a valid array on the Master devices otherwise it seems to check every minute for a valid configuration (at a low level) and locks up. This is, of course, an undocumented "feature" and the documentation does make any reference to it.

Thus, while the configuration is not exactly how I would have liked it, I have worked around the problem and now have all of my disks available.
0
 
LVL 32

Expert Comment

by:LucF
ID: 10304026
miis,
No comment has been added lately (322 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: Accept miis's answer http:#8188665 and Refund

Please leave any comments here within 4 days.

-- Please DO NOT accept this comment as an answer ! --

Thanks,

LucF
EE Cleanup Volunteer
0
 

Author Comment

by:miis
ID: 10304932
LucF,

I agree with your recommendation to close this TA and refund the points as I resolved it myself. What is the procedure to do this?

Regards,

Martin.
0
 
LVL 32

Expert Comment

by:LucF
ID: 10305112
A moderator will follow up within a week to do this for you.

For the next time this happens you can find the closing procedure for this kind of things here: http:/help.jsp#hi71
0
 

Accepted Solution

by:
SpazMODic earned 0 total points
ID: 10347861
PAQed, with points refunded (250)

SpazMODic
EE Moderator
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Create your own, high-performance VM backup appliance by installing NAKIVO Backup & Replication directly onto a Synology NAS!
The business world is becoming increasingly integrated with tech. It’s not just for a select few anymore — but what about if you have a small business? It may be easier than you think to integrate technology into your small business, and it’s likely…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question