• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 173
  • Last Modified:

Dial Up Networking in W98 SE

I have a peculiar problem on my PC running W98 Second Edition.
I used to be able to connect normally to my ISP using DialUp Networking.
Over the last few days I find that I am able to connect, but the connection terminates almost immediately. Reconnect, or even many attempts to dial up fresh results in the same effect.

The problem is the same with either ISDN or over normal telephone line.
The problem is the same even when I connect to different ISP's.

I am able to connect to my ISP via a diffferent machine.

The TCP/IP settings are exactly as per the ISP's recommendation.

By pure chance I have found a work around.
Under Network Neighbourhood -> Properties I select Dial up Adapter. I then select any one of the parameters listed there. I click on the parameter value, but do not change it.
I then say OK. Windows says Re-boot for changes to take effect.
I say No. After this my dial up works fine just like old.
This remains in force only till the next reboot. After every reboot, I need to do the work around and every time it works without fail.

I tried removiing and re-installing DUN as suggested by Microsoft Article 181599.
(I removed only the Dial up Adapter and not all Network components)

Any clues
Thanks in advance



0
ntaloref
Asked:
ntaloref
  • 3
  • 2
  • 2
  • +2
2 Solutions
 
slink9Commented:
You should also remove TCP/IP and reinstall it.  I believe that will fix it.
0
 
CrazyOneCommented:
Open Network Properties
Delete all protocols and everything else except the Network card
Click Apply
Close the Properties wincow
Click the Cancel button if it asks if you want to reboot

Start > Run regedit
backup registry first
delete the following keys

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VXD\Dhcp
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VXD\Dhcpoptions
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VXD\MSTCP
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VXD\Winsock2
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock2

Open Network Properties
Click ADD > PROTOCOL > Microsoft > TCPIP and this should Add Client for MS Networks

Reboot and be ready to insert your Win98 CD


The Crazy One
0
 
yoshi78Commented:
When you say you are able to connect to your ISP with a different machine...is it at a different location as well?  If not, the before mentioned answer should clear up everything.  If yes, then you need to try your computer somewhere else as the problems could exist in your phone lines.  Also, ISPs can have problems if you are running a connection with a different company other than your phone company.  A switching problem can occur between two phone companies, i've seen this personally on the job and it produces the effects you describe.  It's also unfixable unless the phone company chooses to correct the problem or you choose to go with an even more local service.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
sysandprogCommented:
Listening
0
 
ntalorefAuthor Commented:
Thanks everyone for a prompt response

The other computer which works is also from the same location, hence I concentrated on the remove and re-install.

I tried the solution from CrazyOne. I found some deviation in the procedure.

After I remove all the elements from Network properties (including dialup adapter) but keeping the network adapter and say OK, I am asked a path for copying Windows files before the reboot option.

I have tried both ways i.e giving the path and enabling files to be copied and also skipping this with Cancel.
In any case I have taken care to avoid a reboot.

Ater that I removed the registry entries. Re-installed TCP/IP (I also had to re-install Dial up adapter).
After "OK" I am again asked for the Path.
I specified the path and finally re-booted the PC.

Since I am not asked for the Windows CD after reboot is there something I have missed.

0
 
slink9Commented:
You are supposed to be asked for the Windows CD so it can update the components.
0
 
CrazyOneCommented:
>>>Re-installed TCP/IP (I also had to re-install Dial up adapter).


If you didn't get asked for the CD when you did this then Win98 used the setup files that were intalled on your machine instead.
0
 
slink9Commented:
Are you asked for the path to the Windows CD perhaps?
0
 
yoshi78Commented:
I would delete everything in the network folder including your client and start fresh. When you are asked for a path, I would give the path of your cd drive so you ensure the origional settings will load.  Afterward if it doesn't work, I may suggest a new modem.

ps I'm assuming that the other puter you tried was tried on the exact same line with the exact same cord.
0
 
ntalorefAuthor Commented:
Hello everyone,

Apologies for not having responded.
I had given up since nothing I tried worked. I was using my workaround since I did not want to re-install W98.

A reminder from the moderator inspired me to re-think.
As is usually the case after a break some solution flashes.

It had to do with the way the Protocols were 'Bound' to the adapters.


I am using NetBeuI for my Local Network and TCP/IP for my Dialup.
Hence I retain only the Bindings
NetBeuI -> Ethernet adapter
TCP/IP -> Dial-up adapter

I normally removed the other ones.
Today I re-instated the other two as well so I have
NetBeuI -> Ethernet adapter
NetBeuI -> Dial-up adapter
TCP/IP -> Dial-up adapter
TCP/IP -> Ethernet adapter.

And Presto! the thing started working

I have tried most of the suggestions and in a way i feel all of them led me upto resolving my problem

Thanks everyone and sorry for the delay.

regards
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 3
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now