• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 226
  • Last Modified:

php4apache2

Hi,
On windows 2000 I have installed apache_2.0.44-win32-x86-no-ssl and it was working fine befor adding the lines :
LoadModule php4_module <path to php4apache2.dll>
AddType application/x-httpd-php .php
to httpd.conf.

I have replaced php4apache2.dll with the latest one(28 KB), but still I am getting the same error when starting apache <<Cannot load <path to php4apache2.dll> into server: The specified module could not be found.
So, is there any soluton to enable php4 on apache2?

Thanks
0
last
Asked:
last
  • 5
  • 4
1 Solution
 
chidamzCommented:
Hi last,

  Do the following steps
Download & Install Apache 2.0.40
Download & Install PHP 4.2.2
Download the latest CVS snapshot of PHP at http://snaps.php.net/win32/
Extract the php4apache2.dll file from the sapi directory of the "latest" PHP folder and copy it over your existing php4apache2.dll in your existing PHP installation.
Add these lines to your Apache httpd.conf:
LoadModule php4_module c:\php\sapi\php4apache2.dll
AddType application/x-httpd-php .php .phtml .php3 .htm .inc
Do that, restart Apache.
Note: Make sure that you read the PHP install.txt on initially setting PHP up. [Editing php.ini, etc.]
IF you need latest version of php4apache2.dll mail me

E.chidambaram


0
 
lastAuthor Commented:
Hi chidamz,

But I already have installed apache 2.0.44 with PHP4.3.2RC1
So shall I remove them and install the old ones which you refered?
what is the exact story, is it a bug in the new PHPs (later than 4.2.2)?

Thanks a lot
0
 
chidamzCommented:
Hi last ,

  problem  mostly occurs due to Apache 2.0
if have older version of apache 1.3 it will work fine with
any new version of php

chidambaram
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
lastAuthor Commented:
Hi chidambaram
But I think older versions than apache 2.0 have security vulnerabilities.

Thanks
0
 
chidamzCommented:
Hi
 yes u r correct

 It is better to install apache2.0 and php 4.2.2
I have above configuration in my windows 2000 machine
It works fine.if you face any issues please let me know
I can help.



chidambaram
0
 
lastAuthor Commented:
Hi,

where I can find the win32 binaries for the same apache version that you have.?

Last
0
 
chidamzCommented:
0
 
lastAuthor Commented:
chidamz'
yes,php4.3.2rc1 works fine with apache2.0.42.
Please let me know if there is any chance to solve the problem by using latest apache.
Thanks alot.
0
 
chidamzCommented:
Hi last,
 I am trying with new apache version
i will let u know when i succeed

chidambaram
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now