?
Solved

Serial link between 2 cisco 2500's not working help

Posted on 2003-03-21
24
Medium Priority
?
399 Views
Last Modified: 2008-03-17
I have a 2503 and a 2507 connected via dce to dte crossover cable on s0. I also have each router with its on switch. The problem:
2503 = router1a
2507 = router1
On router1a I get the rip update and the router to router1's switch. I can not ping it. On router1 I do not get the rip update. The serial link says that it is up/up on both routers. What is my problem. I will include the sh run and sh int for both routers.

router1#sh run
Building configuration...

Current configuration : 1464 bytes
!
version 12.2
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router1
!
logging queue-limit 100
enable secret 5 $1$d16I$iegadzRtixfeGspgzCaKk1
enable password nate
!
ip subnet-zero
!
!
!
!
hub ether 0 1
 link-test
 auto-polarity
!
hub ether 0 2
 link-test
 auto-polarity
!
hub ether 0 3
 link-test
 auto-polarity
!
hub ether 0 4
 link-test
 auto-polarity
!
hub ether 0 5
 link-test
 auto-polarity
!
hub ether 0 6
 link-test
 auto-polarity
!
hub ether 0 7
 link-test
 auto-polarity
!
hub ether 0 8
 link-test
 auto-polarity
!
hub ether 0 9
 link-test
 auto-polarity
!
hub ether 0 10
 link-test
 auto-polarity
!
hub ether 0 11
 link-test
 auto-polarity
!
hub ether 0 12
 link-test
 auto-polarity
!
hub ether 0 13
 link-test
 auto-polarity
!
hub ether 0 14
 link-test
 auto-polarity
!
hub ether 0 15
 link-test
 auto-polarity
!
hub ether 0 16
 link-test
 auto-polarity
!
interface Ethernet0
 ip address 196.10.10.1 255.255.255.0
 no ip mroute-cache
 no cdp enable
 no mop enabled
!
interface Serial0
 bandwidth 1544
 ip address 201.10.10.1 255.255.255.0
 no ip mroute-cache
 no keepalive
 no cdp enable
!
interface Serial1
 no ip address
 no ip mroute-cache
 shutdown
 no cdp enable
!
router rip
 version 2
 network 196.10.10.0
 network 201.10.10.0
 no auto-summary
!
ip classless
ip http server
!
no cdp run
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password nate
 login
!
end
router1#sh int s0
Serial0 is up, line protocol is up
  Hardware is HD64570
  Internet address is 201.10.10.1/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive not set
  Last input never, output 00:10:07, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 4
  Queueing strategy: weighted fair
  Output queue: 125/1000/64/4 (size/max total/threshold/drops)
     Conversations  20/20/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     3 packets output, 98 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     2 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

router1#sh ip protocols
Routing Protocol is "rip"
  Sending updates every 30 seconds, next due in 22 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Ethernet0             2     2
    Serial0               2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    196.10.10.0
    201.10.10.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

router1a#sh run
Building configuration...

Current configuration : 716 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router1a
!
enable secret 5 $1$fEBC$V3hq0h5oI0YfCUAXPcav3.
enable password nate
!
!
!
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 195.10.10.1 255.255.255.0
!
interface Serial0
 bandwidth 1544
 ip address 201.10.10.2 255.255.255.0
 no keepalive
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router rip
 version 2
 network 195.10.10.0
 network 201.10.10.0
 no auto-summary
!
ip classless
ip http server
!
!
snmp-server community public RO
!
line con 0
line aux 0
line vty 0 4
 password nate
 login
!
end

router1a#sh int s0
Serial0 is up, line protocol is up
  Hardware is HD64570
  Internet address is 201.10.10.2/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive not set
  Last input never, output 00:14:11, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 48/1000/64/0 (size/max total/threshold/drops)
     Conversations  3/3/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     3 packets output, 329 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     4 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


router1a#sh ip pro
Routing Protocol is "rip"
  Sending updates every 30 seconds, next due in 11 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Ethernet0             2     2
    Serial0               2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    195.10.10.0
    201.10.10.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

0
Comment
Question by:liqid_ice
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
  • 6
  • +2
24 Comments
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8181175
I do not see a clock rate set on your serial interfaces, Did you set it?
0
 

Expert Comment

by:boulders
ID: 8181218
You will only need to set the clockrate on one of the serial interfaces for the link. Test the connectivity by enabling cdp and showing the cdp timers before testing ip pings. This will prove physical connectivity between the devices.
0
 

Author Comment

by:liqid_ice
ID: 8181245
It was set but I had the cables switched now it is set and still the same results. Router1a receives rip update router1 does not.
router1a#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    196.10.10.0/24 [120/1] via 201.10.10.1, 00:00:14, Serial0
C    195.10.10.0/24 is directly connected, Ethernet0
C    201.10.10.0/24 is directly connected, Serial0

router1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    196.10.10.0/24 is directly connected, Ethernet0
C    201.10.10.0/24 is directly connected, Serial0

0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 5

Expert Comment

by:rrhunt28
ID: 8181323
The order in which you plug the cable in does not matter.  Just plug it in, then set the clock rate on BOTH serial interfaces.  Now that said, only the DCE will take the clock rate, however, it is a good practive to set on both, because the router will let you know if it does not need it.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8181402
router#sho controller serial 0
This will show you which one has a DCE cable attached. That one only should have the clockrate command.

Turn cdp on on the serial interfaces, it is an indepsensible troubleshooting tool.
0
 

Expert Comment

by:boulders
ID: 8181491
Try setting up static routes to both networks pointing to each other to eliminate any rip issues.
0
 

Author Comment

by:liqid_ice
ID: 8181834
Ok here is something of intrest. I enabled cdp and did a sh cdp neighbor. The results were as follows. router1a showed router1 as a neighbor. Router1 did not show any neighbors. I can look at the led for the serial port. When I ping from router1 to router1a the led works. I still get failed ping. When I ping from router1a to router1 the led never works. I wonder if the serial port is in a one way mode or possibly a bad port on this router. What do ya'll think.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8181894
Possible. Start with some simple debugs.
debug cdp
debug rip
See what the output shows..
0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8181910
Maybe save your current config, and redo it with something very simple just to test with.
0
 

Author Comment

by:liqid_ice
ID: 8181928
Upon playing around here is what I found. I will up the points to 50 if someone can explain it to me. router1 = dce
router1a = dte I have only one way transmission from router1 to router1a.

I swapped dce and dte cables and enabled clock on router1a. Now everything works fine. I can ping and have rip updates for both routers. router1 = 2507 router1a =2503

This is just weird.
0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8181983
Might have been a bad cable connection, and when you swapped it you corrected it.  
0
 

Author Comment

by:liqid_ice
ID: 8182134
No that is not the case rrhunt. I have swapped the cables back and forth. The only way for it work is for the 2503 to be the DCE side and the 2507 to be the DTE side. When I do this it works. When I swap them it does not work.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8182164
Did your "clockrate" command follow the dce cable, get removed on the side with the dte, and it still only works one way?
0
 

Author Comment

by:liqid_ice
ID: 8182449
That is correct Irmoore. The clock rate follows the DCE and the DTE side will not take the command for clock rate. Like I said though. The only way for this to work is for the 2303 to have the DCE side and the 2507 to have the DTE side. I am confused as to why this is happening. I have stumped the CCNPS at my work with this. So I will up the points to 75 for info on what is the reason for this.
0
 

Author Comment

by:liqid_ice
ID: 8182477
That is correct Irmoore. The clock rate follows the DCE and the DTE side will not take the command for clock rate. Like I said though. The only way for this to work is for the 2303 to have the DCE side and the 2507 to have the DTE side. I am confused as to why this is happening. I have stumped the CCNPS at my work with this. So I will up the points to 75 for info on what is the reason for this.
0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8182486
I think he means to say, did you erase the serial and redo it, incase it kept the clockrate setting on the wrong side.  You are correct that it will not take it if you try and set it, but if it is already there, you might have problems.
0
 

Author Comment

by:liqid_ice
ID: 8182566
Yes I made sure that the clock rate was off on the DTE side.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8182582
What clockrate are you using?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8182598
What version IOS on each one?
0
 

Author Comment

by:liqid_ice
ID: 8182788
I am using 12.2.16. The clock rate is set at 56000
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8185252
Hmmmm.... got me stumped, too. Sorry. Could be bad serial interface on one...??
0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8196063
Did you make sure non of the pins where bent or missing on the cable, and the router?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8725649
liqid_ice,
No comment has been added lately (82 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: close (PAQ) / point Refund

Please leave any comments here within 7 days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Thanks,

lrmoore
EE Cleanup Volunteer
---------------------
If you feel that your question was not properly addressed, or that none of the comments received were appropriate answers,
please post comments here where a Moderator will see it.
0
 

Accepted Solution

by:
PashaMod earned 0 total points
ID: 8776669
Per recommendation,

PashaMod
Community Support Moderator @Experts Exchange
0

Featured Post

Turn your laptop into a mobile console!

The CV211 Laptop USB Console Adapter provides a direct Laptop-to-Computer connection for fast and easy remote desktop access with no software to install.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question