?
Solved

DHCP not assigning Addresses

Posted on 2003-03-21
4
Medium Priority
?
275 Views
Last Modified: 2010-03-18
i am using Redhat 8.0 as a gateway and can't get clients an IP address.

I am running up to date dhcpd, the service is started and configured. here is dhcpd.conf:

subnet x.x.x.x netmask 255.255.255.0 { }
 # where x.x.x.x is the static, public IP assigned to external interface eth0

ddns-update-style ad-hoc;
subnet 192.168.0.0 netmask 255.255.255.0 {
        range 192.168.0.2 192.168.0.60;
        default-lease-time 86400;
        max-lease-time 86400;
        get-lease-hostnames on;
        option routers 192.168.0.1;
        option ip-forwarding on;
        option broadcast-address 192.168.0.255;
        option subnet-mask 255.255.255.0;
        option domain-name-servers m.m.m.m, n.n.n.n;
 #where m and n represent ns1 and ns2

}


i added route 255.255.255.255 dev eth0
and route 255.255.255.255 dev eth1
tried both, either and neither.

current route tables looks like:
255.255.255.255 *               255.255.255.255 UH    0      0        0 eth1
255.255.255.255 *               255.255.255.255 UH    0      0        0 eth0
192.168.0.0     *               255.255.255.0   U     0      0        0 eth1
x.x.x.0   *               255.255.255.0   U     0      0        0 eth0
127.0.0.0       *               255.0.0.0       U     0      0        0 lo
default         rtr1080-07-vl18 0.0.0.0         UG    0      0        0 eth0


dhcpd daemon set at eth1

sooo if i assign an IP address to a client .... say 192.168.0.3 and input gw address 192.168.0.1 and name servers, there is no problem. But if I assign same gateway address and name servers but say get IP automatically, i get squat.I will post my iptables if you think they are necessary but the packets do get routed and the internet works as expected when an IP is assigned.

whats up?

thank you.
0
Comment
Question by:weazy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 2

Expert Comment

by:sir_giatay
ID: 8185688
subnet x.x.x.x netmask 255.255.255.0 {
       option routers x.x.x.y;
# your ISP gateway
 }

x.x.x.y is the gateway of eth0
0
 
LVL 12

Accepted Solution

by:
mburdick earned 750 total points
ID: 8188263
See my comments in http://www.experts-exchange.com/Networking/Linux_Networking/Q_20559199.html as there is a lot there that may be pertinent to you as well.
0
 

Author Comment

by:weazy
ID: 8205775
mburdick,

like the user you were trying to help I am able to get folks on the net when they insert the private network ip i.e. 192.168.0.x they connect no problem, use DHCP and it doesn't work. even after the changes you proposed.

ipconfig /all on the windows box shows the dhcp server address as 255.255.255.255 does that have a bearing?
0
 
LVL 12

Expert Comment

by:mburdick
ID: 8210018
On the RedHat system, open a command window and do "service iptables stop". Then, try to obtain a DHCP address from a client machine.

If you still can not get an address on the client machine, there is a problem with the configuration of your DHCP server. To make sure that the server is running, and on the proper interface, do the following:

ifconfig -a

Look through the list of interfaces and determine the name of the interface that is on the Inside of your network. Make sure that the interface has an IP address. Then do:

ps -ef |grep dhcpd

Make sure that it shows the same interface name as the interface on the Inside of your network.

##################

If you *can* get an address after turning off IPTABLES, you need to open the appropriate "hole" in the firewall to allow DHCP requests through.
0

Featured Post

Docker-Compose to Simplify Multi-Container Builds

Our veteran DevOps Author takes you through how to build a multi-container environment, managed with a single utility in order to simplify your deployments.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Suggested Courses
Course of the Month14 days, 3 hours left to enroll

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question