• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 920
  • Last Modified:

Excel E notation default

Is there any way to turn off that stupid default setting that takes a number (say, a Serial Number) like 368000007767 and changes it to 3.68E+11??  I know I can change the cell/colum format to number (with no decimal places) but the column SHOULD be a text field.  If I change it to Number (0 decimals) it looks okay...if I then change it to Text, it converts back to the E Notation.  

0
ccrashh
Asked:
ccrashh
1 Solution
 
MoliereCommented:
You can format the column as TEXT using the Format Cells command or you could use the formula =TEXT(A1,"0000000000")
This will cast the value as a text field.
0
 
sebastienmCommented:
that's messy... one more problem with the Text format i was not aware of.

Say you the data is in column A starting in A2
You could:
- in a new column say F, in F2:
    =TEXT(A2,"0")
- copy/paste this formula down along the data
- copy F / paste Special As Value over column A

Regards,
Sebastien
0
 
MoliereCommented:
The only problem with using =TEXT(A2,"0") concerns leading zeros. If you do not have a Serial numbers which start with zero, you are OK. Otherwise, you need to put as many zeros in your TEXT formula as you have digits.

Of course, doing the COPY and PASTE VALUES is a great idea.
0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 
Todd WedlakeCommented:
simply right click the cell you want or the rows and columns you want.  select format cells, go to custtom and enter a single #.

That will do the trick for you.

Todd
0
 
randomgurnCommented:
Enter a single quote right at the start of the cell.

So, for example if you have serial 32005345776576756, just type:

'32005345776576756

The ' won't appear in the worksheet, but it sort of tells Excel to not try to interpret what is in the cell.


Cheers,

gurn.
0
 
ccrashhAuthor Commented:
Everyone has some good points, but the issue is I am getting a CSV file I am importing into Excel.  When I do, it converts it automatically...and then I have to do the conversion.  I was hoping that there was an easy way to turn it off.

Thanks all.
0
 
Todd WedlakeCommented:
ok here's what I've done.  I created a CSV text file with some long numbers in it.

in Excel,
data, import external data, import data, select the file you want to import, select delimited, oem 437, start import at row 1, next, deselect tab, select comma, text qualifier set to none, next, at this point you'll notice that one of the columns is highlighted, select text for the column data format, and repeat this by selecting each column and setting the column data format to text, click finish, select the row you want to import to, select ok.

Imports perfectly!

Good luck
Todd
0
 
dbase118Commented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

Answered by twedlake
Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

dbase118
EE Cleanup Volunteer
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now